summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/zeromq/zeromq-3.2.5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/zeromq/zeromq-3.2.5.ebuild')
-rw-r--r--net-libs/zeromq/zeromq-3.2.5.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/net-libs/zeromq/zeromq-3.2.5.ebuild b/net-libs/zeromq/zeromq-3.2.5.ebuild
new file mode 100644
index 000000000000..5bf377533927
--- /dev/null
+++ b/net-libs/zeromq/zeromq-3.2.5.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools
+
+DESCRIPTION="ZeroMQ is a brokerless kernel"
+HOMEPAGE="http://www.zeromq.org/"
+SRC_URI="http://download.zeromq.org/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/3"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="pgm test static-libs elibc_glibc"
+
+DEPEND="
+ || ( sys-devel/gcc sys-devel/gcc-apple )
+ pgm? (
+ virtual/pkgconfig
+ >=net-libs/openpgm-5.2
+ )
+ elibc_glibc? ( sys-apps/util-linux )"
+RDEPEND=""
+
+src_prepare() {
+ einfo "Removing bundled OpenPGM library"
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.in || die
+ rm -r "${S}"/foreign/openpgm/libpgm* || die
+ # apply effective bit of below commit to fix compilation on Darwin
+ # https://github.com/zeromq/zeromq3-x/commit/400cbc208a768c4df5039f401dd2688eede6e1ca
+ sed -i -e '/strndup/d' tests/test_disconnect_inproc.cpp || die
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ use pgm && myconf="--with-system-pgm" || myconf="--without-pgm"
+ econf \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install() {
+ default
+ doman doc/*.[1-9]
+
+ # remove useless .la files
+ find "${ED}" -name '*.la' -delete || die
+
+ # remove useless .a (only for non static compilation)
+ if ! use static-libs; then
+ find "${ED}" -name '*.a' -delete || die
+ fi
+}