summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-04-26 10:30:59 -0400
committerCraig Andrews <candrews@gentoo.org>2023-04-26 10:32:13 -0400
commit136e31ebf3f1d59b0ad54f9bc3c50cdffc8f3a74 (patch)
tree1cca508e583ae051b3f156fe3420ddabcf3b1655 /net-libs
parentnet-libs/nghttp3: add 0.11.0 (diff)
downloadgentoo-136e31ebf3f1d59b0ad54f9bc3c50cdffc8f3a74.tar.gz
gentoo-136e31ebf3f1d59b0ad54f9bc3c50cdffc8f3a74.tar.bz2
gentoo-136e31ebf3f1d59b0ad54f9bc3c50cdffc8f3a74.zip
net-libs/nghttp3: drop 0.10.0
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nghttp3/Manifest1
-rw-r--r--net-libs/nghttp3/nghttp3-0.10.0.ebuild40
2 files changed, 0 insertions, 41 deletions
diff --git a/net-libs/nghttp3/Manifest b/net-libs/nghttp3/Manifest
index f94c60f6c841..f474123694de 100644
--- a/net-libs/nghttp3/Manifest
+++ b/net-libs/nghttp3/Manifest
@@ -1,2 +1 @@
-DIST nghttp3-0.10.0.tar.xz 367700 BLAKE2B 9f2a68d245d5b09eea3eeee1a3dd88fd1a88d44bb33e2d69fbf44d3e7a7edbd24de28ca974a64ee5351338cb790de2a6f6dba38a520a64196ec85264eebafbd3 SHA512 8854bb213c5ef5907260b087e192847d6a0be7421207092497842cf014026426f2e184ae2a1d5575774592d7e29dcbd509d06eff54c52b9aa7451d33b23a3270
DIST nghttp3-0.11.0.tar.xz 367392 BLAKE2B 908da41e168e83d82de7649051c66866682c58e93e3da6a2f4b85a1765b04ccbb06888df3e9b87b5cd6d1eb51d95af9bbb02955e47fde6194b169bb7ef78f756 SHA512 752adffcd5b8d26ea89e040597474e1b6d91a87a5feda445b637fd17255768e570570c0786984e3eaf36dac94df1f32659d9991d3bbf9a02b060c63aadb708fd
diff --git a/net-libs/nghttp3/nghttp3-0.10.0.ebuild b/net-libs/nghttp3/nghttp3-0.10.0.ebuild
deleted file mode 100644
index 719966f4eab6..000000000000
--- a/net-libs/nghttp3/nghttp3-0.10.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake-multilib
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/ngtcp2/nghttp3/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="~amd64 ~hppa"
-fi
-
-DESCRIPTION="HTTP/3 library written in C"
-HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
-
-LICENSE="MIT"
-SLOT="0/0"
-IUSE="static-libs test"
-
-BDEPEND="virtual/pkgconfig"
-DEPEND="test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
-RDEPEND=""
-RESTRICT="!test? ( test )"
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DENABLE_LIB_ONLY=ON
- -DENABLE_STATIC_LIB=$(usex static-libs)
- -DENABLE_EXAMPLES=OFF
- -DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
- )
- cmake_src_configure
-}
-
-multilib_src_test() {
- cmake_build check
-}