summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-11-29 21:35:40 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-11-29 21:35:56 +0300
commit1b7df8e49161d585c6bc90dbe7daf9f42126d918 (patch)
tree3022c0f4d545b1b6e121816d022b634c418c8832 /net-libs
parentnet-libs/libtorrent-rasterbar: mark stable (diff)
downloadgentoo-1b7df8e49161d585c6bc90dbe7daf9f42126d918.tar.gz
gentoo-1b7df8e49161d585c6bc90dbe7daf9f42126d918.tar.bz2
gentoo-1b7df8e49161d585c6bc90dbe7daf9f42126d918.zip
net-libs/libtorrent-rasterbar: Drop old
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libtorrent-rasterbar/Manifest1
-rw-r--r--net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.1.9.ebuild104
2 files changed, 0 insertions, 105 deletions
diff --git a/net-libs/libtorrent-rasterbar/Manifest b/net-libs/libtorrent-rasterbar/Manifest
index 40153ffeebb4..f4bd96395319 100644
--- a/net-libs/libtorrent-rasterbar/Manifest
+++ b/net-libs/libtorrent-rasterbar/Manifest
@@ -1,3 +1,2 @@
DIST libtorrent-rasterbar-1.1.10.tar.gz 3902542 BLAKE2B 3a78862ce2825c9da32ab38122db05c2816daa237559446a60702f562e971c5597210dfc2612235294cec3f60fa3de8cab3a0246887ac4779b01171a460f70f0 SHA512 414deeb9765bfb6072af5fa00ad836bfe3751622a80783ea84389e31355b342a4371f0dc195b2d27b154826e515b2e6063c8786f792afa347abba9caadaa5b2a
DIST libtorrent-rasterbar-1.1.11.tar.gz 4044314 BLAKE2B 96192ffdcb5bd1888307c874e2685314db9a99438337b0cb67ef317a2fe54b4a0e8e28fcdf34a1656a9abb69cc79f9bbda22cdedf1b8f2ba4f1b5488922c87b3 SHA512 1e0449406ea34b226033e3f54f719c5f2842043c7e54107e847050c67b1c5e9d2cb5a08fbf0e81c2c6e31eda6fe85c5ec0ff8ca47916c979894f778fc3313bb6
-DIST libtorrent-rasterbar-1.1.9.tar.gz 3903742 BLAKE2B a9f942e7d06e076dec98314bc44e8633731c51e8469095ebff8c9c8084305714ca40663a0d963f16188ba17fa640f273eaa1396784514bc04e4bc4cbcdc3aab2 SHA512 2dcf81fdf34b81790012a6c20dc344dccb89535359cffeb9a2725763f0a1842a00af1ae06b63e4e32054f06ceb14e32031afe479dc36897ddab28494241eb756
diff --git a/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.1.9.ebuild b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.1.9.ebuild
deleted file mode 100644
index dea208929568..000000000000
--- a/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.1.9.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-PYTHON_REQ_USE="threads"
-DISTUTILS_OPTIONAL=true
-DISTUTILS_IN_SOURCE_BUILD=true
-
-inherit distutils-r1 flag-o-matic
-
-MY_PV=$(ver_rs 1-2 '_')
-
-DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
-HOMEPAGE="http://libtorrent.org"
-SRC_URI="https://github.com/arvidn/libtorrent/releases/download/libtorrent-${MY_PV}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/9"
-KEYWORDS="amd64 ~arm ppc ppc64 ~sparc x86 ~x86-fbsd"
-IUSE="debug +dht doc examples libressl python +ssl static-libs test"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- dev-libs/boost:=[threads]
- virtual/libiconv
- examples? ( !net-p2p/mldonkey )
- python? (
- ${PYTHON_DEPS}
- dev-libs/boost:=[python,${PYTHON_USEDEP}]
- )
- ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:= )
- )
-"
-DEPEND="${RDEPEND}
- sys-devel/libtool
-"
-
-src_prepare() {
- default
-
- # bug 578026
- # prepend -L${S}/... to ensure bindings link against the lib we just built
- sed -i -e "s|^|-L${S}/src/.libs |" bindings/python/link_flags.in || die
-
- # prepend -I${S}/... to ensure bindings use the right headers
- sed -i -e "s|^|-I${S}/src/include |" bindings/python/compile_flags.in || die
-
- use python && distutils-r1_src_prepare
-}
-
-src_configure() {
- append-cxxflags -std=c++11 # bug 634506
-
- local myeconfargs=(
- $(use_enable debug)
- $(use_enable debug logging)
- $(use_enable debug disk-stats)
- $(use_enable dht dht $(usex debug logging $(usex ('yes' 'no'))))
- $(use_enable examples)
- $(use_enable ssl encryption)
- $(use_enable static-libs static)
- $(use_enable test tests)
- --with-libiconv
- )
- econf "${myeconfargs[@]}"
-
- if use python; then
- python_configure() {
- econf "${myeconfargs[@]}" \
- --enable-python-binding \
- --with-boost-python="${EPYTHON#python}"
- }
- distutils-r1_src_configure
- fi
-}
-
-src_compile() {
- default
-
- python_compile() {
- cd "${BUILD_DIR}/../bindings/python" || die
- distutils-r1_python_compile
- }
- use python && distutils-r1_src_compile
-}
-
-src_install() {
- use doc && HTML_DOCS+=( "${S}"/docs )
-
- default
-
- python_install() {
- cd "${BUILD_DIR}/../bindings/python" || die
- distutils-r1_python_install
- }
- use python && distutils-r1_src_install
-
- find "${D}" -name '*.la' -delete || die
-}