summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-07-10 21:11:21 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-07-10 21:11:37 +0100
commit615a57b837f40f4c1671f6b6f41be41602268aa4 (patch)
tree30f2789278ff030a1f9689a9eb19b16d2e69c037 /net-libs
parentwww-client/chromium: dev channel bump to 85.0.4183.15 (diff)
downloadgentoo-615a57b837f40f4c1671f6b6f41be41602268aa4.tar.gz
gentoo-615a57b837f40f4c1671f6b6f41be41602268aa4.tar.bz2
gentoo-615a57b837f40f4c1671f6b6f41be41602268aa4.zip
net-libs/libnsl: tweak config.rpath shell
`config.rpath` contains a bit of invalid shell: ``` checking for shared library run path origin... libnsl-1.3.0/config.rpath: line 219: ==: command not found libnsl-1.3.0/config.rpath: line 219: ==: command not found ``` ``` if $LD --help 2>&1 | grep ': supported targets:.* elf' > /dev/null; then if $libdir == /usr/lib | $libdir == /usr/lib64; then hardcode_libdir_flag_spec="" fi else ld_shlibs=no fi ``` The change restores default `config.rpath`. Reported-by: Agostino Sarubbo Closes: https://bugs.gentoo.org/732100 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libnsl/files/libnsl-1.3.0-rpath.patch16
-rw-r--r--net-libs/libnsl/libnsl-1.3.0-r1.ebuild42
2 files changed, 58 insertions, 0 deletions
diff --git a/net-libs/libnsl/files/libnsl-1.3.0-rpath.patch b/net-libs/libnsl/files/libnsl-1.3.0-rpath.patch
new file mode 100644
index 000000000000..1189dae37cfa
--- /dev/null
+++ b/net-libs/libnsl/files/libnsl-1.3.0-rpath.patch
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/732100
+
+Remove invalid shell from config.rpath.
+--- a/config.rpath
++++ b/config.rpath
+@@ -216,9 +216,7 @@ if test "$with_gnu_ld" = yes; then
+ ;;
+ gnu* | linux* | tpf* | k*bsd*-gnu | kopensolaris*-gnu)
+ if $LD --help 2>&1 | grep ': supported targets:.* elf' > /dev/null; then
+- if $libdir == /usr/lib | $libdir == /usr/lib64; then
+- hardcode_libdir_flag_spec=""
+- fi
++ :
+ else
+ ld_shlibs=no
+ fi
diff --git a/net-libs/libnsl/libnsl-1.3.0-r1.ebuild b/net-libs/libnsl/libnsl-1.3.0-r1.ebuild
new file mode 100644
index 000000000000..abd6e83ed26c
--- /dev/null
+++ b/net-libs/libnsl/libnsl-1.3.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="Public client interface for NIS(YP) and NIS+ in a IPv6 ready version"
+HOMEPAGE="https://github.com/thkukuk/libnsl"
+SRC_URI="https://github.com/thkukuk/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+SLOT="0/2"
+LICENSE="LGPL-2.1+"
+
+# Stabilize together with glibc-2.26!
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+IUSE=""
+
+DEPEND="
+ >=net-libs/libtirpc-1.0.2-r1[${MULTILIB_USEDEP}]
+"
+RDEPEND="${DEPEND}
+ !<sys-libs/glibc-2.26
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.0-rpath.patch
+)
+
+multilib_src_configure() {
+ local myconf=(
+ --enable-shared
+ --disable-static
+ )
+ ECONF_SOURCE=${S} econf "${myconf[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -type f -name '*.la' -delete || die
+}