summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2022-05-16 12:57:56 -0400
committerCraig Andrews <candrews@gentoo.org>2022-05-16 12:58:22 -0400
commit6e7184a6767c9d6062d05cc0a615e84d6b93a2ac (patch)
tree1a9b2c6def17f7676d038d7f6531ef9eb9c9defc /net-libs
parentdev-python/vdf: enable py3.11 (diff)
downloadgentoo-6e7184a6767c9d6062d05cc0a615e84d6b93a2ac.tar.gz
gentoo-6e7184a6767c9d6062d05cc0a615e84d6b93a2ac.tar.bz2
gentoo-6e7184a6767c9d6062d05cc0a615e84d6b93a2ac.zip
net-libs/ngtcp2: 0.5.0 version bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/ngtcp2/Manifest1
-rw-r--r--net-libs/ngtcp2/ngtcp2-0.5.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-libs/ngtcp2/Manifest b/net-libs/ngtcp2/Manifest
index 6f2396805556..dcab15c68bd0 100644
--- a/net-libs/ngtcp2/Manifest
+++ b/net-libs/ngtcp2/Manifest
@@ -3,4 +3,5 @@ DIST ngtcp2-0.2.1.tar.xz 554280 BLAKE2B 243599cde08eeb5833d4836cfe3a1b1ea3b9cd33
DIST ngtcp2-0.3.0.tar.xz 570876 BLAKE2B 645d09b2b33076d93bfffb79eba347cda5d0d782e1321138f436fe776808b3a51a0a2fc5599ecfe67b4db87b3e653b3e37293f746dabe7ae50cc32cd929c08f7 SHA512 3e37c269fba0261dc1514095104725064c078cc0dc66c0cfb8b536a8e3fe474888ca6a88b02c176689d94ddabf7acad14e1e8dea121da93f18bbe261169b0ee9
DIST ngtcp2-0.3.1.tar.xz 566612 BLAKE2B 9b9b2e8a671e924bb13d41874c5f5a940fdde352b2f0ac60c41fbb9478bd03c070baecbe3e867ecce73e6671309a93b3696410ea3a965ea618349391e963ae0a SHA512 8c5beae1b257272212dcfaf9d8b56e728ba0b08e0c2f2f27d9f5049c8278a60bdcd97df140e5661793a65a936ce556f5afa55f05fd5b60c647d47dadc4a4cdc3
DIST ngtcp2-0.4.0.tar.xz 573692 BLAKE2B 9eb428a19a7e6a42dc6344f7569dbb33cb083028c25c34c9bec0999a7f055d1ee1173ffae500ddcdca60e20d508b7b56f2489e9af03e10284611179b5098ce16 SHA512 5ce0933a6e53ce29a0d007f487aad11f068d9450ada10af6e5639c891a292977bf4bc57ccf0b5782b8e6e84292859faf3d409de49038b586c74205acc3a391ee
+DIST ngtcp2-0.5.0.tar.xz 570732 BLAKE2B 3e1e11a8e65afb6ff3e7c790545a889459ffaeccd2a93085634b55a2124143a96750b06e3bc494c5311664b9f35adb57784dc164756f7026dbca4a25c33acdf6 SHA512 bd30005126b11165741d2295252c5fe9ca82b1f1cebf9d0064b79f4bf7778b62e39e241063f80b5ad2d5fa859b5f799f938958cf8963d1b1c8477c2202c1ec71
DIST ngtcp2-0_pre20190912.tar.gz 302984 BLAKE2B 906b248b0c19395288ed2c5ad55c8d42a9df9d76458104785c1013b9ebfaf1b92a4b87ced8755377fcb627018cf8854be0e4687e4c8a23ae994e5a21f466f739 SHA512 91b93575143960af421e8bd37d686602905fa3093750cfbbe3af1b20d743318281d22162676dc451562768ca08b6d0767b1dc28f3f8f6733235ebd76015a05bb
diff --git a/net-libs/ngtcp2/ngtcp2-0.5.0.ebuild b/net-libs/ngtcp2/ngtcp2-0.5.0.ebuild
new file mode 100644
index 000000000000..a828f15d1ad2
--- /dev/null
+++ b/net-libs/ngtcp2/ngtcp2-0.5.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/ngtcp2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ngtcp2/ngtcp2/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~hppa"
+fi
+
+DESCRIPTION="Implementation of the IETF QUIC Protocol"
+HOMEPAGE="https://github.com/ngtcp2/ngtcp2/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="+gnutls openssl +ssl test"
+REQUIRED_USE="ssl? ( || ( gnutls openssl ) )"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-3.7.2:0= )
+ openssl? (
+ >=dev-libs/openssl-1.1.1:0=
+ )
+ )"
+DEPEND="${RDEPEND}
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_GNUTLS=$(usex gnutls)
+ -DENABLE_OPENSSL=$(usex openssl)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libev=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libnghttp3=ON
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build check
+}