summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-19 13:19:26 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-19 13:28:05 +0200
commit74685fa9ce5e9fd8b09f390ccfc2319603351ae4 (patch)
tree77556637c0fdd9398cf04d74cea8372a9cd3b77c /net-libs
parentnet-libs/farstream: Disable unused Python check (diff)
downloadgentoo-74685fa9ce5e9fd8b09f390ccfc2319603351ae4.tar.gz
gentoo-74685fa9ce5e9fd8b09f390ccfc2319603351ae4.tar.bz2
gentoo-74685fa9ce5e9fd8b09f390ccfc2319603351ae4.zip
net-libs/ldns: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/ldns/Manifest1
-rw-r--r--net-libs/ldns/files/ldns-1.7.0-CVE-2017-1000231.patch15
-rw-r--r--net-libs/ldns/files/ldns-1.7.0-CVE-2017-1000232.patch17
-rw-r--r--net-libs/ldns/ldns-1.7.0-r2.ebuild98
4 files changed, 0 insertions, 131 deletions
diff --git a/net-libs/ldns/Manifest b/net-libs/ldns/Manifest
index 7654e7092d5c..13e5bc23ba61 100644
--- a/net-libs/ldns/Manifest
+++ b/net-libs/ldns/Manifest
@@ -1,2 +1 @@
-DIST ldns-1.7.0.tar.gz 1304424 BLAKE2B 2f37aa2d00c1d9cf18711bd4f873f4722df01c4f4d0f627e054f04b2473c0fbf19449e293a130d5c8b98dcebafeb3d7b3f5923ae0244bd80139cea77f2171e06 SHA512 8a4e48bcc2a244b92447a9830b60efbb656fb7955f3559ef2eb6f8e724c4c0208776350c44ccf7dcf1ffe0b7b9d9ccc4cbddc5bc16e8888db494ab4d0bce3bd8
DIST ldns-1.7.1.tar.gz 1244394 BLAKE2B 8f2d9c6e34c4f13924ce1531a5757c4a619fc31ebc5a0a3d4aaf43fcfc8b53e8f371984b1c60ab74f735a05a9ca0710fc29a40fffeaef66eb54395eb3a727a0d SHA512 e8f72a4ff4aa544acac5e7be9a8ba38c6b8d388bb26f9a0ed04c1a921622f8582cc8539beafc76a29187a55c94069b7c1875e77522e1a7e7bb3e297dd1e4c2b7
diff --git a/net-libs/ldns/files/ldns-1.7.0-CVE-2017-1000231.patch b/net-libs/ldns/files/ldns-1.7.0-CVE-2017-1000231.patch
deleted file mode 100644
index 9ff92e25c75e..000000000000
--- a/net-libs/ldns/files/ldns-1.7.0-CVE-2017-1000231.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/parse.c b/parse.c
-index e68627c..947dbb8 100644
---- a/parse.c
-+++ b/parse.c
-@@ -118,6 +118,10 @@ ldns_fget_token_l(FILE *f, char *token, const char *delim, size_t limit, int *li
- if (line_nr) {
- *line_nr = *line_nr + 1;
- }
-+ if (limit > 0 && (i >= limit || (size_t)(t-token) >= limit)) {
-+ *t = '\0';
-+ return -1;
-+ }
- *t++ = ' ';
- prev_c = c;
- continue;
diff --git a/net-libs/ldns/files/ldns-1.7.0-CVE-2017-1000232.patch b/net-libs/ldns/files/ldns-1.7.0-CVE-2017-1000232.patch
deleted file mode 100644
index 341dfa5916e4..000000000000
--- a/net-libs/ldns/files/ldns-1.7.0-CVE-2017-1000232.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/str2host.c b/str2host.c
-index b274b17..f2a317b 100644
---- a/str2host.c
-+++ b/str2host.c
-@@ -1525,8 +1525,10 @@ ldns_str2rdf_long_str(ldns_rdf **rd, const char *str)
- if (! str) {
- return LDNS_STATUS_SYNTAX_BAD_ESCAPE;
- }
-- length = (size_t)(dp - data);
--
-+ if (!(length = (size_t)(dp - data))) {
-+ LDNS_FREE(data);
-+ return LDNS_STATUS_SYNTAX_EMPTY;
-+ }
- /* Lose the overmeasure */
- data = LDNS_XREALLOC(dp = data, uint8_t, length);
- if (! data) {
diff --git a/net-libs/ldns/ldns-1.7.0-r2.ebuild b/net-libs/ldns/ldns-1.7.0-r2.ebuild
deleted file mode 100644
index c55730be0304..000000000000
--- a/net-libs/ldns/ldns-1.7.0-r2.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils ltprune multilib-minimal python-single-r1
-
-DESCRIPTION="a library with the aim to simplify DNS programming in C"
-HOMEPAGE="http://www.nlnetlabs.nl/projects/ldns/"
-SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="+dane doc +ecdsa gost libressl python static-libs vim-syntax"
-
-# configure will die if ecdsa is enabled and ssl is not
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- python? ( ${PYTHON_DEPS} )
- ecdsa? (
- !libressl? ( >=dev-libs/openssl-1.0.1e:0=[-bindist,${MULTILIB_USEDEP}] )
- )
- !libressl? ( >=dev-libs/openssl-1.0.1e:0=[${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
-"
-DEPEND="${RDEPEND}
- python? ( dev-lang/swig )
- doc? ( app-doc/doxygen )
-"
-
-RESTRICT="test" # 1.6.9 has no test directory
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/ldns-config
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-multilib_src_configure() {
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable static-libs static) \
- $(use_enable gost) \
- $(use_enable ecdsa) \
- $(use_enable dane) \
- $(multilib_native_use_with python pyldns) \
- $(multilib_native_use_with python pyldnsx) \
- --with-ssl="${EPREFIX}"/usr \
- --enable-sha2 \
- --without-drill \
- --without-examples \
- --disable-dane-ta-usage \
- --disable-rpath
-
- # >=openssl-1.1.0 required for dane-ta
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-CVE-2017-1000231.patch"
- epatch "${FILESDIR}/${P}-CVE-2017-1000232.patch"
-}
-
-multilib_src_compile() {
- default
-
- if multilib_is_native_abi && use doc ; then
- emake doxygen
- fi
-}
-
-multilib_src_install() {
- default
-
- if multilib_is_native_abi && use doc ; then
- dohtml -r doc/html/.
- fi
-}
-
-multilib_src_install_all() {
- dodoc Changelog README*
-
- prune_libtool_files --modules
- use python && python_optimize
-
- if use vim-syntax ; then
- insinto /usr/share/vim/vimfiles/ftdetect
- doins libdns.vim
- fi
-
- einfo
- elog "Install net-dns/ldns-utils if you want drill and examples"
- einfo
-}