summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-12-01 14:14:13 +0000
committerSam James <sam@gentoo.org>2024-12-01 14:14:13 +0000
commit9191ed55cb8501996d322eb7391035657325ce03 (patch)
treee0323121e2fba58c8e6ef93bb321637af256b28d /net-libs
parentmedia-libs/libsndfile: build (just) 1.2.2-r2 w/ bash (diff)
downloadgentoo-9191ed55cb8501996d322eb7391035657325ce03.tar.gz
gentoo-9191ed55cb8501996d322eb7391035657325ce03.tar.bz2
gentoo-9191ed55cb8501996d322eb7391035657325ce03.zip
net-libs/libtirpc: add 1.3.6
Closes: https://bugs.gentoo.org/911863 Closes: https://bugs.gentoo.org/943709 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libtirpc/Manifest1
-rw-r--r--net-libs/libtirpc/libtirpc-1.3.6.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/net-libs/libtirpc/Manifest b/net-libs/libtirpc/Manifest
index db58a31a0f2a..a0d59d4f4928 100644
--- a/net-libs/libtirpc/Manifest
+++ b/net-libs/libtirpc/Manifest
@@ -1,2 +1,3 @@
DIST libtirpc-1.3.5.tar.bz2 565188 BLAKE2B 1ae1cc0be1c52bca8fbe2300159d9298b069b3f81adde7f50da3fb7049f9b9f628393dfe94e9276facfeea2b1ccdc9a52632fee4af432c36e457fd3ff2b0963c SHA512 c80a953671c5692294efe7425e41c7f12bd4c430f473f9ea71883168cb4a69111f0018122bd0e7982e18f4576e45d4977ce0790743382faae006c446813d2a4f
+DIST libtirpc-1.3.6.tar.bz2 566384 BLAKE2B 521e1e3d2ceefd668f1b0d52b7c0342b97952d322eeb7bf740bb1eb1fb88a14b0a2fce57f07a9fd3797d289f57f511085924bba3d8984f15c799468d30f47500 SHA512 f3ccc45f9de8d517ccc10dd4b68b844bbe71a2cb61ca5819995d97319353f7e24cfee205e09dddf65cf47605314176aee161091d7379b6113ee8d1f5077c93d0
DIST libtirpc-glibc-nfs.tar.xz 8948 BLAKE2B 7316623d9f2b6928e296137fe2bf6794b208d549c2ffba9e4a35b47f7b04bf023798a09f38c02d039debf6adc466d7689cf3c8274d71a22eaff08729642c0a28 SHA512 90255bf0a27af16164e0710dd940778609925d473f4343093ff19d98cc4f23023788bf4edf0178eae1961afc0ba8b69b273de95b7d7e2afdb706701d8ba6f7ba
diff --git a/net-libs/libtirpc/libtirpc-1.3.6.ebuild b/net-libs/libtirpc/libtirpc-1.3.6.ebuild
new file mode 100644
index 000000000000..83d0f66abfba
--- /dev/null
+++ b/net-libs/libtirpc/libtirpc-1.3.6.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic libtool multilib-minimal
+
+DESCRIPTION="Transport Independent RPC library (SunRPC replacement)"
+HOMEPAGE="https://sourceforge.net/projects/libtirpc/ https://git.linux-nfs.org/?p=steved/libtirpc.git"
+SRC_URI="
+ https://downloads.sourceforge.net/${PN}/${P}.tar.bz2
+ https://dev.gentoo.org/~sam/distfiles/${PN}-glibc-nfs.tar.xz
+"
+
+LICENSE="BSD BSD-2 BSD-4 LGPL-2.1+"
+SLOT="0/3" # subslot matches SONAME major
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="kerberos static-libs"
+
+RDEPEND="kerberos? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )"
+DEPEND="
+ ${RDEPEND}
+ elibc_musl? ( sys-libs/queue-standalone )
+"
+BDEPEND="
+ app-arch/xz-utils
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ cp -ra "${WORKDIR}"/tirpc "${S}"/ || die
+
+ default
+ elibtoolize
+}
+
+multilib_src_configure() {
+ # bug #943709
+ append-cflags -std=gnu17
+ append-ldflags $(test-flags-CCLD -Wl,--undefined-version)
+ # bug #911863
+ append-lfs-flags
+
+ local myeconfargs=(
+ $(use_enable kerberos gssapi)
+ $(use_enable static-libs static)
+ KRB5_CONFIG="${ESYSROOT}"/usr/bin/krb5-config
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ insinto /etc
+ doins doc/netconfig
+
+ insinto /usr/include/tirpc
+ doins -r "${WORKDIR}"/tirpc/*
+
+ # makes sure that the linking order for nfs-utils is proper, as
+ # libtool would inject a libgssglue dependency in the list.
+ if ! use static-libs ; then
+ find "${ED}" -name "*.la" -delete || die
+ fi
+}