summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-09 19:04:01 +0000
committerSam James <sam@gentoo.org>2023-12-09 19:05:05 +0000
commitaf30ce8d18c222a1999d02a93fa6ed315686be21 (patch)
treeb21e53d90b265339cccd05e0f5f9b8810475483f /net-libs
parentxfce-extra/xfce4-dict: Stabilize 0.8.6 ppc64, #919585 (diff)
downloadgentoo-af30ce8d18c222a1999d02a93fa6ed315686be21.tar.gz
gentoo-af30ce8d18c222a1999d02a93fa6ed315686be21.tar.bz2
gentoo-af30ce8d18c222a1999d02a93fa6ed315686be21.zip
net-libs/libgssglue: add 0.8
Closes: https://bugs.gentoo.org/919208 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libgssglue/Manifest1
-rw-r--r--net-libs/libgssglue/libgssglue-0.8.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-libs/libgssglue/Manifest b/net-libs/libgssglue/Manifest
index 0c41040f803f..4cc0874ee420 100644
--- a/net-libs/libgssglue/Manifest
+++ b/net-libs/libgssglue/Manifest
@@ -1,2 +1,3 @@
DIST libgssglue-0.4.tar.gz 346984 BLAKE2B 5815db41ff3f65b014e713b68667bb49d3aecab943e891de881af2a2d157cceddc5173e7eff9ed2eac714b2e1341429694f1051ad98a3c4b728a61eaceeaddfb SHA512 25d514c08320e42851ff153d7691267a8454f205492faf942f566aa30c1ac1c83bd095732a1a0fcc010ba3a5d48b4c95a196ad05bc821598cc1fc3a2c4960d29
DIST libgssglue-libgssglue-0.7.tar.bz2 31415 BLAKE2B 4017ff17b876b00d93d5120ca8fe2a1f472b61c7b73dec0194d0ebaa244176b5d6f85fbfe5ce52cd77bcce9e1718f979b36e8926577640bbad38208fcea78f5a SHA512 04ea9af9f56afeca40b1dd22708dfa2e844d587106f370820a8976a22e8b95c646cdc5c5ef4256e34780cdb34c5617c45187fe3866670662f15ac579ef22dcca
+DIST libgssglue-libgssglue-0.8.tar.bz2 34586 BLAKE2B 4dcd39f53904c2d5e559b15329bd6c1b8931dda426ef156d65e21d68cce85bc12d20338254a0d9fffb6acc7cec074a56e355f4bc95c065e4dafe787d4b8c077b SHA512 7866875d7394fd8c6eeb9621a88ab0393c0d30606c407fa5d5b25a30579642d37bdafb81b748bb84cf026f47716e4c4f68da6e6eb2d5afeedfb37270f1749aa1
diff --git a/net-libs/libgssglue/libgssglue-0.8.ebuild b/net-libs/libgssglue/libgssglue-0.8.ebuild
new file mode 100644
index 000000000000..0cea0d079823
--- /dev/null
+++ b/net-libs/libgssglue/libgssglue-0.8.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools readme.gentoo-r1
+
+DESCRIPTION="Exports a gssapi interface which calls other random gssapi libraries"
+HOMEPAGE="http://www.citi.umich.edu/projects/nfsv4/linux https://gitlab.com/gsasl/libgssglue"
+SRC_URI="https://gitlab.com/gsasl/libgssglue/-/archive/${P}/${PN}-${P}.tar.bz2"
+S="${WORKDIR}"/${PN}-${P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="virtual/krb5"
+
+DOC_CONTENTS="
+This package allows choosing a Kerberos or GSSAPI implementation
+at runtime.
+
+See
+https://blog.josefsson.org/2022/07/14/towards-pluggable-gss-api-modules/
+for more details.
+
+A system-wide implementation can be chosen by editing ${EPREFIX}/etc/gssapi_mech.conf,
+or it can be set per-process via the GSSAPI_MECH_CONF environment variable.
+"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ readme.gentoo_create_doc
+
+ insinto /etc
+ doins doc/gssapi_mech.conf
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}