summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-08-03 21:54:00 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-08-03 22:07:54 +0200
commitc875ee49b4fec73ee9b1c8ffc608507e4aef312b (patch)
tree07b2b8b10bb58beb4dbe02822ce4940480b8791f /net-libs
parentapp-text/diff-pdf: drop 0.4.1-r2 (diff)
downloadgentoo-c875ee49b4fec73ee9b1c8ffc608507e4aef312b.tar.gz
gentoo-c875ee49b4fec73ee9b1c8ffc608507e4aef312b.tar.bz2
gentoo-c875ee49b4fec73ee9b1c8ffc608507e4aef312b.zip
net-libs/libupnp: add 1.14.13
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libupnp/Manifest1
-rw-r--r--net-libs/libupnp/libupnp-1.14.13.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-libs/libupnp/Manifest b/net-libs/libupnp/Manifest
index d28f01297328..c88a40a0905f 100644
--- a/net-libs/libupnp/Manifest
+++ b/net-libs/libupnp/Manifest
@@ -1 +1,2 @@
DIST libupnp-1.14.12.tar.gz 788299 BLAKE2B 721c10f9fa4ffc60743b4ebf8be566ea595931cb1f2a2448d8e3cecfc787abfb855cb16256eaaa10ce6a901cd5e5b3d14672610841b2a718d5dd003ccfd3c2f0 SHA512 aab17aa12f15d110bfab20cbcbae5f54926b6ca7a30bce10b9287cd39919a06a5e9f1493405e1d561c0d58ba46926f87009df891e4e4f37097df1c3c67635ca9
+DIST libupnp-1.14.13.tar.gz 807484 BLAKE2B af3cd6c852297d7b131b2deefba8a72427e225c765017edb5f927b81bd1ce2b72d43caf2c46bd383b83536ba858d52dc8d051e272dacc8bd3c952e43443650a4 SHA512 ae6ae72a5e784a0f9508af94c4070627e791660fa37966e9825643fd0f88b171826bda9a2ec872d4961bf3454e5a9cd716127f0bdf6e63c789c4e22aab0b7e71
diff --git a/net-libs/libupnp/libupnp-1.14.13.ebuild b/net-libs/libupnp/libupnp-1.14.13.ebuild
new file mode 100644
index 000000000000..a8b52238c73f
--- /dev/null
+++ b/net-libs/libupnp/libupnp-1.14.13.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_PN="pupnp"
+
+DESCRIPTION="An Portable Open Source UPnP Development Kit"
+HOMEPAGE="http://pupnp.sourceforge.net/"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-release-${PV}"
+
+LICENSE="BSD"
+SLOT="0/17"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux"
+IUSE="blocking-tcp debug doc +ipv6 +reuseaddr samples +ssl static-libs"
+
+RDEPEND="ssl? ( dev-libs/openssl:0= )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${PN}-1.14.12-disable-network-tests.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable blocking-tcp blocking-tcp-connections)
+ $(use_enable debug)
+ $(use_enable ipv6)
+ $(use_enable reuseaddr)
+ $(use_enable samples)
+ $(use_enable ssl open_ssl)
+ $(use_enable static-libs static)
+ )
+
+ econf ${myeconfargs[@]}
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}