summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-05-09 16:10:56 +0200
committerMarek Szuba <marecki@gentoo.org>2021-05-09 16:28:43 +0200
commiteb883d12833510e1b745cfd4678bbb8b17f610a3 (patch)
tree0159b73ac109b27f8f05c867921818b4a0e51bb9 /net-libs
parentnet-libs/nodejs-16.1.0: disable test-release-npm (diff)
downloadgentoo-eb883d12833510e1b745cfd4678bbb8b17f610a3.tar.gz
gentoo-eb883d12833510e1b745cfd4678bbb8b17f610a3.tar.bz2
gentoo-eb883d12833510e1b745cfd4678bbb8b17f610a3.zip
net-libs/nodejs-14.16.1-r1: synchronise test configuration with v16
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nodejs/nodejs-14.16.1-r1.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/net-libs/nodejs/nodejs-14.16.1-r1.ebuild b/net-libs/nodejs/nodejs-14.16.1-r1.ebuild
index c386c0e45b7c..3eb26e5b189c 100644
--- a/net-libs/nodejs/nodejs-14.16.1-r1.ebuild
+++ b/net-libs/nodejs/nodejs-14.16.1-r1.ebuild
@@ -89,13 +89,6 @@ src_prepare() {
sed -i -e "/'-O3'/d" common.gypi node.gypi || die
- # Avoid a test that I've only been able to reproduce from emerge. It doesnt
- # seem sandbox related either (invoking it from a sandbox works fine).
- # The issue is that no stdin handle is openened when asked for one.
- # It doesn't really belong upstream , so it'll just be removed until someone
- # with more gentoo-knowledge than me (jbergstroem) figures it out.
- rm test/parallel/test-stdout-close-unref.js || die
-
# debug builds. change install path, remove optimisations and override buildtype
if use debug; then
sed -i -e "s|out/Release/|out/Debug/|g" tools/install.py || die
@@ -105,6 +98,13 @@ src_prepare() {
# We need to disable mprotect on two files when it builds Bug 694100.
use pax_kernel && PATCHES+=( "${FILESDIR}"/${PN}-13.8.0-paxmarking.patch )
+ # All this test does is check if the npm CLI produces warnings of any sort,
+ # failing if it does. Overkill, much? Especially given one possible warning
+ # is that there is a newer version of npm available upstream (yes, it does
+ # use the network if available), thus making it a real possibility for this
+ # test to begin failing one day even though it was fine before.
+ rm -f test/parallel/test-release-npm.js
+
default
}
@@ -230,5 +230,5 @@ src_test() {
fi
out/${BUILDTYPE}/cctest || die
- "${EPYTHON}" tools/test.py --mode=${BUILDTYPE,,} -J message parallel sequential || die
+ "${EPYTHON}" tools/test.py --mode=${BUILDTYPE,,} --flaky-tests=dontcare -J message parallel sequential || die
}