summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/fastforward
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/fastforward')
-rw-r--r--net-mail/fastforward/Manifest1
-rw-r--r--net-mail/fastforward/fastforward-0.51-r1.ebuild44
-rw-r--r--net-mail/fastforward/files/0.51-errno.patch11
-rw-r--r--net-mail/fastforward/metadata.xml5
4 files changed, 61 insertions, 0 deletions
diff --git a/net-mail/fastforward/Manifest b/net-mail/fastforward/Manifest
new file mode 100644
index 000000000000..71269355cb9d
--- /dev/null
+++ b/net-mail/fastforward/Manifest
@@ -0,0 +1 @@
+DIST fastforward-0.51.tar.gz 40659 SHA256 45a1a071d54701bf973fed7582b5ff76cb6ed3e43089da6da87caabbb4b4fd7e
diff --git a/net-mail/fastforward/fastforward-0.51-r1.ebuild b/net-mail/fastforward/fastforward-0.51-r1.ebuild
new file mode 100644
index 000000000000..bc6396c9132d
--- /dev/null
+++ b/net-mail/fastforward/fastforward-0.51-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils fixheadtails
+
+DESCRIPTION="handle qmail forwarding according to a cdb database"
+HOMEPAGE="http://cr.yp.to/fastforward.html"
+SRC_URI="http://cr.yp.to/software/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="x86 sparc ~ppc"
+IUSE=""
+
+DEPEND="sys-apps/groff"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-errno.patch"
+ ht_fix_file Makefile
+
+ echo "gcc ${CFLAGS}" > conf-cc
+ echo "gcc" > conf-ld
+}
+
+src_compile() {
+ emake it || die
+}
+
+# make check is actually an install-check target, see bug #283177
+src_test() { :; }
+
+src_install() {
+ dodoc ALIASES BLURB CHANGES FILES INSTALL README SYSDEPS TARGETS
+ dodoc THANKS TODO VERSION
+ doman *.1
+
+ insopts -o root -g qmail -m 755
+ insinto /var/qmail/bin
+ doins fastforward newaliases newinclude printforward printmaillist \
+ setforward setmaillist
+}
diff --git a/net-mail/fastforward/files/0.51-errno.patch b/net-mail/fastforward/files/0.51-errno.patch
new file mode 100644
index 000000000000..4aca1b2b4e58
--- /dev/null
+++ b/net-mail/fastforward/files/0.51-errno.patch
@@ -0,0 +1,11 @@
+--- error.h.orig 2003-03-05 15:42:51.000000000 -0500
++++ error.h 2003-03-05 15:43:00.000000000 -0500
+@@ -1,7 +1,7 @@
+ #ifndef ERROR_H
+ #define ERROR_H
+
+-extern int errno;
++#include <errno.h>
+
+ extern int error_intr;
+ extern int error_nomem;
diff --git a/net-mail/fastforward/metadata.xml b/net-mail/fastforward/metadata.xml
new file mode 100644
index 000000000000..210ce3ffc25e
--- /dev/null
+++ b/net-mail/fastforward/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>qmail</herd>
+</pkgmetadata>