summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRemco Rijnders <r+gentoo@r78.nl>2021-01-22 14:12:33 -0500
committerSam James <sam@gentoo.org>2021-01-23 03:38:50 +0000
commita695db36bdc3909518707cbeb0bda560b7caab3f (patch)
tree6401f7cf14e19ccc6b95c1cc3c084f1a4a0f6fe8 /net-mail/getmail/getmail-6.14.ebuild
parentdev-python/latexcodec: mark ALLARCHES (diff)
downloadgentoo-a695db36bdc3909518707cbeb0bda560b7caab3f.tar.gz
gentoo-a695db36bdc3909518707cbeb0bda560b7caab3f.tar.bz2
gentoo-a695db36bdc3909518707cbeb0bda560b7caab3f.zip
net-mail/getmail: Version bump to 6.14
Signed-off-by: Remco Rijnders <r+gentoo@r78.nl> Closes: https://github.com/gentoo/gentoo/pull/19161 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-mail/getmail/getmail-6.14.ebuild')
-rw-r--r--net-mail/getmail/getmail-6.14.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-mail/getmail/getmail-6.14.ebuild b/net-mail/getmail/getmail-6.14.ebuild
new file mode 100644
index 000000000000..5f757ea11287
--- /dev/null
+++ b/net-mail/getmail/getmail-6.14.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_REQ_USE="ssl"
+
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="A mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="https://www.getmail6.org/ https://github.com/getmail6/getmail6"
+SRC_URI="https://github.com/getmail6/getmail6/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/getmail6-${PV}"
+
+python_prepare_all() {
+ # Use gentoo version number (including revision) for doc dir and remove COPYING file
+ sed -i -e "s,'getmail-%s' % __version__,'${PF}'," \
+ -e "/docs\/COPYING/d" "${S}"/setup.py || die
+
+ distutils-r1_python_prepare_all
+}