summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/qmailadmin/qmailadmin-1.2.15.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/qmailadmin/qmailadmin-1.2.15.ebuild')
-rw-r--r--net-mail/qmailadmin/qmailadmin-1.2.15.ebuild95
1 files changed, 95 insertions, 0 deletions
diff --git a/net-mail/qmailadmin/qmailadmin-1.2.15.ebuild b/net-mail/qmailadmin/qmailadmin-1.2.15.ebuild
new file mode 100644
index 000000000000..d139c04c4a97
--- /dev/null
+++ b/net-mail/qmailadmin/qmailadmin-1.2.15.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit qmail eutils webapp autotools
+
+# the RESTRICT is because the vpopmail lib directory is locked down
+# and non-root can't access them.
+RESTRICT="userpriv"
+
+MY_P=${P/_rc/-rc}
+
+DESCRIPTION="A web interface for managing a qmail system with virtual domains"
+HOMEPAGE="http://www.inter7.com/qmailadmin.html"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+WEBAPP_MANUAL_SLOT="yes"
+KEYWORDS="amd64 arm ~hppa ppc s390 sh sparc x86"
+IUSE="maildrop"
+
+DEPEND="virtual/qmail
+ >=net-mail/vpopmail-5.3
+ net-mail/autorespond
+ maildrop? ( >=mail-filter/maildrop-2.0.1 )"
+
+S="${WORKDIR}"/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.2.9-maildir.patch
+ epatch "${FILESDIR}"/${PN}-1.2.12-quota-overflow.patch
+ eautoreconf
+}
+
+src_compile() {
+ # Pass spam stuff through $@ so we get the quoting right
+ if use maildrop ; then
+ set -- --enable-modify-spam \
+ --enable-spam-command='|preline maildrop /etc/maildroprc'
+ else
+ set --
+ fi
+ # If vpopmail is built with mysql, we need to pick that up.
+ CFLAGS="${CFLAGS} $(</var/vpopmail/etc/inc_deps)"
+ LDFLAGS="${LDFLAGS} $(</var/vpopmail/etc/lib_deps)"
+
+ econf \
+ --enable-valias \
+ --enable-vpopmaildir=/var/vpopmail \
+ --enable-htmldir="${MY_HTDOCSDIR}" \
+ --enable-imagedir="${MY_HTDOCSDIR}"/images \
+ --enable-imageurl=/${PN}/images \
+ --enable-htmllibdir=/usr/share/${PN}/htmllib \
+ --enable-cgibindir="${MY_CGIBINDIR}" \
+ --enable-cgipath=/cgi-bin/${PN} \
+ --enable-qmaildir="${QMAIL_HOME}" \
+ --enable-autoresponder-path="${QMAIL_HOME}"/bin \
+ --enable-true-path=/bin \
+ --enable-ezmlmdir=/usr/bin \
+ --enable-domain-autofill \
+ --enable-modify-quota \
+ --enable-no-cache \
+ --enable-trivial-password \
+ --enable-catchall \
+ --enable-maxusersperpage=50 \
+ --enable-maxaliasesperpage=50 \
+ --enable-vpopuser=vpopmail \
+ --enable-vpopgroup=vpopmail \
+ LDFLAGS="${LDFLAGS}" \
+ CFLAGS="${CFLAGS}" \
+ "$@" \
+ || die "econf failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ webapp_src_preinst
+
+ make DESTDIR="${D}" install || die "make install failed"
+
+ dodoc AUTHORS INSTALL README.hooks BUGS TODO ChangeLog \
+ TRANSLATORS NEWS FAQ README contrib/*
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ einfo "If you would like support for ezmlm mailing lists inside qmailadmin,"
+ einfo "please emerge some variant of ezmlm-idx."
+ webapp_pkg_postinst
+}