summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/adjtimex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/adjtimex')
-rw-r--r--net-misc/adjtimex/Manifest2
-rw-r--r--net-misc/adjtimex/adjtimex-1.29-r1.ebuild59
-rw-r--r--net-misc/adjtimex/files/adjtimex-1.29-r1-gentoo-utc.patch30
-rw-r--r--net-misc/adjtimex/files/adjtimex.init35
-rw-r--r--net-misc/adjtimex/metadata.xml7
5 files changed, 133 insertions, 0 deletions
diff --git a/net-misc/adjtimex/Manifest b/net-misc/adjtimex/Manifest
new file mode 100644
index 000000000000..2d3cd915626a
--- /dev/null
+++ b/net-misc/adjtimex/Manifest
@@ -0,0 +1,2 @@
+DIST adjtimex_1.29-2.diff.gz 51735 SHA256 54293c8aff704a8077b4d0ec31e8a21cf8de93e145e0e8644ec91e132da6e577 SHA512 cc78cf9fd93cb243019952f877cb9730a5755d87336fc1a956162e957fd579de3770cb6bbba58ac9b6d350ee631ed294303360d0aa4153b12a31eb1bb4e35924 WHIRLPOOL 24f5a37ffa2b7b81b0d2f0d4755bd26e07e6bc32896858d574a96bb02c8df3d71f8acbeba9363c0ee37fdca59dba0a8a83f33014b562f85bd5b7abbdb99100d3
+DIST adjtimex_1.29.orig.tar.gz 85551 SHA256 04b9e8b66e77276ed07e78de89af37fd1aa12725923de853480827c4fafd176a SHA512 5a48cdc538866c06562f62e369c08d60978c791ed91565262c0179c6fa25dd343963992d00e10f32475fdc00b458f81cf9c61adbfa9e1b7a8d4981ebeeff5649 WHIRLPOOL f22f4ba2f0945ca53f4967094b10df1a741d705b07f86ae3e024ebb3624acc6cfd56d12414c2a00b1f0747a07c80d65fa0e7471816879cb3c159b5b079228112
diff --git a/net-misc/adjtimex/adjtimex-1.29-r1.ebuild b/net-misc/adjtimex/adjtimex-1.29-r1.ebuild
new file mode 100644
index 000000000000..20cb55ce4ed3
--- /dev/null
+++ b/net-misc/adjtimex/adjtimex-1.29-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils fixheadtails toolchain-funcs
+
+DEBIAN_PV="2"
+MY_P="${P/-/_}"
+DEBIAN_URI="mirror://debian/pool/main/${PN:0:1}/${PN}"
+DEBIAN_PATCH="${MY_P}-${DEBIAN_PV}.diff.gz"
+DEBIAN_SRC="${MY_P}.orig.tar.gz"
+DESCRIPTION="display or set the kernel time variables"
+HOMEPAGE="http://www.ibiblio.org/linsearch/lsms/adjtimex.html"
+SRC_URI="${DEBIAN_URI}/${DEBIAN_PATCH}
+ ${DEBIAN_URI}/${DEBIAN_SRC}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc x86"
+IUSE=""
+
+DEPEND="sys-apps/sed"
+RDEPEND=""
+
+src_prepare() {
+ cd "${WORKDIR}"
+ epatch "${DISTDIR}"/${DEBIAN_PATCH}
+ cd "${S}"
+ for i in debian/adjtimexconfig debian/adjtimexconfig.8 ; do
+ sed -e 's|/etc/default/adjtimex|/etc/conf.d/adjtimex|' \
+ -i.orig ${i}
+ sed -e 's|^/sbin/adjtimex |/usr/sbin/adjtimex |' \
+ -i.orig ${i}
+ done
+ epatch "${FILESDIR}"/${PN}-1.29-r1-gentoo-utc.patch
+ ht_fix_file debian/adjtimexconfig
+ sed -i \
+ -e '/CFLAGS = -Wall -t/,/endif/d' \
+ -e '/$(CC).* -o/s|$(CFLAGS)|& $(LDFLAGS)|g' \
+ Makefile.in || die "sed Makefile.in"
+}
+
+src_configure() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ dodoc README* ChangeLog
+ doman adjtimex.8 debian/adjtimexconfig.8
+ dosbin adjtimex debian/adjtimexconfig
+ newinitd "${FILESDIR}"/adjtimex.init adjtimex
+}
+
+pkg_postinst() {
+ einfo "Please run adjtimexconfig to create the configuration file"
+}
diff --git a/net-misc/adjtimex/files/adjtimex-1.29-r1-gentoo-utc.patch b/net-misc/adjtimex/files/adjtimex-1.29-r1-gentoo-utc.patch
new file mode 100644
index 000000000000..ac8730d1ee7d
--- /dev/null
+++ b/net-misc/adjtimex/files/adjtimex-1.29-r1-gentoo-utc.patch
@@ -0,0 +1,30 @@
+--- adjtimex-1.29-debian/debian/adjtimexconfig 2011-12-23 21:29:32.962449759 +0100
++++ adjtimex-1.29/debian/adjtimexconfig 2011-12-23 21:30:00.610638657 +0100
+@@ -3,6 +3,18 @@
+ conffile=/etc/default/adjtimex
+ startfile=/etc/init.d/adjtimex
+
++# Get UTC setting
++params=''
++if [ -f /etc/conf.d/clock ]; then
++ #baselayout-1
++ source /etc/conf.d/clock
++ [ "$CLOCK" == "UTC" ] && params='--utc'
++elif [ -f /etc/conf.d/hwclock ]; then
++ #baselayout-2
++ source /etc/conf.d/hwclock
++ [ "$clock" == "UTC" ] && params='--utc'
++fi
++
+ echo -n "Comparing clocks (this will take 70 sec)..."
+
+ # Get the parameters
+@@ -11,7 +23,7 @@
+ baseline=`awk '/<= tick/{print ($1+$NF)/2}' /etc/adj.adjust`
+ hz=`awk '/USER_HZ/{print $3}' /etc/adj.adjust`
+ /usr/sbin/adjtimex --tick $baseline --frequency 0
+-/usr/sbin/adjtimex --adjust --force-adjust >/etc/adj.adjust
++/usr/sbin/adjtimex ${params} --adjust --force-adjust >/etc/adj.adjust
+ echo "done."
+ ticks=`tail -n 1 /etc/adj.adjust|awk '{print $6}'`
+ freq=`tail -n 1 /etc/adj.adjust|awk '{print $7}'`
diff --git a/net-misc/adjtimex/files/adjtimex.init b/net-misc/adjtimex/files/adjtimex.init
new file mode 100644
index 000000000000..8586deb12c6c
--- /dev/null
+++ b/net-misc/adjtimex/files/adjtimex.init
@@ -0,0 +1,35 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DAEMON=adjtimex
+OPTS="--tick ${TICK} --frequency ${FREQ}"
+CONFD="/etc/conf.d/${DAEMON}"
+
+depend() {
+ before ntp-client ntpd
+ need localmount
+}
+
+checkconfig() {
+ if [ ! -f "${CONFD}" ]; then
+ eerror "Configuration file not found!"
+ eerror "You must run adjtimexconfig to create it."
+ return 1
+ fi
+}
+
+
+start() {
+ checkconfig || return 1
+ ebegin "Regulating system clock with ${DAEMON}..."
+ /usr/sbin/${DAEMON} ${OPTS}
+ eend $?
+}
+
+stop() {
+ :
+}
+
+# vim: ts=4 sw=4 ft=gentoo-init-d:
diff --git a/net-misc/adjtimex/metadata.xml b/net-misc/adjtimex/metadata.xml
new file mode 100644
index 000000000000..c6d862855eb5
--- /dev/null
+++ b/net-misc/adjtimex/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+</pkgmetadata>