summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2023-08-08 13:05:49 -0500
committerBen Kohler <bkohler@gentoo.org>2023-08-08 14:01:31 -0500
commitf7870c72ab7ee6d03a5cb1376452ad9b9dcba3c1 (patch)
treeffd5cf31873d3ca584b90e4ce0b1f0f7895986f1 /net-misc/connman
parentsys-firmware/intel-microcode: add 20230808_p20230804 (diff)
downloadgentoo-f7870c72ab7ee6d03a5cb1376452ad9b9dcba3c1.tar.gz
gentoo-f7870c72ab7ee6d03a5cb1376452ad9b9dcba3c1.tar.bz2
gentoo-f7870c72ab7ee6d03a5cb1376452ad9b9dcba3c1.zip
net-misc/connman: add 1.42
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-misc/connman')
-rw-r--r--net-misc/connman/Manifest1
-rw-r--r--net-misc/connman/connman-1.42.ebuild132
2 files changed, 133 insertions, 0 deletions
diff --git a/net-misc/connman/Manifest b/net-misc/connman/Manifest
index 0990fde8834d..f633d07aa562 100644
--- a/net-misc/connman/Manifest
+++ b/net-misc/connman/Manifest
@@ -1,2 +1,3 @@
+DIST connman-1.42.tar.gz 743965 BLAKE2B 1d9eeb4c917978df502de684128a3464bbc7f3960878842a3ac27295dc5d049641cd5218a9542055b5d9ab2b6114fb773fc8a173f54dca3afe37109ab58bde35 SHA512 98ede28854e5948c8b67c5ba03b156ed9966e9fcda2d39168062873b194a192d12af885c63d9a2cb0b7b5b882b69fdbb0e09c4eb0c6772a76db06de7b9e363d7
DIST connman-24180d1243bf005c721be6f9d8d6da67bb669c55.tar.gz 744924 BLAKE2B 87b1b1dc09c483fb69d75c5c43b89492b32d0e0357fb25208c369a446f85641e5e364ce3bd21f0e43c95e06a8578f28dea4b26decb8a0ebf591bf4c44616645f SHA512 dd6eb7684aeac7a07c504de018b6efda2ceab4ff3b66e4942bf8d8a37e1feee609a63a5b9fa73ce3b3582b6949ea3399f8740bcb7dc39885d239610d3b280d0c
DIST connman-9971144ae862e83f1f5d8cb84c0b62f2542dcdec.tar.gz 743500 BLAKE2B 513380639f02c103f4e9aca73571e00edc42894e612712c20319c3ee9b8845bff41ce05b17016b52b7d34f09c8f74f877a639fd21455b13a5a2ef1554eb0b093 SHA512 bc37dabb13b76e3fa0efd811d664f321b47118d378285dfa06710ec227822c409ed0c60c2f42c00ae081e47ec879ec1b19f784e9fc2346d1d57f6e87550dda22
diff --git a/net-misc/connman/connman-1.42.ebuild b/net-misc/connman/connman-1.42.ebuild
new file mode 100644
index 000000000000..55d02f7ec4ab
--- /dev/null
+++ b/net-misc/connman/connman-1.42.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+inherit autotools systemd tmpfiles
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/network/connman/connman.git"
+else
+ SRC_URI="https://git.kernel.org/pub/scm/network/connman/connman.git/snapshot/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Provides a daemon for managing internet connections"
+HOMEPAGE="https://git.kernel.org/pub/scm/network/connman/connman.git/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="bluetooth debug doc +ethernet examples iptables iwd l2tp networkmanager
++nftables ofono openconnect openvpn policykit pptp tools vpnc +wifi wireguard
+wispr"
+
+REQUIRED_USE="^^ ( iptables nftables )"
+BDEPEND="virtual/pkgconfig"
+COMMON_DEPEND=">=dev-libs/glib-2.16
+ net-libs/gnutls
+ >=sys-apps/dbus-1.2.24
+ sys-libs/readline:0=
+ nftables? (
+ >=net-libs/libnftnl-1.0.4:0=
+ >=net-libs/libmnl-1.0.0:0=
+ )
+ openconnect? ( net-vpn/openconnect )
+ openvpn? ( net-vpn/openvpn )
+ pptp? ( net-dialup/pptpclient )
+ vpnc? ( net-vpn/vpnc )
+ wireguard? ( >=net-libs/libmnl-1.0.0:0= )"
+RDEPEND="${COMMON_DEPEND}
+ bluetooth? ( net-wireless/bluez )
+ iptables? ( >=net-firewall/iptables-1.4.8 )
+ l2tp? ( net-dialup/xl2tpd )
+ ofono? ( net-misc/ofono )
+ policykit? ( sys-auth/polkit )
+ wifi? (
+ !iwd? ( >=net-wireless/wpa_supplicant-0.7.3-r3[dbus] )
+ iwd? ( net-wireless/iwd )
+ )"
+DEPEND="${COMMON_DEPEND}
+ >=sys-kernel/linux-headers-2.6.39"
+
+PATCHES=( "${FILESDIR}/libresolv-musl-fix.patch" )
+
+if [ ! -z ${COMMIT} ]; then
+ S=${WORKDIR}/${PN}-${COMMIT}
+fi
+
+src_prepare() {
+ default
+ eautoreconf
+
+ cp "${FILESDIR}"/connman.initd2 "${T}"
+ if use iwd; then
+ sed -i \
+ -e "s/need dbus/need dbus iwd/" \
+ -e '/start-stop-daemon --start/ s/ -- / -- --wifi=iwd_agent /' \
+ "${T}"/connman.initd2 || die
+ sed -i \
+ -e "/^ExecStart/ s/$/ --wifi=iwd_agent/" \
+ src/connman.service.in || die
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ --localstatedir=/var \
+ --runstatedir=/run \
+ --with-systemdunitdir=$(systemd_get_systemunitdir) \
+ --with-tmpfilesdir="${EPREFIX}"/usr/lib/tmpfiles.d \
+ --enable-client \
+ --enable-datafiles \
+ --enable-loopback=builtin \
+ $(use_enable bluetooth bluetooth builtin) \
+ $(use_enable debug) \
+ $(use_enable ethernet ethernet builtin) \
+ $(use_enable examples test) \
+ $(use_enable l2tp l2tp builtin) \
+ $(use_enable networkmanager nmcompat) \
+ $(use_enable ofono ofono builtin) \
+ $(use_enable openconnect openconnect builtin) \
+ $(use_enable openvpn openvpn builtin) \
+ $(use_enable policykit polkit builtin) \
+ $(use_enable pptp pptp builtin) \
+ $(use_enable tools) \
+ $(use_enable vpnc vpnc builtin) \
+ $(use_enable wireguard) \
+ $(use_enable wispr wispr builtin) \
+ --with-firewall=$(usex iptables "iptables" "nftables" ) \
+ --disable-iospm \
+ --disable-hh2serial-gps
+ )
+ # wifi USE logic to match networkmanager ebuild behavior
+ if use wifi; then
+ if use iwd; then
+ myeconfargs+=( --enable-iwd --disable-wifi )
+ else
+ myeconfargs+=( --disable-iwd --enable-wifi=builtin )
+ fi
+ else
+ myeconfargs+=( --disable-iwd --disable-wifi )
+ fi
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ dobin client/connmanctl
+
+ if use doc; then
+ dodoc doc/*.txt
+ fi
+ keepdir /usr/lib/${PN}/scripts
+ keepdir /var/lib/${PN}
+ newinitd "${T}"/${PN}.initd2 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process connman_resolvconf.conf
+}