summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2019-01-26 12:06:11 +0100
committerPacho Ramos <pacho@gentoo.org>2019-01-26 12:06:23 +0100
commit9f550b9bf83b90b935f178da78aa09c9b9fe4cea (patch)
treebda8750f634ea992b3882b1c08b32e9a872e73d8 /net-misc/gwhois/gwhois-20120626-r1.ebuild
parentmedia-tv/w_scan: Version bump, re bug 612466 (diff)
downloadgentoo-9f550b9bf83b90b935f178da78aa09c9b9fe4cea.tar.gz
gentoo-9f550b9bf83b90b935f178da78aa09c9b9fe4cea.tar.bz2
gentoo-9f550b9bf83b90b935f178da78aa09c9b9fe4cea.zip
net-misc/gwhois: Use Debian sources as they are still maintained
Bug: https://bugs.gentoo.org/675980 Package-Manager: Portage-2.3.58, Repoman-2.3.12 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'net-misc/gwhois/gwhois-20120626-r1.ebuild')
-rw-r--r--net-misc/gwhois/gwhois-20120626-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/net-misc/gwhois/gwhois-20120626-r1.ebuild b/net-misc/gwhois/gwhois-20120626-r1.ebuild
new file mode 100644
index 000000000000..59fb8f605ff6
--- /dev/null
+++ b/net-misc/gwhois/gwhois-20120626-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit readme.gentoo-r1
+
+MY_P="${P/_p/.}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Generic whois"
+HOMEPAGE="https://julijane.de/gwhois/"
+# Debian is still maintaining it
+#SRC_URI="http://gwhois.de/gwhois/${MY_P/-/_}.tar.gz"
+
+DEBIAN_VER="1.2"
+SRC_URI="mirror://debian/pool/main/g/${PN}/${MY_P/-/_}-${DEBIAN_VER}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ www-client/lynx
+ net-misc/curl
+ dev-lang/perl:=
+ dev-perl/libwww-perl
+ dev-perl/Net-LibIDN
+"
+DEPEND=""
+
+DOC_CONTENTS="
+ See included gwhois.xinetd for an example on how to
+ use gwhois as a whois proxy using xinetd.
+ Just copy gwhois.xinetd to /etc/xinetd.d/gwhois
+ and reload xinetd.
+"
+
+src_install() {
+ dodir /etc/gwhois
+ insinto /etc/gwhois
+ doins pattern
+ dobin gwhois
+ doman gwhois.1
+ dodoc TODO "${FILESDIR}/gwhois.xinetd" README.RIPE
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ if [ -f /etc/gwhois/pattern.ripe ]; then
+ ewarn ""
+ ewarn "Will move old /etc/gwhois/pattern.ripe to removethis-pattern.ripe"
+ ewarn "as it causes malfunction with this version."
+ ewarn "If you did not modify the file, just remove it."
+ ewarn ""
+ mv /etc/gwhois/pattern.ripe /etc/gwhois/removethis-pattern.ripe
+ fi
+ readme.gentoo_print_elog
+}