summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 07:50:16 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:10:08 +0100
commit671a31eaae5db702b9671f46ec3589178d8be5ef (patch)
tree2d395a81c05881a626cf6a5a6d244698b34ff3c3 /net-misc/pedro
parentnet-analyzer/ntopng: clean up patches (diff)
downloadgentoo-671a31eaae5db702b9671f46ec3589178d8be5ef.tar.gz
gentoo-671a31eaae5db702b9671f46ec3589178d8be5ef.tar.bz2
gentoo-671a31eaae5db702b9671f46ec3589178d8be5ef.zip
net-misc/pedro: respect PKG_CONFIG
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/pedro')
-rw-r--r--net-misc/pedro/files/pedro-1.6-portage.patch4
-rw-r--r--net-misc/pedro/pedro-1.6.ebuild16
2 files changed, 15 insertions, 5 deletions
diff --git a/net-misc/pedro/files/pedro-1.6-portage.patch b/net-misc/pedro/files/pedro-1.6-portage.patch
index b72a3251b89a..9c9829129b2b 100644
--- a/net-misc/pedro/files/pedro-1.6-portage.patch
+++ b/net-misc/pedro/files/pedro-1.6-portage.patch
@@ -5,7 +5,7 @@
#AC_CONFIG_MACRO_DIR([m4])
-CPPFLAGS="-O2 -g `pkg-config --cflags glib-2.0`"
-+CPPFLAGS="`pkg-config --cflags glib-2.0`"
++CPPFLAGS="`${PKG_CONFIG} --cflags glib-2.0`"
case "${host}" in
i[3456789]86-*-mingw32*)
WIN32="yes"
@@ -14,7 +14,7 @@
*)
WIN32="no"
- LDFLAGS="-L../lib -lpedro `pkg-config --libs glib-2.0` -lm"
-+ LDFLAGS="$LDFLAGS -L../lib -lpedro `pkg-config --libs glib-2.0` -lm"
++ LDFLAGS="$LDFLAGS -L../lib -lpedro `${PKG_CONFIG} --libs glib-2.0` -lm"
;;
esac
ac_config_files="$ac_config_files Makefile src/Makefile src/server/Makefile src/lib/Makefile src/examples/Makefile doc/Makefile"
diff --git a/net-misc/pedro/pedro-1.6.ebuild b/net-misc/pedro/pedro-1.6.ebuild
index 428ab0412b8a..d80053f1055a 100644
--- a/net-misc/pedro/pedro-1.6.ebuild
+++ b/net-misc/pedro/pedro-1.6.ebuild
@@ -1,12 +1,15 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+inherit toolchain-funcs
+
DESCRIPTION="Pedro is a subscription/notification communications system"
HOMEPAGE="http://www.itee.uq.edu.au/~pjr/HomePages/PedroHome.html"
SRC_URI="http://www.itee.uq.edu.au/~pjr/HomePages/PedroFiles/${P}.tgz
doc? ( mirror://gentoo/${PN}-manual-${PV}.tar.gz )"
+S="${WORKDIR}"/${P}
LICENSE="GPL-2"
SLOT="0"
@@ -15,10 +18,17 @@ IUSE="doc examples"
RDEPEND="dev-libs/glib:2"
DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-S="${WORKDIR}"/${P}
+PATCHES=(
+ "${FILESDIR}"/${P}-portage.patch
+)
-PATCHES=( "${FILESDIR}/${P}-portage.patch" )
+src_configure() {
+ tc-export PKG_CONFIG
+
+ default
+}
src_install() {
default