summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-25 18:57:23 +0100
committerSam James <sam@gentoo.org>2021-02-26 14:26:05 +0000
commit4473f3a6338ff271d2f42f956de3e5d26509b51c (patch)
treedd67a9aac4b8bdf890305659d0b8afc6cc6dec61 /net-misc/pyhoca-cli
parentnet-irc/limnoria: Mark ALLARCHES (diff)
downloadgentoo-4473f3a6338ff271d2f42f956de3e5d26509b51c.tar.gz
gentoo-4473f3a6338ff271d2f42f956de3e5d26509b51c.tar.bz2
gentoo-4473f3a6338ff271d2f42f956de3e5d26509b51c.zip
net-misc/pyhoca-cli: Port to python 3.{8,9}
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/pyhoca-cli')
-rw-r--r--net-misc/pyhoca-cli/pyhoca-cli-0.6.1.2.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/net-misc/pyhoca-cli/pyhoca-cli-0.6.1.2.ebuild b/net-misc/pyhoca-cli/pyhoca-cli-0.6.1.2.ebuild
index 3f2ee6193450..107198b5c85b 100644
--- a/net-misc/pyhoca-cli/pyhoca-cli-0.6.1.2.ebuild
+++ b/net-misc/pyhoca-cli/pyhoca-cli-0.6.1.2.ebuild
@@ -3,21 +3,26 @@
EAPI=7
-PYTHON_COMPAT=( python3_7 )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
DESCRIPTION="X2Go command line client"
HOMEPAGE="http://www.x2go.org"
SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
-LICENSE="AGPL-3"
+LICENSE="AGPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="dev-python/setproctitle[${PYTHON_USEDEP}]
+RDEPEND="
+ dev-python/setproctitle[${PYTHON_USEDEP}]
>=net-misc/python-x2go-0.6.1.1[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ # we don't need setuptools at runtime
+ sed -i -e '/install_requires/d' setup.py || die
+ distutils-r1_python_prepare_all
+}
python_install() {
distutils-r1_python_install