summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJay Faulkner <jay@jvf.cc>2023-08-17 16:06:01 -0700
committerSam James <sam@gentoo.org>2023-08-18 04:48:04 +0100
commitae31310d7938f6ca21ce4dd7ceb76e09a604b755 (patch)
tree2e89099fb6b3ed638cd1f7b673eb2b3699e2c44a /net-misc/r8152
parentflag-o-matic.eclass: handle C++ assertions and FORTIFY_SOURCE in _filter-hard... (diff)
downloadgentoo-ae31310d7938f6ca21ce4dd7ceb76e09a604b755.tar.gz
gentoo-ae31310d7938f6ca21ce4dd7ceb76e09a604b755.tar.bz2
gentoo-ae31310d7938f6ca21ce4dd7ceb76e09a604b755.zip
net-misc/r8152: Fix build issues for kernel 6.4.10+
Build of this module was broken by a recent kernel update; this change allows the module to build on 6.4.10+ now as well as against older kernels. Closes: https://bugs.gentoo.org/912330 Signed-off-by: Jay Faulkner <jay@jvf.cc> Closes: https://github.com/gentoo/gentoo/pull/32366 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/r8152')
-rw-r--r--net-misc/r8152/files/r8152-2.16.3-kernel-6.4.10-fix.patch27
-rw-r--r--net-misc/r8152/r8152-2.16.3-r1.ebuild1
-rw-r--r--net-misc/r8152/r8152-2.16.3.ebuild1
3 files changed, 29 insertions, 0 deletions
diff --git a/net-misc/r8152/files/r8152-2.16.3-kernel-6.4.10-fix.patch b/net-misc/r8152/files/r8152-2.16.3-kernel-6.4.10-fix.patch
new file mode 100644
index 000000000000..016e6c24fb0c
--- /dev/null
+++ b/net-misc/r8152/files/r8152-2.16.3-kernel-6.4.10-fix.patch
@@ -0,0 +1,27 @@
+From: https://github.com/wget/realtek-r8152-linux/pull/33.patch
+From ea0387211368754fb1d3fe9f72ddc766ba2dacce Mon Sep 17 00:00:00 2001
+From: Martin Pecka <peckama2@fel.cvut.cz>
+Date: Mon, 14 Aug 2023 13:44:36 +0200
+Subject: [PATCH] Fixed compatibility with Linux 6.4.10+
+
+---
+ r8152.c | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/r8152.c b/r8152.c
+index c3ba2ca..47aad6d 100644
+--- a/r8152.c
++++ b/r8152.c
+@@ -25,6 +25,12 @@
+ #include <linux/ip.h>
+ #include <linux/ipv6.h>
+ #include <net/ip6_checksum.h>
++// Linux 6.4.10 added net/gso.h
++#if defined __has_include
++#if __has_include (<net/gso.h>)
++#include <net/gso.h>
++#endif
++#endif
+ #include <linux/usb/cdc.h>
+ #include <linux/suspend.h>
+ #include <linux/atomic.h>
diff --git a/net-misc/r8152/r8152-2.16.3-r1.ebuild b/net-misc/r8152/r8152-2.16.3-r1.ebuild
index aeaed97ff0a8..d37cee6a6d2d 100644
--- a/net-misc/r8152/r8152-2.16.3-r1.ebuild
+++ b/net-misc/r8152/r8152-2.16.3-r1.ebuild
@@ -23,6 +23,7 @@ IUSE="+center-tap-short"
PATCHES=(
"${FILESDIR}"/${PN}-2.16.3-kernel-5.19-fix.patch
"${FILESDIR}"/${PN}-2.16.3-kernel-6.1-fix.patch
+ "${FILESDIR}"/${PN}-2.16.3-kernel-6.4.10-fix.patch
"${FILESDIR}"/${PN}-2.16.3-asus-c5000-support.patch
)
diff --git a/net-misc/r8152/r8152-2.16.3.ebuild b/net-misc/r8152/r8152-2.16.3.ebuild
index b4d899b3c45e..5130aa2dfa1d 100644
--- a/net-misc/r8152/r8152-2.16.3.ebuild
+++ b/net-misc/r8152/r8152-2.16.3.ebuild
@@ -25,6 +25,7 @@ IUSE="+center-tap-short"
PATCHES=(
"${FILESDIR}"/${PN}-2.16.3-kernel-5.19-fix.patch
"${FILESDIR}"/${PN}-2.16.3-kernel-6.1-fix.patch
+ "${FILESDIR}"/${PN}-2.16.3-kernel-6.4.10-fix.patch
)
pkg_setup() {