summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-12-04 13:58:24 +0100
committerPacho Ramos <pacho@gentoo.org>2022-12-04 15:49:16 +0100
commit408a0f597acad6052c741c15fa7f14cd71024847 (patch)
tree83e9445649b3d34b18d0ddbd618ece41b8b75f07 /net-misc/r8168
parentmedia-fonts/noto-emoji: drop 20211101 (diff)
downloadgentoo-408a0f597acad6052c741c15fa7f14cd71024847.tar.gz
gentoo-408a0f597acad6052c741c15fa7f14cd71024847.tar.bz2
gentoo-408a0f597acad6052c741c15fa7f14cd71024847.zip
net-misc/r8168: add 8.051.02
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'net-misc/r8168')
-rw-r--r--net-misc/r8168/Manifest1
-rw-r--r--net-misc/r8168/r8168-8.051.02.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/r8168/Manifest b/net-misc/r8168/Manifest
index 8a8110c06a6b..a1d893baeda4 100644
--- a/net-misc/r8168/Manifest
+++ b/net-misc/r8168/Manifest
@@ -1,2 +1,3 @@
DIST r8168-8.049.02.tar.bz2 113195 BLAKE2B ee34ac7249d732a867384fdd2c87321a513e7b2770c79d0c13666edca7d4bf752d853d7f91554d7ee716b3f30ec5f3a69aed96221a79a60282f0b6d2f70f05d6 SHA512 8ccb69ab533cde6ff88f0e8af2dd66f7e6ce9467020a727d47748c5109b64d6d14eee6bc151db5ddbe70a476a2def5f2faf3871902b335074f43dd05484d39e0
DIST r8168-8.050.03.tar.bz2 115525 BLAKE2B 9681417c5ded9d089259d80226a16789beaacf31902d896410d581927468c44486a4c496e45d9973851ccca2d4c408159064452849b03347c789390b2b23e57b SHA512 b4c0af2f4e6b9dc36f2db9e33f465d8598afa0b28577ea1f016617e853af00cf41886941fd8173a5b035e219d87a0fae28771230079c88f34039efe669c1e1c6
+DIST r8168-8.051.02.tar.bz2 115969 BLAKE2B 28b809c0330920ee0db7a8f8d41e178882531cd0a6793efeadd9670b1a9b5cbe903061073fd1d461f4234feb41249a244f9ef35cdbb780da498e5a6d6f1a5490 SHA512 2f29a413e7db2b7295ea0a970b3385de1dfd6e41e1820097355687daa5c8d155c1cf6115c72875bff4f366365579bffc81733469a62d76f437065b7e514387ca
diff --git a/net-misc/r8168/r8168-8.051.02.ebuild b/net-misc/r8168/r8168-8.051.02.ebuild
new file mode 100644
index 000000000000..4258fbb99cdb
--- /dev/null
+++ b/net-misc/r8168/r8168-8.051.02.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info linux-mod
+
+DESCRIPTION="r8168 driver for Realtek 8111/8168 PCI-E NICs"
+HOMEPAGE="https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-pci-express-software"
+
+# "GBE Ethernet LINUX driver r8168 for kernel up to 5.19" from above link,
+# we need to mirror it to avoid users from needing to fill a captcha to
+# download
+SRC_URI="https://dev.gentoo.org/~pacho/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+MODULE_NAMES="r8168(net:${S}/src)"
+BUILD_TARGETS="modules"
+IUSE="use-firmware"
+
+CONFIG_CHECK="~!R8169"
+WARNING_R8169="CONFIG_R8169 is enabled. ${P} will not be loaded unless kernel driver Realtek 8169 PCI Gigabit Ethernet (CONFIG_R8169) is DISABLED."
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNELDIR=${KV_DIR}"
+ BUILD_PARAMS+=" ENABLE_USE_FIRMWARE_FILE=$(usex use-firmware y n)"
+}
+
+src_install() {
+ linux-mod_src_install
+ einstalldocs
+}