summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2017-05-27 03:31:49 +0800
committerJason Zaman <perfinion@gentoo.org>2017-05-27 03:32:20 +0800
commit7edde5465da4ee83092bed63e95f8bd29f133550 (patch)
tree25fa127dda3c14a7f7b09bbf0f58860a9c1fb5d3 /net-misc/rclone/rclone-9999.ebuild
parentapp-office/libreoffice: Fix minimal firebird version (diff)
downloadgentoo-7edde5465da4ee83092bed63e95f8bd29f133550.tar.gz
gentoo-7edde5465da4ee83092bed63e95f8bd29f133550.tar.bz2
gentoo-7edde5465da4ee83092bed63e95f8bd29f133550.zip
net-misc/rclone: New package
Ebuild from Jack Coulter and Chris Pritchard Gentoo-Bug: https://bugs.gentoo.org/609510 Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'net-misc/rclone/rclone-9999.ebuild')
-rw-r--r--net-misc/rclone/rclone-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-misc/rclone/rclone-9999.ebuild b/net-misc/rclone/rclone-9999.ebuild
new file mode 100644
index 000000000000..0c936bdca50e
--- /dev/null
+++ b/net-misc/rclone/rclone-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build
+EGO_PN="github.com/ncw/${PN}"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64 ~arm ~x86"
+ EGIT_COMMIT="v${PV}"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+
+DESCRIPTION="A program to sync files to and from various cloud storage providers"
+HOMEPAGE="https://rclone.org/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_install() {
+ dobin ${PN}
+ doman src/${EGO_PN}/${PN}.1
+ dodoc src/${EGO_PN}/README.md
+}