summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-11-15 17:12:33 +0000
committerSam James <sam@gentoo.org>2023-11-15 17:13:07 +0000
commiteb08e4aa7127cf0fd098b3e430bb20e39f0c3aa1 (patch)
tree76652639311c55f0bb1cd43a326bc1dd41cbcde1 /net-misc/socat
parentapp-crypt/p11-kit: add 0.25.3 (diff)
downloadgentoo-eb08e4aa7127cf0fd098b3e430bb20e39f0c3aa1.tar.gz
gentoo-eb08e4aa7127cf0fd098b3e430bb20e39f0c3aa1.tar.bz2
gentoo-eb08e4aa7127cf0fd098b3e430bb20e39f0c3aa1.zip
net-misc/socat: add 1.8.0.0
Closes: https://bugs.gentoo.org/898738 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/socat')
-rw-r--r--net-misc/socat/Manifest1
-rw-r--r--net-misc/socat/socat-1.8.0.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/net-misc/socat/Manifest b/net-misc/socat/Manifest
index ae6c8cfa71c3..ea585d6d46d3 100644
--- a/net-misc/socat/Manifest
+++ b/net-misc/socat/Manifest
@@ -1,2 +1,3 @@
DIST socat-1.7.4.3.tar.gz 655520 BLAKE2B d91de7ef55332001e6439f64130555b9558338fb9b6c15c91ab5efc8f86a2e7e0f5fe0b292754731a198d83be5f511c3388c65c7c7f559c55691f42703f1849b SHA512 81cb34c245052b6a0ae38a711591358460b6070957af4a9eeb11a3cadb4aff184eeaedabbc7ecdc7fdf21a6126c06f90f19b24a87ce74b30bfd60a3879181046
DIST socat-1.7.4.4.tar.bz2 522127 BLAKE2B 221b1c7c1ef0ac9c2402a6917ce7740a7ed857ceae4f4c346ed3c69c261fd0f9ca667e21cab5f97427d3947b06fdb0ac6d090852465878db968a24b8ece587ad SHA512 3eedfbf599ecf1d6fd391d03d710044bc5e18a762395bc4cb151b96fe673d405a6630da3070ecddd5ac558126b56aa65feaa74d528eeb755a04aa0ec61690651
+DIST socat-1.8.0.0.tar.bz2 564066 BLAKE2B b0b3e8c46f746b1aaff7390bbf9521cca8c421f3c20cd7a7f7d8ffd3d7b5e5e881e2477642f7d29247ee5a9d9edf6c8370a43c5f2757e456966b17e3ba08a58a SHA512 dd15c31204f2843ab473a30aa841e960e7c00ac7487e2265d69f9e8ea0afde3841d57cfcb99084f03935d7223da65cee27166837f2f9b3a20c834bc161af802b
diff --git a/net-misc/socat/socat-1.8.0.0.ebuild b/net-misc/socat/socat-1.8.0.0.ebuild
new file mode 100644
index 000000000000..ca3d608643a5
--- /dev/null
+++ b/net-misc/socat/socat-1.8.0.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo flag-o-matic toolchain-funcs
+
+MY_P=${P/_beta/-b}
+DESCRIPTION="Multipurpose relay (SOcket CAT)"
+HOMEPAGE="http://www.dest-unreach.org/socat/ https://repo.or.cz/socat.git"
+SRC_URI="http://www.dest-unreach.org/socat/download/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="ipv6 readline ssl tcpd"
+
+DEPEND="
+ ssl? ( >=dev-libs/openssl-3:= )
+ readline? ( sys-libs/readline:= )
+ tcpd? ( sys-apps/tcp-wrappers )
+"
+RDEPEND="${DEPEND}"
+
+# Tests are a large bash script
+# Hard to disable individual tests needing network or privileges
+# in 1.7.4.2: FAILED: 59 329
+#RESTRICT="test"
+
+DOCS=( BUGREPORTS CHANGES DEVELOPMENT EXAMPLES FAQ FILES PORTING README SECURITY )
+
+src_configure() {
+ # bug #293324
+ filter-flags '-Wno-error*'
+
+ tc-export AR
+
+ local myeconfargs=(
+ $(use_enable ssl openssl)
+ $(use_enable readline)
+ $(use_enable ipv6 ip6)
+ $(use_enable tcpd libwrap)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ edo ./test.sh -v --expect-fail 217,311,313,410,478,528
+}
+
+src_install() {
+ default
+
+ docinto html
+ dodoc doc/*.html doc/*.css
+}