summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-30 23:52:31 +0100
committerSam James <sam@gentoo.org>2022-05-30 23:53:37 +0100
commit556d50f4c7fa81a9b8b4280b3d3e92486e8ab5ae (patch)
tree97c4a3dc54c54c892c664dc429747f953c1e094d /net-misc/streamlink
parentdev-python/versioningit: new package, add 1.1.1 (diff)
downloadgentoo-556d50f4c7fa81a9b8b4280b3d3e92486e8ab5ae.tar.gz
gentoo-556d50f4c7fa81a9b8b4280b3d3e92486e8ab5ae.tar.bz2
gentoo-556d50f4c7fa81a9b8b4280b3d3e92486e8ab5ae.zip
net-misc/streamlink: add 4.0.1
Closes: https://bugs.gentoo.org/846167 Closes: https://bugs.gentoo.org/789771 Closes: https://bugs.gentoo.org/842243 Closes: https://bugs.gentoo.org/788466 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/streamlink')
-rw-r--r--net-misc/streamlink/Manifest1
-rw-r--r--net-misc/streamlink/streamlink-4.0.1.ebuild57
-rw-r--r--net-misc/streamlink/streamlink-9999.ebuild39
3 files changed, 69 insertions, 28 deletions
diff --git a/net-misc/streamlink/Manifest b/net-misc/streamlink/Manifest
index 0335efdca28a..5dcfc55bd281 100644
--- a/net-misc/streamlink/Manifest
+++ b/net-misc/streamlink/Manifest
@@ -1,3 +1,4 @@
DIST streamlink-1.3.1.tar.gz 695736 BLAKE2B 377fdfb6a90b2e680697dda57b4237a14b63df1e33af5fcbf8333ebd3bc85f877e0e3c4698ab965d766560234cc0ddb7399c8b43eac1b3bbbc4984bfd2ed2194 SHA512 d6c299c6ea444d5b5956a752be8a5c192ca2aae25087db4045035c53fa078396b1bf89203cd55a82630c33492117323892caa5cf27c9dc9ea4b64602dbfdd87c
DIST streamlink-2.0.0.tar.gz 497816 BLAKE2B e0d8ebf2ae72bb2dc9c9a22810577a34ae6fe3a81bb75b03f5186c69170b9ed94311c1e018bd2a2a0e9a5fc1d8f8470de431f602bd3c8bb2d215c9c8d87dc867 SHA512 ce8b34670ea991ddd9b86eb4f05233468ad9df7ea743ed047cd2e3de8d0844dcded082df1215273e8a22ac5386dd17f64c80662b80fb8dbfae421b7f18c146d6
+DIST streamlink-4.0.1.tar.gz 512977 BLAKE2B ea897f80c72d6ec29340fc7fc3c915fd7e09f06df8eecad14ed3e36cb7be0bc792fe867327b4d440c9208886cb28b93255e0ef03e62f0d423a4b38f9438f9ca2 SHA512 f4a40e5f2cf6e564c1baebcafab64a6fd6345dcb1ff626a4ad3fa123a5227f0774347d22260b5e672b6e225c2924c8f50b20abdbf072e560da1bc6626fc4d62b
DIST streamlink.1-2.0.0.man.xz 12956 BLAKE2B e4e24f1f04a4edabcc9973005a1097a6ed0cf450bf65624fee9dee13c39312e96d48a91c5558b5b4f2e1122510ea64d497588c42c1c6f2a83f1bb6fd92843419 SHA512 3d857b953a10a4c4ca9906cd03d170a7b76ecf724c3627571b90fa584c729cce54f492438c7e9aae32fc65b5c0561e0d325b0b1f9bcc69a98bc000b81e5492c9
diff --git a/net-misc/streamlink/streamlink-4.0.1.ebuild b/net-misc/streamlink/streamlink-4.0.1.ebuild
new file mode 100644
index 000000000000..fa55f7a3837a
--- /dev/null
+++ b/net-misc/streamlink/streamlink-4.0.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/streamlink/${PN}.git"
+ inherit git-r3
+fi
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE='xml(+),threads(+)'
+inherit distutils-r1
+
+DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
+HOMEPAGE="https://streamlink.github.io/"
+
+if [[ ${PV} != 9999* ]]; then
+ SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD-2 Apache-2.0"
+SLOT="0"
+
+DEPEND="
+ $(python_gen_cond_dep '
+ >dev-python/requests-2.21.0[${PYTHON_USEDEP}]
+ dev-python/isodate[${PYTHON_USEDEP}]
+ dev-python/websocket-client[${PYTHON_USEDEP}]
+ dev-python/pycountry[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
+ >=dev-python/versioningit-1.1.1[${PYTHON_USEDEP}]
+ ')
+"
+RDEPEND="${DEPEND}
+ media-video/rtmpdump
+ media-video/ffmpeg
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/versioningit[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ >=dev-python/freezegun-1.0.0[${PYTHON_USEDEP}]
+ )
+ ')"
+
+distutils_enable_tests pytest
+
+python_configure_all() {
+ # Avoid iso-639, iso3166 dependencies since we use pycountry.
+ export STREAMLINK_USE_PYCOUNTRY=1
+}
diff --git a/net-misc/streamlink/streamlink-9999.ebuild b/net-misc/streamlink/streamlink-9999.ebuild
index 92c0803d4cf5..fa55f7a3837a 100644
--- a/net-misc/streamlink/streamlink-9999.ebuild
+++ b/net-misc/streamlink/streamlink-9999.ebuild
@@ -1,31 +1,29 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="https://github.com/streamlink/${PN}.git"
- GIT_ECLASS="git-r3"
+ inherit git-r3
fi
-PYTHON_COMPAT=( python3_{8..9} )
-PYTHON_REQ_USE='xml(+),threads(+)'
DISTUTILS_SINGLE_IMPL=1
-inherit distutils-r1 ${GIT_ECLASS}
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE='xml(+),threads(+)'
+inherit distutils-r1
DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
HOMEPAGE="https://streamlink.github.io/"
if [[ ${PV} != 9999* ]]; then
SRC_URI="https://github.com/streamlink/${PN}/releases/download/${PV}/${P}.tar.gz"
- SRC_URI+=" https://dev.gentoo.org/~leio/distfiles/streamlink.1-${PV}.man.xz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64"
fi
LICENSE="BSD-2 Apache-2.0"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
DEPEND="
$(python_gen_cond_dep '
@@ -34,6 +32,7 @@ DEPEND="
dev-python/websocket-client[${PYTHON_USEDEP}]
dev-python/pycountry[${PYTHON_USEDEP}]
>=dev-python/pycryptodome-3.4.3[${PYTHON_USEDEP}]
+ >=dev-python/versioningit-1.1.1[${PYTHON_USEDEP}]
')
"
RDEPEND="${DEPEND}
@@ -42,33 +41,17 @@ RDEPEND="${DEPEND}
"
BDEPEND="
$(python_gen_cond_dep '
+ dev-python/versioningit[${PYTHON_USEDEP}]
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/requests-mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
>=dev-python/freezegun-1.0.0[${PYTHON_USEDEP}]
)
')"
-src_prepare() {
- distutils-r1_src_prepare
- if [[ ${PV} != 9999* ]]; then
- mv "${WORKDIR}"/streamlink.1-${PV}.man "${WORKDIR}"/streamlink.1 || die
- fi
-}
+distutils_enable_tests pytest
python_configure_all() {
# Avoid iso-639, iso3166 dependencies since we use pycountry.
export STREAMLINK_USE_PYCOUNTRY=1
}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if [[ ${PV} != 9999* ]]; then
- doman "${WORKDIR}"/streamlink.1
- fi
-}