summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/vrrpd/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/vrrpd/files')
-rw-r--r--net-misc/vrrpd/files/vrrpd-1.9-rollup.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/vrrpd/files/vrrpd-1.9-rollup.patch b/net-misc/vrrpd/files/vrrpd-1.9-rollup.patch
new file mode 100644
index 000000000000..72c5f3ad47f3
--- /dev/null
+++ b/net-misc/vrrpd/files/vrrpd-1.9-rollup.patch
@@ -0,0 +1,37 @@
+This is a partial rollup of patches submitted to upstream to clean up the
+packaging.
+
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+
+diff --git a/Makefile b/Makefile
+old mode 100755
+new mode 100644
+index d7f3309..869d06d
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,8 @@
+ PROJECT=vrrpd
+
+-ALL_EXE=vrrpd
++ALL_EXE=vrrpd atropos
+
++ATROPOS_OBJS = atropos.o
+ VRRPD_OBJS = vrrpd.o libnetlink.o ipaddr.o
+
+ MAIN_OPT=
+@@ -18,9 +19,13 @@ COMMON_CFLAGS= $(MAIN_OPT) $(INCLUDEOPT) $(PROF_OPT) $(DBG_OPT) $(MACHINEOPT)
+ CC=gcc
+ CFLAGS= $(COMMON_CFLAGS) -Wall
+
++all: $(ALL_EXE)
++
++atropos: $(ATROPOS_OBJS)
++ $(CC) $(PROF_OPT) -o $@ $^
++
+ vrrpd : $(VRRPD_OBJS)
+- $(CC) $(PROF_OPT) -o $@ $(VRRPD_OBJS) $(LINKLIB)
+- $(CC) atropos.c -o atropos
++ $(CC) $(PROF_OPT) -o $@ $^ $(LINKLIB)
+
+ vrrpd.o: vrrpd.h
+ libnetlink.o: libnetlink.h