summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2023-09-01 18:17:18 +0100
committerMatthew Smith <matthew@gentoo.org>2023-09-01 18:21:15 +0100
commitd094dd12e83313941d9936cdaa89b62dde62035e (patch)
tree0654fe63b33458ebe0799107255182c0b069c7fc /net-misc/xmrig
parentnet-misc/xmrig: drop 6.19.0-r1, 6.19.1, 6.19.2, 6.19.3 (diff)
downloadgentoo-d094dd12e83313941d9936cdaa89b62dde62035e.tar.gz
gentoo-d094dd12e83313941d9936cdaa89b62dde62035e.tar.bz2
gentoo-d094dd12e83313941d9936cdaa89b62dde62035e.zip
net-misc/xmrig: filter FORTIFY_SOURCE=3
Closes: https://bugs.gentoo.org/913420 Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'net-misc/xmrig')
-rw-r--r--net-misc/xmrig/xmrig-6.18.1-r2.ebuild (renamed from net-misc/xmrig/xmrig-6.18.1-r1.ebuild)9
-rw-r--r--net-misc/xmrig/xmrig-6.20.0-r1.ebuild (renamed from net-misc/xmrig/xmrig-6.20.0.ebuild)9
-rw-r--r--net-misc/xmrig/xmrig-9999.ebuild9
3 files changed, 24 insertions, 3 deletions
diff --git a/net-misc/xmrig/xmrig-6.18.1-r1.ebuild b/net-misc/xmrig/xmrig-6.18.1-r2.ebuild
index 89809b2e8627..7152c4ad7635 100644
--- a/net-misc/xmrig/xmrig-6.18.1-r1.ebuild
+++ b/net-misc/xmrig/xmrig-6.18.1-r2.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake systemd
+inherit cmake flag-o-matic systemd toolchain-funcs
DESCRIPTION="RandomX, CryptoNight, KawPow, AstroBWT, and Argon2 CPU/GPU miner"
HOMEPAGE="https://xmrig.com https://github.com/xmrig/xmrig"
@@ -45,6 +45,13 @@ src_prepare() {
}
src_configure() {
+ # JIT broken with FORTIFY_SOURCE=3
+ # Bug #913420
+ if tc-enables-fortify-source; then
+ filter-flags -D_FORTIFY_SOURCE=3
+ append-cppflags -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2
+ fi
+
local mycmakeargs=(
-DWITH_SSE4_1=$(usex cpu_flags_x86_sse4_1)
-DWITH_HWLOC=$(usex hwloc)
diff --git a/net-misc/xmrig/xmrig-6.20.0.ebuild b/net-misc/xmrig/xmrig-6.20.0-r1.ebuild
index 7f9e7dd2397c..a36872e00718 100644
--- a/net-misc/xmrig/xmrig-6.20.0.ebuild
+++ b/net-misc/xmrig/xmrig-6.20.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake systemd
+inherit cmake flag-o-matic systemd toolchain-funcs
DESCRIPTION="RandomX, CryptoNight, KawPow, AstroBWT, and Argon2 CPU/GPU miner"
HOMEPAGE="https://xmrig.com https://github.com/xmrig/xmrig"
@@ -44,6 +44,13 @@ src_prepare() {
}
src_configure() {
+ # JIT broken with FORTIFY_SOURCE=3
+ # Bug #913420
+ if tc-enables-fortify-source; then
+ filter-flags -D_FORTIFY_SOURCE=3
+ append-cppflags -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2
+ fi
+
local mycmakeargs=(
-DWITH_SSE4_1=$(usex cpu_flags_x86_sse4_1)
-DWITH_HWLOC=$(usex hwloc)
diff --git a/net-misc/xmrig/xmrig-9999.ebuild b/net-misc/xmrig/xmrig-9999.ebuild
index 7f9e7dd2397c..a36872e00718 100644
--- a/net-misc/xmrig/xmrig-9999.ebuild
+++ b/net-misc/xmrig/xmrig-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake systemd
+inherit cmake flag-o-matic systemd toolchain-funcs
DESCRIPTION="RandomX, CryptoNight, KawPow, AstroBWT, and Argon2 CPU/GPU miner"
HOMEPAGE="https://xmrig.com https://github.com/xmrig/xmrig"
@@ -44,6 +44,13 @@ src_prepare() {
}
src_configure() {
+ # JIT broken with FORTIFY_SOURCE=3
+ # Bug #913420
+ if tc-enables-fortify-source; then
+ filter-flags -D_FORTIFY_SOURCE=3
+ append-cppflags -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2
+ fi
+
local mycmakeargs=(
-DWITH_SSE4_1=$(usex cpu_flags_x86_sse4_1)
-DWITH_HWLOC=$(usex hwloc)