summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-09-16 13:34:51 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-09-16 13:35:09 +0300
commit580ab49ecf2abf7385c8b2bc9fb221cf8f97af6b (patch)
treefdf4072d81297fb27dd2745fc455a6d577e448c4 /net-misc
parentsys-kernel/vanilla-sources: Automated version bump to {4.4.156,4.9.127,4.14.7... (diff)
downloadgentoo-580ab49ecf2abf7385c8b2bc9fb221cf8f97af6b.tar.gz
gentoo-580ab49ecf2abf7385c8b2bc9fb221cf8f97af6b.tar.bz2
gentoo-580ab49ecf2abf7385c8b2bc9fb221cf8f97af6b.zip
net-misc/teamviewer: version bump (v13.2.13582)
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/teamviewer/Manifest2
-rw-r--r--net-misc/teamviewer/teamviewer-13.2.13582.ebuild129
2 files changed, 131 insertions, 0 deletions
diff --git a/net-misc/teamviewer/Manifest b/net-misc/teamviewer/Manifest
index a84e0ba8f8a5..b5b1f436bed7 100644
--- a/net-misc/teamviewer/Manifest
+++ b/net-misc/teamviewer/Manifest
@@ -2,3 +2,5 @@ DIST teamviewer_13.1.3026_amd64.tar.xz 11500188 BLAKE2B 98dab12224ea65cdb7c45f01
DIST teamviewer_13.1.3026_i386.tar.xz 11343300 BLAKE2B c0170acf9c67f34755800a0200016dacb6f93f3f3805932fbf467dc19bb0213fce74363a0bc703af1c62b4c1bafda2257bd0cc2c52aad4dd1f22ae5a9fb2d486 SHA512 f7dac040de4a0ac3489ee5e911c3c278723cee2372bd42a4a929d3cb268f735eb73cccc514a8d72cc49c82277869533289e3195936218be6db323e732c9c380e
DIST teamviewer_13.1.8286_amd64.tar.xz 11574812 BLAKE2B 9941a3c1894e4b1a285ac61bdeffb47629c7972d19a573016c357275b3fc5ede51838f35acb2debe36ccd96c20cab6478868b78c831ab7137cb1196440e62297 SHA512 76b10c1df368f4c639ff60a69dc541f791b82b73a19accce4c60fdfcff2922a4a674e08da73df570587e840088b466f4791f8da0691582451259965044a18ccb
DIST teamviewer_13.1.8286_i386.tar.xz 11422756 BLAKE2B 0bc408cbbf44bdeb84ce8c1d1274e8253ec261571670bce46130a325729eb801f101afae768a38cc43719abe625ebc89b12f3eacba507c9193e1049366b1c2c0 SHA512 1fdbdacfdd2f7884af246326e63f6bcfaf8efc95ec326f566216a173509a21891e4c66d85ef1290648a890135ae3fe23f185da36346d68c016da923b7c9c644a
+DIST teamviewer_13.2.13582_amd64.tar.xz 11472084 BLAKE2B adcec9bfb9ccedbc958eceef611f0f04b9b192313d3c060202166b77a4c2623008cbac147e9136925156446ef10a143283735f13c52cebd30e924329d1ff2453 SHA512 82a7cce2046a0dd268181044093e0d0bccfef0cbc2e842a94bc9a9fda87062b7236ff23606dd482e68baf8194b189ae6994603ac0584fad624d7f47366f34af3
+DIST teamviewer_13.2.13582_i386.tar.xz 11406728 BLAKE2B 91bd8fe9c30f8be9de2ce089a0f678e90cb371233c2e8a05e695aa203634846510f1381b449007648a4b0e6b2b201a654b71dae1c63ade0eb08e732ae343766b SHA512 9453b289ba99f63c75e1acb03d3e5a343db4814cffc4464b46116b269a6556e9fda4b1d963fa35e2e912ae959b09fd5dcfbc26ca31ccd76e6d3235be2d9cf55e
diff --git a/net-misc/teamviewer/teamviewer-13.2.13582.ebuild b/net-misc/teamviewer/teamviewer-13.2.13582.ebuild
new file mode 100644
index 000000000000..a897021c7c98
--- /dev/null
+++ b/net-misc/teamviewer/teamviewer-13.2.13582.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN=${PN}${PV/\.*}
+inherit desktop gnome2-utils systemd
+
+DESCRIPTION="All-In-One Solution for Remote Access and Support over the Internet"
+HOMEPAGE="https://www.teamviewer.com"
+SRC_URI="amd64? ( https://dl.tvcdn.de/download/linux/version_${PV/\.*}x/${PN}_${PV}_amd64.tar.xz )
+ x86? ( https://dl.tvcdn.de/download/linux/version_${PV/\.*}x/${PN}_${PV}_i386.tar.xz )"
+
+LICENSE="TeamViewer MIT"
+SLOT="${PV/\.*}"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-apps/sed"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ sys-apps/dbus
+"
+
+RESTRICT="bindist mirror"
+
+# Silence QA messages
+QA_PREBUILT="opt/${MY_PN}/*"
+
+S="${WORKDIR}"/teamviewer
+
+src_prepare() {
+ default
+
+ # Switch operation mode from 'portable' to 'installed'
+ sed -e "s/TAR_NI/TAR_IN/g" -i tv_bin/script/tvw_config || die
+
+ sed -e "/^ExecStart/s/${PN}/${MY_PN}/" \
+ -i tv_bin/script/teamviewerd.service || die
+}
+
+src_install() {
+ local dst="/opt/${MY_PN}" # install destination
+
+ # Quirk:
+ # Remove Intel 80386 32-bit ELF binary 'libdepend' present in all
+ # archives. It will trip the 'emerge @preserved-libs' logic on amd64
+ # when changing the ABI of one of its dependencies. According to the
+ # TeamViewer devs, this binary is an unused remnant of previous Wine-
+ # based builds and will be removed in future releases anyway
+ rm tv_bin/script/libdepend
+
+ insinto ${dst}
+ doins -r tv_bin
+
+ # Set permissions for executables and libraries
+ for exe in $(find tv_bin -type f -executable -or -name '*.so'); do
+ fperms 755 ${dst}/${exe}
+ done
+
+ # No slotting here, binary expects this service path
+ newinitd "${FILESDIR}"/teamviewerd13.init teamviewerd
+ systemd_dounit tv_bin/script/teamviewerd.service
+
+ insinto /usr/share/dbus-1/services
+ doins tv_bin/script/com.teamviewer.TeamViewer.service
+ doins tv_bin/script/com.teamviewer.TeamViewer.Desktop.service
+
+ insinto /usr/share/polkit-1/actions
+ doins tv_bin/script/com.teamviewer.TeamViewer.policy
+
+ for size in 16 24 32 48 256; do
+ newicon -s ${size} tv_bin/desktop/teamviewer_${size}.png TeamViewer.png
+ done
+
+ # Install documents (NOTE: using 'dodoc -r doc' instead of loop will
+ # have the undesired result of installing subdirectory 'doc' in /usr/
+ # share/doc/teamviewer-<version>)
+ for doc in $(find doc -type f); do
+ dodoc ${doc}
+ done
+
+ keepdir /etc/${MY_PN}
+ dosym ../../etc/${MY_PN} ${dst}/config
+
+ # Create directory and symlink for log files (NOTE: according to Team-
+ # Viewer devs, all paths are hard-coded in the binaries; therefore
+ # using the same path as the DEB/RPM archives, i.e. '/var/log/teamviewer
+ # <major-version>')
+ keepdir /var/log/${MY_PN}
+ dosym ../../var/log/${MY_PN} ${dst}/logfiles
+
+ dodir /opt/bin
+ dosym ${dst}/tv_bin/teamviewerd /opt/bin/teamviewerd
+ dosym ${dst}/tv_bin/script/teamviewer /opt/bin/teamviewer
+
+ make_desktop_entry teamviewer "TeamViewer ${SLOT}" TeamViewer
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ elog "Please note that parallel installation of multiple versions of"
+ elog "TeamViewer is currently not supported at runtime. Bug #621818"
+ elog ""
+ elog "Before using TeamViewer, you need to start its daemon:"
+ elog "OpenRC:"
+ elog "# /etc/init.d/teamviewerd start"
+ elog "# rc-update add teamviewerd default"
+ elog
+ elog "Systemd:"
+ elog "# systemctl start teamviewerd.service"
+ elog "# systemctl enable teamviewerd.service"
+ elog
+ elog "To display additional command line options simply run:"
+ elog "$ teamviewer help"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}