summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-p2p/gift-gnutella
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-p2p/gift-gnutella')
-rw-r--r--net-p2p/gift-gnutella/Manifest1
-rw-r--r--net-p2p/gift-gnutella/files/cacheupdate.sh73
-rw-r--r--net-p2p/gift-gnutella/gift-gnutella-0.0.11.ebuild47
-rw-r--r--net-p2p/gift-gnutella/metadata.xml8
4 files changed, 129 insertions, 0 deletions
diff --git a/net-p2p/gift-gnutella/Manifest b/net-p2p/gift-gnutella/Manifest
new file mode 100644
index 000000000000..ad7879ed5ede
--- /dev/null
+++ b/net-p2p/gift-gnutella/Manifest
@@ -0,0 +1 @@
+DIST gift-gnutella-0.0.11.tar.bz2 405742 SHA256 5a28fd53ad617a6acdc3042144829e74822510d80963a6ca35e7d256d5a06f86
diff --git a/net-p2p/gift-gnutella/files/cacheupdate.sh b/net-p2p/gift-gnutella/files/cacheupdate.sh
new file mode 100644
index 000000000000..ee6f832aae28
--- /dev/null
+++ b/net-p2p/gift-gnutella/files/cacheupdate.sh
@@ -0,0 +1,73 @@
+#!/bin/bash
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+CACHE_LIST="g2.tjtech.org/g2/
+ gwc1c.olden.ch.3557.nyud.net:8080/gwc/
+ gwc.eod.cc/skulls.php
+ skulls.mi-cha-el.org/skulls.php
+ gwc.frodoslair.net/skulls/skulls"
+
+URLFILE="?urlfile=1\&client=GEN2\&version=0.2"
+HOSTFILE="?hostfile=1\&client=GEN2\&version=0.2"
+
+if [ -d ~/.giFT/Gnutella/ ]; then
+ cd ~/.giFT/Gnutella
+
+ # Try to fetch an updated list
+ wget http://gcachescan.jonatkins.com/ -O .my_list &> /dev/null
+ if [[ $? -eq 0 ]] ; then
+ my_cache_list=$(grep gcachedetail .my_list | sed -e "s:.*gcachedetail.cgi?\(.*\)\">?</a>.*:\1:g" | head -n 10)
+ [[ -n ${my_cache_list} ]] && CACHE_LIST=${my_cache_list}
+ else
+ echo "Failed to fetch gwebcaches' list, trying with local list."
+ fi
+
+ # Fetch gwebcaches
+ ok=0
+ for cache in ${CACHE_LIST} ; do
+ wget ${cache}${URLFILE} -O .gwebcaches.new &> /dev/null
+ if [[ $? -ne 0 ]] ; then
+ echo "Failed to fetch gwebcaches file from ${cache}"
+ #CACHE_LIST=${CACHE_LIST/${cache}/}
+ elif [[ -z $(grep -e "^http://.*" .gwebcaches.new) ]] || [[ -n $(grep ERROR .gwebcaches.new) ]] ; then
+ echo "Fetched file from ${cache} is invalid"
+ else
+ mv .gwebcaches.new gwebcaches
+ echo -e "\ngwebcaches fetched\n"
+ ok=1
+ break
+ fi
+ done
+ if [[ $ok -ne 1 ]] ; then
+ echo "Couldn't fetch gwebcaches!"
+ exit 1
+ fi
+
+ # Fetch nodes
+ ok=0
+ for cache in ${CACHE_LIST} ; do
+ wget ${cache}${HOSTFILE} -O .nodes.new &> /dev/null
+ if [[ $? -ne 0 ]] ; then
+ echo "Failed to fetch nodes file from ${cache}"
+ #CACHE_LIST=${CACHE_LIST/${cache}/}
+ elif [[ -n $(grep ERROR .nodes.new) ]] ; then
+ echo "Fetched file from ${cache} is invalid"
+ else
+ mv .nodes.new nodes
+ echo -e "\nnodes fetched\n"
+ ok=1
+ break
+ fi
+ done
+ if [[ $ok -ne 1 ]] ; then
+ echo "Couldn't fetch nodes!"
+ exit 1
+ fi
+
+ rm .my_list
+ echo -e "\nUpdate complete!"
+else
+ echo " ~/.giFT/Gnutella/ does not exist. Please run gift-setup."
+fi
diff --git a/net-p2p/gift-gnutella/gift-gnutella-0.0.11.ebuild b/net-p2p/gift-gnutella/gift-gnutella-0.0.11.ebuild
new file mode 100644
index 000000000000..43c817730a04
--- /dev/null
+++ b/net-p2p/gift-gnutella/gift-gnutella-0.0.11.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="The giFT Gnutella plugin"
+HOMEPAGE="http://gift.sf.net/"
+SRC_URI="mirror://sourceforge/gift/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="alpha amd64 ia64 ~ppc sparc x86 ~x86-fbsd"
+IUSE="xml"
+
+RDEPEND=">=net-p2p/gift-0.11.6"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ app-arch/bzip2
+ dev-libs/libxml2"
+
+src_compile() {
+ econf $(use_with xml libxml) || die "failed to configure"
+ emake || die "failed to build"
+}
+
+src_install() {
+ einstall giftconfdir="${D}"/etc/giFT \
+ plugindir="${D}"/usr/$(get_libdir)/giFT \
+ datadir="${D}"/usr/share \
+ giftperldir="${D}"/usr/bin \
+ libgiftincdir="${D}"/usr/include/libgift || die "einstall failed"
+ newbin "${FILESDIR}"/cacheupdate.sh ${PN}-cacheupdate.sh
+}
+
+pkg_postinst() {
+ elog "It is recommended that you re-run gift-setup as"
+ elog "the user you will run the giFT daemon as:"
+ elog "\tgift-setup"
+ echo
+ elog "Alternatively you can add the following line to"
+ elog "your ~/.giFT/giftd.conf configuration file:"
+ elog "plugins = Gnutella"
+ echo
+ elog "To update your caches, run:"
+ elog "\t${PN}-cacheupdate.sh"
+}
diff --git a/net-p2p/gift-gnutella/metadata.xml b/net-p2p/gift-gnutella/metadata.xml
new file mode 100644
index 000000000000..166c0c557414
--- /dev/null
+++ b/net-p2p/gift-gnutella/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-p2p</herd>
+ <upstream>
+ <remote-id type="sourceforge">gift</remote-id>
+ </upstream>
+</pkgmetadata>