summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2016-12-04 16:50:55 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2016-12-05 07:56:20 -0800
commit9ceddf8ef8152d588da83666434c20f7c3cf5303 (patch)
tree09657a005ea3a1a5ea6f18dc67ce9d45f7ff4824 /net-proxy/haproxy/haproxy-9999.ebuild
parentprofiles: net-proxy/haproxy feature masking. (diff)
downloadgentoo-9ceddf8ef8152d588da83666434c20f7c3cf5303.tar.gz
gentoo-9ceddf8ef8152d588da83666434c20f7c3cf5303.tar.bz2
gentoo-9ceddf8ef8152d588da83666434c20f7c3cf5303.zip
net-proxy/haproxy: prepare for split 9999 on different major versions
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'net-proxy/haproxy/haproxy-9999.ebuild')
-rw-r--r--net-proxy/haproxy/haproxy-9999.ebuild146
1 files changed, 0 insertions, 146 deletions
diff --git a/net-proxy/haproxy/haproxy-9999.ebuild b/net-proxy/haproxy/haproxy-9999.ebuild
deleted file mode 100644
index 97a58d9c88f9..000000000000
--- a/net-proxy/haproxy/haproxy-9999.ebuild
+++ /dev/null
@@ -1,146 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="6"
-
-inherit user versionator toolchain-funcs flag-o-matic systemd linux-info git-r3
-
-MY_P="${PN}-${PV/_beta/-dev}"
-
-DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
-HOMEPAGE="http://haproxy.1wt.eu"
-EGIT_REPO_URI="http://master.formilux.org/git/people/willy/haproxy.git"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS=""
-IUSE="+crypt doc examples libressl slz net_ns +pcre pcre-jit ssl tools vim-syntax +zlib" # lua
-REQUIRED_USE="pcre-jit? ( pcre )
- ?? ( slz zlib )"
-
-DEPEND="
- pcre? (
- dev-libs/libpcre
- pcre-jit? ( dev-libs/libpcre[jit] )
- )
- ssl? (
- !libressl? ( dev-libs/openssl:0=[zlib?] )
- libressl? ( dev-libs/libressl:0= )
- )
- slz? ( dev-libs/libslz:= )
- zlib? ( sys-libs/zlib )"
-# lua? ( dev-lang/lua:5.3 )
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS=( CHANGELOG CONTRIBUTING MAINTAINERS )
-
-haproxy_use() {
- (( $# != 2 )) && die "${FUNCNAME} <USE flag> <make option>"
-
- usex "${1}" "USE_${2}=1" "USE_${2}="
-}
-
-pkg_setup() {
- enewgroup haproxy
- enewuser haproxy -1 -1 -1 haproxy
-
- if use net_ns; then
- CONFIG_CHECK="~NET_NS"
- linux-info_pkg_setup
- fi
-}
-
-src_prepare() {
- default
-
- sed -e 's:@SBINDIR@:'/usr/bin':' contrib/systemd/haproxy.service.in \
- > contrib/systemd/haproxy.service || die
-
- sed -ie 's:/usr/sbin/haproxy:/usr/bin/haproxy:' src/haproxy-systemd-wrapper.c || die
-}
-
-src_compile() {
- local -a args=(
- TARGET=linux2628
- USE_GETADDRINFO=1
- )
-
- args+=( $(haproxy_use crypt LIBCRYPT) )
-
-# bug 541042
-# args+=( $(haproxy_use lua LUA) )
-
- args+=( $(haproxy_use net_ns NS) )
- args+=( $(haproxy_use pcre PCRE) )
- args+=( $(haproxy_use pcre-jit PCRE_JIT) )
- args+=( $(haproxy_use ssl OPENSSL) )
- args+=( $(haproxy_use slz SLZ) )
- args+=( $(haproxy_use zlib ZLIB) )
-
- # For now, until the strict-aliasing breakage will be fixed
- append-cflags -fno-strict-aliasing
-
- emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args[@]}
-
- if use tools ; then
- for contrib in halog iprange ; do
- emake -C contrib/${contrib} \
- CFLAGS="${CFLAGS}" OPTIMIZE="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args[@]}
- done
- fi
-}
-
-src_install() {
- dobin haproxy
-
- newconfd "${FILESDIR}/${PN}.confd" $PN
- newinitd "${FILESDIR}/${PN}.initd-r3" $PN
-
- doman doc/haproxy.1
-
- dobin haproxy-systemd-wrapper
- systemd_dounit contrib/systemd/haproxy.service
-
- einstalldocs
-
- if use doc; then
- dodoc ROADMAP doc/{close-options,configuration,cookie-options,intro,linux-syn-cookies,management,proxy-protocol}.txt
- fi
-
- if use tools ; then
- dobin contrib/halog/halog
- newbin contrib/iprange/iprange haproxy_iprange
- fi
-
- if use net_ns && use doc; then
- dodoc doc/network-namespaces.txt
- fi
-
- if use examples ; then
- docinto examples
- dodoc examples/*.cfg
- dodoc examples/seamless_reload.txt
- fi
-
- if use vim-syntax ; then
- insinto /usr/share/vim/vimfiles/syntax
- doins examples/haproxy.vim
- fi
-}
-
-pkg_postinst() {
- if [[ ! -f "${EROOT}/etc/haproxy/haproxy.cfg" ]] ; then
- ewarn "You need to create /etc/haproxy/haproxy.cfg before you start the haproxy service."
- ewarn "It's best practice to not run haproxy as root, user and group haproxy was therefore created."
- ewarn "Make use of them with the \"user\" and \"group\" directives."
-
- if [[ -d "${EROOT}/usr/share/doc/${PF}" ]]; then
- einfo "Please consult the installed documentation for learning the configuration file's syntax."
- einfo "The documentation and sample configuration files are installed here:"
- einfo " ${EROOT}usr/share/doc/${PF}"
- fi
- fi
-}