summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-25 12:55:39 +0100
committerSam James <sam@gentoo.org>2022-10-25 13:15:25 +0100
commit57a8a56b1036b3ee654acc97e87f25b8d0478cce (patch)
treeafd95f4d6533ab7d4d036c4c314c7f11fbc0e2cf /net-proxy/tayga
parentnet-proxy/tayga: drop 0.9.2-r2 (diff)
downloadgentoo-57a8a56b1036b3ee654acc97e87f25b8d0478cce.tar.gz
gentoo-57a8a56b1036b3ee654acc97e87f25b8d0478cce.tar.bz2
gentoo-57a8a56b1036b3ee654acc97e87f25b8d0478cce.zip
net-proxy/tayga: fix build w/ Clang 16
Bug: https://bugs.gentoo.org/867217 Closes: https://bugs.gentoo.org/871678 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-proxy/tayga')
-rw-r--r--net-proxy/tayga/files/tayga-0.9.2-Fix-implicit-function-declaration.patch16
-rw-r--r--net-proxy/tayga/tayga-0.9.2-r4.ebuild (renamed from net-proxy/tayga/tayga-0.9.2-r3.ebuild)9
2 files changed, 19 insertions, 6 deletions
diff --git a/net-proxy/tayga/files/tayga-0.9.2-Fix-implicit-function-declaration.patch b/net-proxy/tayga/files/tayga-0.9.2-Fix-implicit-function-declaration.patch
new file mode 100644
index 000000000000..581aecc0a53f
--- /dev/null
+++ b/net-proxy/tayga/files/tayga-0.9.2-Fix-implicit-function-declaration.patch
@@ -0,0 +1,16 @@
+From 64b2c3859304c595e7099dd157596951ec21562b Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 25 Oct 2022 12:54:31 +0100
+Subject: [PATCH] Fix implicit function declaration
+
+Bug: https://bugs.gentoo.org/871678
+--- a/nat64.c
++++ b/nat64.c
+@@ -16,6 +16,7 @@
+ */
+
+ #include <tayga.h>
++#include <sys/uio.h>
+
+ extern struct config *gcfg;
+
diff --git a/net-proxy/tayga/tayga-0.9.2-r3.ebuild b/net-proxy/tayga/tayga-0.9.2-r4.ebuild
index d8b3c48363fc..00f3a03f825b 100644
--- a/net-proxy/tayga/tayga-0.9.2-r3.ebuild
+++ b/net-proxy/tayga/tayga-0.9.2-r4.ebuild
@@ -1,26 +1,23 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=8
inherit autotools
-DESCRIPTION="out-of-kernel stateless NAT64 implementation based on TUN"
+DESCRIPTION="Out-of-kernel stateless NAT64 implementation based on TUN"
HOMEPAGE="http://www.litech.org/tayga/"
SRC_URI="http://www.litech.org/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~riscv"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-static-EAM.patch
"${FILESDIR}"/${P}-manpage-RFC.patch
"${FILESDIR}"/${P}-release-reserved-addr.patch
+ "${FILESDIR}"/${PN}-0.9.2-Fix-implicit-function-declaration.patch
)
src_prepare() {