summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-wireless/wepdecrypt/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-wireless/wepdecrypt/files')
-rw-r--r--net-wireless/wepdecrypt/files/wepdecrypt-0.8-buffer.patch11
-rw-r--r--net-wireless/wepdecrypt/files/wepdecrypt-0.8-build.patch20
-rw-r--r--net-wireless/wepdecrypt/files/wepdecrypt-0.8-dyn.patch13
-rw-r--r--net-wireless/wepdecrypt/files/wepdecrypt-0.8-fltk.patch16
4 files changed, 60 insertions, 0 deletions
diff --git a/net-wireless/wepdecrypt/files/wepdecrypt-0.8-buffer.patch b/net-wireless/wepdecrypt/files/wepdecrypt-0.8-buffer.patch
new file mode 100644
index 000000000000..528816f147b5
--- /dev/null
+++ b/net-wireless/wepdecrypt/files/wepdecrypt-0.8-buffer.patch
@@ -0,0 +1,11 @@
+--- src/wepclient.c 2006-07-08 19:48:08.000000000 -0400
++++ src/wepclient.c.new 2010-12-10 13:16:32.000000000 -0500
+@@ -75,7 +75,7 @@
+ int server_connection(unsigned char * server_host, int port, char * packet_file, unsigned char * init_key, unsigned char * end_key, unsigned char * decrypted_key, unsigned char * bssid, unsigned char * mode ,int option){
+ int sd, read_bytes, write_bytes, i, fd;
+ char file[11]="local.dump";
+- unsigned char buffer[149], digest[16];
++ unsigned char buffer[150], digest[16];
+ struct sockaddr_in dest;
+ struct in_addr *host_ip;
+ struct hostent *host;
diff --git a/net-wireless/wepdecrypt/files/wepdecrypt-0.8-build.patch b/net-wireless/wepdecrypt/files/wepdecrypt-0.8-build.patch
new file mode 100644
index 000000000000..5c13f87a7402
--- /dev/null
+++ b/net-wireless/wepdecrypt/files/wepdecrypt-0.8-build.patch
@@ -0,0 +1,20 @@
+diff -urNp wepdecrypt-0.8.org/src/Makefile wepdecrypt-0.8/src/Makefile
+--- wepdecrypt-0.8.org/src/Makefile 2006-07-09 02:48:08.000000000 +0300
++++ wepdecrypt-0.8/src/Makefile 2007-11-10 18:36:25.000000000 +0200
+@@ -6,15 +6,12 @@ include ../config.mak
+ wepdecrypt: wepdecrypt.o rc4.o wepfilter.o log.o modes.o misc.o verify.o keygen.o localkeygen.o wepserver.o wepclient.o md5_digest.o
+ $(LD) $(LDFLAGS) -o $@ wepdecrypt.o rc4.o wepfilter.o log.o \
+ modes.o misc.o md5_digest.o wepserver.o wepclient.o verify.o keygen.o localkeygen.o $(LIBS)
+- @if [ -f wepdecrypt.exe ]; then strip.exe wepdecrypt.exe; echo "strip.exe wepdecrypt.exe"; else strip wepdecrypt; echo "strip wepdecrypt"; fi
+
+ gwepdecrypt: gwepdecrypt.cpp
+ $(FLTK) --compile gwepdecrypt.cpp
+- @if [ -f gwepdecrypt.exe ]; then strip.exe gwepdecrypt.exe; echo "strip.exe gwepdecrypt.exe"; else strip gwepdecrypt; echo "strip gwepdecrypt"; fi
+
+ wkeygen: wkeygen.c
+- $(LD) $(LDFLAGS) $(CFLAGS) $(LIBS) -o $@ wkeygen.c
+- @if [ -f wkeygen.exe ]; then strip wkeygen.exe; echo "strip wkeygen.exe"; else strip wkeygen; echo "strip wkeygen"; fi
++ $(LD) $(LDFLAGS) $(CFLAGS) -o $@ wkeygen.c $(LIBS)
+
+ wepdecrypt.o: wepdecrypt.c wepdecrypt.h
+ $(CC) $(CFLAGS) -c -o $@ wepdecrypt.c
diff --git a/net-wireless/wepdecrypt/files/wepdecrypt-0.8-dyn.patch b/net-wireless/wepdecrypt/files/wepdecrypt-0.8-dyn.patch
new file mode 100644
index 000000000000..6fcdc578c729
--- /dev/null
+++ b/net-wireless/wepdecrypt/files/wepdecrypt-0.8-dyn.patch
@@ -0,0 +1,13 @@
+diff --git a/src/Makefile b/src/Makefile
+index a779cb7..f32e65e 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -8,7 +8,7 @@ wepdecrypt: wepdecrypt.o rc4.o wepfilter.o log.o modes.o misc.o verify.o keygen
+ modes.o misc.o md5_digest.o wepserver.o wepclient.o verify.o keygen.o localkeygen.o $(LIBS)
+
+ gwepdecrypt: gwepdecrypt.cpp
+- $(FLTK) --compile gwepdecrypt.cpp
++ $(CXX) $(LDFLAGS) $(CFLAGS) -I. -o $@ gwepdecrypt.cpp $(shell fltk-config --cflags --ldflags) $(LIBS)
+
+ wkeygen: wkeygen.c
+ $(LD) $(LDFLAGS) $(CFLAGS) -o $@ wkeygen.c $(LIBS)
diff --git a/net-wireless/wepdecrypt/files/wepdecrypt-0.8-fltk.patch b/net-wireless/wepdecrypt/files/wepdecrypt-0.8-fltk.patch
new file mode 100644
index 000000000000..149c3eae32ad
--- /dev/null
+++ b/net-wireless/wepdecrypt/files/wepdecrypt-0.8-fltk.patch
@@ -0,0 +1,16 @@
+ configure | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/configure b/configure
+index 12fa395..258b157 100755
+--- a/configure
++++ b/configure
+@@ -2915,7 +2915,7 @@ fi
+ FIELD2=`$FLTK_CONFIG --version | awk -F . '{print $2}'`;
+ FIELD3=`$FLTK_CONFIG --version | awk -F . '{print $3}'`;
+
+- if test $FIELD1 -le 1 -a $FIELD3 -lt 6; then
++ if test $FIELD1 -le 1 -a $FIELD2 -lt 1; then
+ echo -e "\nconfigure: error: fltk-version must be 1.1.6 or greater!\n"; exit -1;
+ fi
+ if test $FIELD1 -lt 1; then