summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2023-10-18 08:33:23 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2023-10-18 09:36:01 +0200
commit779c3d1e7799a008909b7e94a35dec0756bf34de (patch)
tree59dd3fcd1a610e55a49da0272f016d58c02c16fd /sci-astronomy/gasgano/gasgano-2.4.8-r1.ebuild
parentprofiles/base: Un-stable-mask 3.12 on dev-lang/python-exec (diff)
downloadgentoo-779c3d1e7799a008909b7e94a35dec0756bf34de.tar.gz
gentoo-779c3d1e7799a008909b7e94a35dec0756bf34de.tar.bz2
gentoo-779c3d1e7799a008909b7e94a35dec0756bf34de.zip
sci-astronomy/gasgano: dependency slots
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'sci-astronomy/gasgano/gasgano-2.4.8-r1.ebuild')
-rw-r--r--sci-astronomy/gasgano/gasgano-2.4.8-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-astronomy/gasgano/gasgano-2.4.8-r1.ebuild b/sci-astronomy/gasgano/gasgano-2.4.8-r1.ebuild
new file mode 100644
index 000000000000..8c92b45f2493
--- /dev/null
+++ b/sci-astronomy/gasgano/gasgano-2.4.8-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop java-pkg-2
+
+PDOC=VLT-PRO-ESO-19000-1932-V4
+
+DESCRIPTION="ESO astronomical data file organizer"
+HOMEPAGE="http://www.eso.org/sci/software/gasgano/"
+SRC_URI="ftp://ftp.eso.org/pub/dfs/${PN}/${P}.tar.gz
+ doc? ( http://www.eso.org/sci/software/gasgano/${PDOC}.pdf )"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND="
+ >=virtual/jre-1.8:*
+ dev-java/gnu-regexp:1
+ dev-java/junit:0
+ dev-java/jal:0"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:^BASE=\`pwd\`:BASE=${EPREFIX}/usr/share/${PN}:" \
+ -e 's:$BASE/share/:$BASE/lib/:g' \
+ bin/gasgano || die
+}
+
+src_install() {
+ dobin bin/*
+ java-pkg_dojar share/*.jar
+ insinto /usr/share/${PN}
+ doins -r config
+ make_desktop_entry gasgano "Gasgano FITS Organizer"
+ use doc && newdoc "${DISTDIR}"/${PDOC}.pdf user-manual.pdf
+}