summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/express
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/express')
-rw-r--r--sci-biology/express/Manifest2
-rw-r--r--sci-biology/express/express-0.9.5-r1.ebuild36
-rw-r--r--sci-biology/express/express-0.9.5.ebuild35
-rw-r--r--sci-biology/express/express-1.5.1.ebuild37
-rw-r--r--sci-biology/express/files/express-1.5.1-buildsystem.patch55
-rw-r--r--sci-biology/express/metadata.xml5
6 files changed, 170 insertions, 0 deletions
diff --git a/sci-biology/express/Manifest b/sci-biology/express/Manifest
new file mode 100644
index 000000000000..6edb1d9f6603
--- /dev/null
+++ b/sci-biology/express/Manifest
@@ -0,0 +1,2 @@
+DIST express-0.9.5-src.tgz 766024 SHA256 e17250d62750560c2dc9cb579f58784b5076afb74088f36523ddd623e08bc022 SHA512 3a7360ffbe57f4f712b6db38d551d31384d995050a86238d79299edb12f0e7f5dca6f362b7858b5051ea2879af2b3559f78f9780d75ef2ef6fdad7398f781403 WHIRLPOOL 290772dceca2465f922f5d5fe548dc8fd460422589697173c58f98dc3afa2e91175fe1fa52e5f29458ea6af74c8da609776fa583bf5efcb2d5771c4c9ad51cde
+DIST express-1.5.1-src.tgz 931166 SHA256 0c5840a42da830fd8701dda8eef13f4792248bab4e56d665a0e2ca075aff2c0f SHA512 59cf6511a879311247c65334285ea056d571d4fd950aa6243041fa10075ff0d1ddd2afbcfe12e5f7f3e7cdd22fe37fd7f6b43ed4a8eb28d7a33d72366dc549ee WHIRLPOOL 2c75385b2a2ec8f7b77df760344affc108e827eb9f59014f08af0cee0ca8806beeba101d13ed8b43883a25fc9486bd405f402339f0e4e394d3895694c75a4e2a
diff --git a/sci-biology/express/express-0.9.5-r1.ebuild b/sci-biology/express/express-0.9.5-r1.ebuild
new file mode 100644
index 000000000000..608ade0766ea
--- /dev/null
+++ b/sci-biology/express/express-0.9.5-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Streaming RNA-Seq Analysis"
+HOMEPAGE="http://bio.math.berkeley.edu/eXpress/"
+SRC_URI="http://bio.math.berkeley.edu/eXpress/downloads/express-${PV}/express-${PV}-src.tgz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-libs/boost-1.52.0:=
+ sys-libs/zlib
+ sci-biology/bamtools"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}-src"
+
+CMAKE_USE_DIR="${S}/src"
+
+src_prepare() {
+ sed \
+ -e 's|"${CMAKE_CURRENT_SOURCE_DIR}/../bamtools/lib/libbamtools.a"|bamtools|' \
+ -e '1 a find_package(Boost 1.52 COMPONENTS filesystem program_options system thread)' \
+ -e '1 a find_package(ZLIB)' \
+ -e '/add_executable/ a include_directories("/usr/include/bamtools")' \
+ -i src/CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}
diff --git a/sci-biology/express/express-0.9.5.ebuild b/sci-biology/express/express-0.9.5.ebuild
new file mode 100644
index 000000000000..a4fcff4be4f5
--- /dev/null
+++ b/sci-biology/express/express-0.9.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="Streaming RNA-Seq Analysis"
+HOMEPAGE="http://bio.math.berkeley.edu/eXpress/"
+SRC_URI="http://bio.math.berkeley.edu/eXpress/downloads/express-${PV}/express-${PV}-src.tgz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/boost
+ sys-libs/zlib
+ sci-biology/bamtools"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}-src"
+
+CMAKE_USE_DIR="${S}/src"
+
+src_prepare() {
+ sed \
+ -e 's|"${CMAKE_CURRENT_SOURCE_DIR}/../bamtools/lib/libbamtools.a"|bamtools|' \
+ -e '1 a find_package(Boost 1.46 COMPONENTS filesystem program_options thread)' \
+ -e '1 a find_package(ZLIB)' \
+ -e '/add_executable/ a include_directories("/usr/include/bamtools")' \
+ -i src/CMakeLists.txt || die
+}
diff --git a/sci-biology/express/express-1.5.1.ebuild b/sci-biology/express/express-1.5.1.ebuild
new file mode 100644
index 000000000000..231b1f878ba3
--- /dev/null
+++ b/sci-biology/express/express-1.5.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Streaming RNA-Seq Analysis"
+HOMEPAGE="http://bio.math.berkeley.edu/eXpress/"
+SRC_URI="http://bio.math.berkeley.edu/eXpress/downloads/${P}/${P}-src.tgz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-libs/boost-1.52.0:=
+ dev-libs/protobuf
+ dev-util/google-perftools
+ sys-libs/zlib
+ sci-biology/bamtools"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}-src"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-buildsystem.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBAMTOOLS_INCLUDE="${EPREFIX}/usr/include/bamtools"
+ )
+ cmake-utils_src_configure
+}
diff --git a/sci-biology/express/files/express-1.5.1-buildsystem.patch b/sci-biology/express/files/express-1.5.1-buildsystem.patch
new file mode 100644
index 000000000000..fca5feadd111
--- /dev/null
+++ b/sci-biology/express/files/express-1.5.1-buildsystem.patch
@@ -0,0 +1,55 @@
+ CMakeLists.txt | 8 +++-----
+ src/CMakeLists.txt | 4 ++--
+ 2 files changed, 5 insertions(+), 7 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index c768e28..65d5633 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -6,14 +6,12 @@ set(${PROJECT_NAME}_VERSION_MAJOR 1)
+ set(${PROJECT_NAME}_VERSION_MINOR 5)
+ set(${PROJECT_NAME}_VERSION_PATCH 1)
+
+-set(CMAKE_CXX_FLAGS "-Wall")
+-
+ set(CMAKE_CXX_FLAGS_DEBUG "-g ${CMAKE_CXX_FLAGS}")
+ set(CMAKE_CXX_FLAGS_RHDEBINFO "-O3 -g ${CMAKE_CXX_FLAGS}")
+ set(CMAKE_CXX_FLAGS_MINSIZEREL "-Os ${CMAKE_CXX_FLAGS}")
+
+ set(CMAKE_BUILD_TYPE Release)
+-set(Boost_USE_STATIC_LIBS ON)
++set(Boost_USE_STATIC_LIBS OFF)
+
+ find_package(Boost 1.39
+ COMPONENTS
+@@ -33,10 +31,10 @@ endif(GPERFTOOLS_TCMALLOC_LIB)
+
+ find_package(Protobuf)
+ if (PROTOBUF_FOUND)
+- include_directories(${Boost_INCLUDE_DIRS} ${PROTOBUF_INCLUDE_DIR} "${CMAKE_CURRENT_SOURCE_DIR}/bamtools/include")
++ include_directories(${Boost_INCLUDE_DIRS} ${PROTOBUF_INCLUDE_DIR} ${BAMTOOLS_INCLUDE})
+ set(PROTO_INT 1)
+ else (PROTOBUF_FOUND)
+- include_directories(${Boost_INCLUDE_DIRS} "${CMAKE_CURRENT_SOURCE_DIR}/bamtools/include")
++ include_directories(${Boost_INCLUDE_DIRS} ${BAMTOOLS_INCLUDE})
+ set(PROTO_INT 0)
+ endif(PROTOBUF_FOUND)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 1cc0c01..8929d1f 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -16,11 +16,11 @@ endif (GPERFTOOLS_TCMALLOC)
+ if(WIN32)
+ set(LIBRARIES ${LIBRARIES} "${CMAKE_CURRENT_SOURCE_DIR}/../bamtools/lib/libbamtools.lib" "${CMAKE_CURRENT_SOURCE_DIR}/../win_build/zlibd.lib")
+ else(WIN32)
+- set(LIBRARIES ${LIBRARIES} "${CMAKE_CURRENT_SOURCE_DIR}/../bamtools/lib/libbamtools.a" "pthread")
++ set(LIBRARIES ${LIBRARIES} "bamtools" "pthread")
+ endif(WIN32)
+
+ if (PROTOBUF_FOUND)
+- set(LIBRARIES ${LIBRARIES} "libprotobuf.a")
++ set(LIBRARIES ${LIBRARIES} "protobuf")
+ endif(PROTOBUF_FOUND)
+
+ target_link_libraries(express ${LIBRARIES})
diff --git a/sci-biology/express/metadata.xml b/sci-biology/express/metadata.xml
new file mode 100644
index 000000000000..f17a827e3101
--- /dev/null
+++ b/sci-biology/express/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>