summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2017-04-05 22:47:09 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2017-04-05 22:47:09 +0300
commit560758ca9c987c49a6fb0b0d9031dac8b8568c2f (patch)
tree23e9657320130e9693d78ec171624b70e9795128 /sci-chemistry/ParmEd/ParmEd-2.7.3.ebuild
parentsci-chemistry/acpype: Version bump, clean old (diff)
downloadgentoo-560758ca9c987c49a6fb0b0d9031dac8b8568c2f.tar.gz
gentoo-560758ca9c987c49a6fb0b0d9031dac8b8568c2f.tar.bz2
gentoo-560758ca9c987c49a6fb0b0d9031dac8b8568c2f.zip
sci-chemistry/ParmEd: Initial version
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-chemistry/ParmEd/ParmEd-2.7.3.ebuild')
-rw-r--r--sci-chemistry/ParmEd/ParmEd-2.7.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-chemistry/ParmEd/ParmEd-2.7.3.ebuild b/sci-chemistry/ParmEd/ParmEd-2.7.3.ebuild
new file mode 100644
index 000000000000..a183d0d0ae2a
--- /dev/null
+++ b/sci-chemistry/ParmEd/ParmEd-2.7.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+if [[ $PV = *9999* ]]; then
+ scm_eclass=git-2
+ EGIT_REPO_URI="
+ git://github.com/${PN}/${PN}.git
+ https://github.com/${PN}/${PN}.git"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ scm_eclass=vcs-snapshot
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+inherit eutils distutils-r1 ${scm_eclass}
+
+DESCRIPTION="Parameter/topology editor and molecular simulator"
+HOMEPAGE="http://parmed.github.io/ParmEd"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed \
+ -e "/delfile/d" \
+ -e "/deldir/d" \
+ -i setup.py || die
+ distutils-r1_src_prepare
+}