summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-electronics/magic/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-electronics/magic/files')
-rw-r--r--sci-electronics/magic/files/magic-7.5.202-include.patch20
-rw-r--r--sci-electronics/magic/files/magic-7.5.202-install.patch15
-rw-r--r--sci-electronics/magic/files/magic-7.5.231-blt-test.patch11
-rw-r--r--sci-electronics/magic/files/magic-7.5.231-ldflags.patch16
-rw-r--r--sci-electronics/magic/files/magic-7.5.231-verbose-build.patch35
-rw-r--r--sci-electronics/magic/files/magic-ldflags.patch40
6 files changed, 137 insertions, 0 deletions
diff --git a/sci-electronics/magic/files/magic-7.5.202-include.patch b/sci-electronics/magic/files/magic-7.5.202-include.patch
new file mode 100644
index 000000000000..f1fc95a60b32
--- /dev/null
+++ b/sci-electronics/magic/files/magic-7.5.202-include.patch
@@ -0,0 +1,20 @@
+--- magic-7.5.202/textio/txInput.c
++++ magic-7.5.202/textio/txInput.c
+@@ -21,6 +21,7 @@
+ #endif /* not lint */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <string.h>
+ #include <sys/time.h>
+ #include <sys/types.h>
+--- magic-8.0.131/graphics/grX11su3.c
++++ magic-8.0.131/graphics/grX11su3.c
+@@ -20,6 +20,7 @@
+
+ #include <stdio.h>
+ #include <string.h>
++#include <math.h>
+ #include <X11/Xlib.h>
+
+ #include "utils/magic.h"
diff --git a/sci-electronics/magic/files/magic-7.5.202-install.patch b/sci-electronics/magic/files/magic-7.5.202-install.patch
new file mode 100644
index 000000000000..6e28b950c510
--- /dev/null
+++ b/sci-electronics/magic/files/magic-7.5.202-install.patch
@@ -0,0 +1,15 @@
+--- magic-7.5.202/rules.mak
++++ magic-7.5.202/rules.mak
+@@ -43,9 +43,9 @@
+ ${RM} ${MODULE}
+ ${CC} ${CFLAGS} ${CPPFLAGS} ${DFLAGS} lib${MODULE}.o ${EXTRA_LIBS} -o ${MODULE} ${LIBS}
+
+-${BINDIR}/${MODULE}${EXEEXT}: ${MODULE}${EXEEXT}
+- ${RM} ${BINDIR}/${MODULE}${EXEEXT}
+- ${CP} ${MODULE}${EXEEXT} ${BINDIR}
++${DESTDIR}${BINDIR}/${MODULE}${EXEEXT}: ${MODULE}${EXEEXT}
++ ${RM} ${DESTDIR}${BINDIR}/${MODULE}${EXEEXT}
++ ${CP} ${MODULE}${EXEEXT} ${DESTDIR}${BINDIR}
+
+ ../database/database.h: ../database/database.h.in
+ @echo --- making header file database/database.h
diff --git a/sci-electronics/magic/files/magic-7.5.231-blt-test.patch b/sci-electronics/magic/files/magic-7.5.231-blt-test.patch
new file mode 100644
index 000000000000..bf78f3f5b6b2
--- /dev/null
+++ b/sci-electronics/magic/files/magic-7.5.231-blt-test.patch
@@ -0,0 +1,11 @@
+--- magic-7.5.231/scripts/configure.in
++++ magic-7.5.231/scripts/configure.in
+@@ -1695,7 +1695,7 @@
+ if {[[catch {package require BLT}]]} {puts stdout no} {puts stdout yes}
+ exit
+ EOF
+- usingBLT=`cat temp.out`
++ usingBLT=yes
+ rm -f temp.out
+ if test "x${usingBLT}" = "xyes" ; then
+ echo "yes"
diff --git a/sci-electronics/magic/files/magic-7.5.231-ldflags.patch b/sci-electronics/magic/files/magic-7.5.231-ldflags.patch
new file mode 100644
index 000000000000..32555d66f81e
--- /dev/null
+++ b/sci-electronics/magic/files/magic-7.5.231-ldflags.patch
@@ -0,0 +1,16 @@
+--- magic-7.5.231/scripts/configure.in
++++ magic-7.5.231/scripts/configure.in
+@@ -1428,11 +1428,11 @@
+ ;;
+
+ *-linux*)
+- LDDL_FLAGS='-shared -Wl,-soname,$@'
++ LDDL_FLAGS+=' -shared -Wl,-soname,$@'
+ if test "x${loader_run_path}" != "x" ; then
+ LD_RUN_PATH="${LD_RUN_PATH} -Wl,-rpath,${loader_run_path}"
+ fi
+- LDFLAGS=""
++ LDFLAGS+=" "
+ EXTRA_LIB_SPECS="-ldl"
+ ;;
+
diff --git a/sci-electronics/magic/files/magic-7.5.231-verbose-build.patch b/sci-electronics/magic/files/magic-7.5.231-verbose-build.patch
new file mode 100644
index 000000000000..64ad4fd18278
--- /dev/null
+++ b/sci-electronics/magic/files/magic-7.5.231-verbose-build.patch
@@ -0,0 +1,35 @@
+--- magic-7.5.231/Makefile
++++ magic-7.5.231/Makefile
+@@ -18,12 +18,10 @@
+ all: $(ALL_TARGET)
+
+ standard:
+- @echo --- errors and warnings logged in file make.log
+- @${MAKE} mains 2>&1 | tee -a make.log | egrep -i "(.c:|Stop.|---)"
++ @${MAKE} mains
+
+ tcl:
+- @echo --- errors and warnings logged in file make.log
+- @${MAKE} tcllibrary 2>&1 | tee -a make.log | egrep -i "(.c:|Stop.|---)"
++ @${MAKE} tcllibrary
+
+ force: clean all
+
+@@ -67,7 +65,7 @@
+ install-magic:
+ @echo --- installing executable to $(DESTDIR)${BINDIR}
+ @echo --- installing runtime files to $(DESTDIR)${LIBDIR}
+- @${MAKE} install-real 2>&1 >> install.log
++ @${MAKE} install-real
+
+ install-real: install-dirs
+ for dir in ${INSTALL_CAD_DIRS}; do \
+@@ -86,7 +84,7 @@
+ install-tcl:
+ @echo --- installing executable to $(DESTDIR)${BINDIR}
+ @echo --- installing runtime files to $(DESTDIR)${LIBDIR}
+- @${MAKE} install-tcl-real 2>&1 >> install.log
++ @${MAKE} install-tcl-real
+
+ install-tcl-real: install-tcl-dirs
+ for dir in ${INSTALL_CAD_DIRS} ${PROGRAMS}; do \
diff --git a/sci-electronics/magic/files/magic-ldflags.patch b/sci-electronics/magic/files/magic-ldflags.patch
new file mode 100644
index 000000000000..60d5891beee0
--- /dev/null
+++ b/sci-electronics/magic/files/magic-ldflags.patch
@@ -0,0 +1,40 @@
+diff -r -u magic-7.5.202.orig/scripts/configure.in magic-7.5.202/scripts/configure.in
+--- magic-7.5.202.orig/scripts/configure.in 2010-03-08 14:33:07.000000000 +0100
++++ magic-7.5.202/scripts/configure.in 2010-07-02 22:15:50.814199319 +0200
+@@ -1350,7 +1350,6 @@
+ if test "x${loader_run_path}" != "x" ; then
+ LD_RUN_PATH="${LD_RUN_PATH} -Wl,-rpath,${loader_run_path}"
+ fi
+- LDFLAGS=""
+ EXTRA_LIB_SPECS="-ldl"
+ ;;
+
+diff -r -u magic-7.5.202.orig/scripts/defs.mak.in magic-7.5.202/scripts/defs.mak.in
+--- magic-7.5.202.orig/scripts/defs.mak.in 2010-03-08 14:33:07.000000000 +0100
++++ magic-7.5.202/scripts/defs.mak.in 2010-07-02 22:15:50.814199319 +0200
+@@ -53,7 +53,7 @@
+ M4 = @M4@
+ RANLIB = @RANLIB@
+ SHDLIB_EXT = @SHDLIB_EXT@
+-LDDL_FLAGS = @LDDL_FLAGS@
++LDDL_FLAGS = ${LDFLAGS} @LDDL_FLAGS@
+ LD_RUN_PATH = @LD_RUN_PATH@
+ LIB_SPECS = @LIB_SPECS@
+ WISH_EXE = @WISH_EXE@
+diff -r -u magic-7.5.202.orig/tcltk/Makefile magic-7.5.202/tcltk/Makefile
+--- magic-7.5.202.orig/tcltk/Makefile 2009-05-29 15:54:55.000000000 +0200
++++ magic-7.5.202/tcltk/Makefile 2010-07-02 22:16:30.916202298 +0200
+@@ -41,11 +41,11 @@
+ (cd $(DESTDIR)${TCLDIR}; chmod 0755 tkcon.tcl tkshell.tcl)
+
+ magicexec: magicexec.c
+- ${CC} ${CFLAGS} -pg ${CPPFLAGS} ${DFLAGS} magicexec.c -o magicexec \
++ ${CC} ${CFLAGS} -pg ${CPPFLAGS} ${DFLAGS} ${LDFLAGS} magicexec.c -o magicexec \
+ ${LD_RUN_PATH} ${LIBS} ${LIB_SPECS}
+
+ magicdnull: magicdnull.c
+- ${CC} ${CFLAGS} ${CPPFLAGS} ${DFLAGS} magicdnull.c -o magicdnull \
++ ${CC} ${CFLAGS} ${CPPFLAGS} ${DFLAGS} ${LDFLAGS} magicdnull.c -o magicdnull \
+ ${LD_RUN_PATH} ${LIBS} ${LIB_SPECS}
+
+ magic.tcl: magic.tcl.in ${MAGICDIR}/defs.mak