summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2024-01-24 19:51:58 -0800
committerYixun Lan <dlan@gentoo.org>2024-01-31 10:21:54 +0000
commit74111de0290aaba44ebd5cba40fd74fa0596910a (patch)
tree86c55054dfe77bc03cc112fd7dc26faf6294c07f /sci-electronics
parentsci-electronics/kicad: add 7.0.10 (diff)
downloadgentoo-74111de0290aaba44ebd5cba40fd74fa0596910a.tar.gz
gentoo-74111de0290aaba44ebd5cba40fd74fa0596910a.tar.bz2
gentoo-74111de0290aaba44ebd5cba40fd74fa0596910a.zip
sci-electronics/kicad-footprints: add 7.0.10
Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/kicad-footprints/Manifest1
-rw-r--r--sci-electronics/kicad-footprints/kicad-footprints-7.0.10.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/sci-electronics/kicad-footprints/Manifest b/sci-electronics/kicad-footprints/Manifest
index 255373ebe0f2..d0e110adf815 100644
--- a/sci-electronics/kicad-footprints/Manifest
+++ b/sci-electronics/kicad-footprints/Manifest
@@ -1,3 +1,4 @@
+DIST kicad-footprints-7.0.10.tar.bz2 24478270 BLAKE2B dd12467ba7bad3f0ab44164ea4ef6502f44143ec66173d5dadba62ab60559c0e75c4f77d00436ba2f7e1f0b527ae94cd0954fdd568031d049fbb69de56f13c0c SHA512 23fe7018f0f7328dc3d55e9f206d7ee4f4734be768d7024291b9d22c0134f1b887be5baf74fd601454e89a9a282aa9c0ad0ff631f5d29ec2ccac1c30b4dc1b66
DIST kicad-footprints-7.0.7.tar.bz2 24411508 BLAKE2B 1abedfbc3dfab302b5f929b01f2a83e83a4fee6b1d5056bf2c3579068c56807c656dea918f4c37fe030b727d3effbc35063f4f4103c4cfa6071f95c22d507597 SHA512 8af1fb371034bd5b22e0a8a896fa61e4eb0bda5b282759e17872bf4b466f49b39aa56ae068ac3d7d5a7453d9a7d511a81317d3f267a90d2764b2b8282f64aef0
DIST kicad-footprints-7.0.8.tar.bz2 24418267 BLAKE2B d252a75adafbb8ccbe000ad290e1a0ec6044c5662a899812de3466e2fe23d8f3833b54b9c17863ddf26a1e032af404daacdb7848a9517313943b43d1b9ed488e SHA512 984cff22967dd82ec1e4706a61c68bf2357f391c4efccd80dadcae18f71ff0a90fdc61a54b491440da2a2dc7f1a2fc03091e01c9791a919db7a31920ec5b7b02
DIST kicad-footprints-7.0.9.tar.bz2 24450969 BLAKE2B 56b00cbf682835f03495638231f1683b822f01fd7afe5c5a6e559f0f1a25a5fac20b8860661882b4779a8ccea443e28b4c3419e1039c6082f0134c4901c92848 SHA512 93438748934e630c012d28c46a7001d6139a458dd35d0e56dc77523a3e39249b14fc9e39700512a0d9a97b4e236fcbf0410e7f8506371522c883dee826b628a7
diff --git a/sci-electronics/kicad-footprints/kicad-footprints-7.0.10.ebuild b/sci-electronics/kicad-footprints/kicad-footprints-7.0.10.ebuild
new file mode 100644
index 000000000000..cb26f5460629
--- /dev/null
+++ b/sci-electronics/kicad-footprints/kicad-footprints-7.0.10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Electronic Schematic and PCB design tools footprint libraries"
+HOMEPAGE="https://gitlab.com/kicad/libraries/kicad-footprints"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.com/kicad/libraries/kicad-footprints.git"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.com/kicad/libraries/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+ KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="CC-BY-SA-4.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=sci-electronics/kicad-7.0.0"
+
+if [[ ${PV} == 9999 ]] ; then
+# x11-misc-util/macros only required on live ebuilds
+ BDEPEND+=" >=x11-misc/util-macros-1.18"
+fi