summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Jorna <wraeth@gentoo.org>2016-06-08 13:22:43 +1000
committerSam Jorna <wraeth@gentoo.org>2016-06-08 13:43:10 +1000
commit3755f809c5278e73f69dc4818b25d16695060446 (patch)
tree4a79190919cc57cfc47c5ff1ae9429621a6c6030 /sci-geosciences/gdal-grass/gdal-grass-2.1.0.ebuild
parentmail-client/thunderbird: mis-release version bump (diff)
downloadgentoo-3755f809c5278e73f69dc4818b25d16695060446.tar.gz
gentoo-3755f809c5278e73f69dc4818b25d16695060446.tar.bz2
gentoo-3755f809c5278e73f69dc4818b25d16695060446.zip
sci-geosciences/gdal-grass: bump to 2.1.0
Version bump to 2.1.0, also replaces patch for one line with sed. Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'sci-geosciences/gdal-grass/gdal-grass-2.1.0.ebuild')
-rw-r--r--sci-geosciences/gdal-grass/gdal-grass-2.1.0.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sci-geosciences/gdal-grass/gdal-grass-2.1.0.ebuild b/sci-geosciences/gdal-grass/gdal-grass-2.1.0.ebuild
new file mode 100644
index 000000000000..50b440e5476e
--- /dev/null
+++ b/sci-geosciences/gdal-grass/gdal-grass-2.1.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="GDAL plugin to access GRASS data"
+HOMEPAGE="http://www.gdal.org/"
+SRC_URI="http://download.osgeo.org/gdal/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="postgres"
+RDEPEND="
+ >=sci-libs/gdal-2.0.0
+ sci-geosciences/grass:0=
+"
+DEPEND="${RDEPEND}
+ dev-libs/expat
+ dev-libs/json-c
+ virtual/jpeg
+ media-libs/tiff
+ sci-libs/libgeotiff
+ sci-libs/proj
+ sys-libs/zlib
+ postgres? ( dev-db/postgresql )"
+
+# these drivers are copied at install from the already installed GRASS
+QA_PREBUILT="/usr/share/gdal/grass/driver/db/*"
+
+src_prepare() {
+ sed -e 's:mkdir ${GRASSTABLES_DIR}$:mkdir -p ${GRASSTABLES_DIR}:' \
+ -i Makefile.in || die
+ default
+}
+
+src_configure() {
+ econf \
+ --with-grass="/usr/$(get_libdir)/grass70" \
+ --with-gdal="/usr/bin/gdal-config" \
+ $(use_with postgres postgres-includes "/usr/include/postgresql")
+}
+
+src_install() {
+ #pass the right variables to 'make install' to prevent a sandbox access violation
+ emake DESTDIR="${D}" \
+ GRASSTABLES_DIR="${D}$(gdal-config --prefix)/share/gdal/grass" \
+ AUTOLOAD_DIR="${D}/usr/$(get_libdir)/gdalplugins" \
+ install
+}