summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-01-30 09:12:52 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-01-30 09:19:39 +0100
commit612ad41ff7c2e1766aa2e9e807f142fe256b1ce6 (patch)
tree18fcbd9e0cfbdf4d8f98c0792338fbf1e1676218 /sci-geosciences/gpsbabel/files
parentdev-ruby/tzinfo: add github, rubygems upstream metadata (diff)
downloadgentoo-612ad41ff7c2e1766aa2e9e807f142fe256b1ce6.tar.gz
gentoo-612ad41ff7c2e1766aa2e9e807f142fe256b1ce6.tar.bz2
gentoo-612ad41ff7c2e1766aa2e9e807f142fe256b1ce6.zip
sci-geosciences/gpsbabel: drop use gui, add use qt6
Though the build system provides separate targets for the gui and cli tools, the cmake configure files do not reflect this and they will search for qt unconditionally. Patching is non-trivial because the source files for the gui and for the cli are not completely separated. The package does support qt6 but the upstream cmake files do not provide a means of selecting which to use and will choose a version automagically. A simple patch is enough to fix this. Closes: https://bugs.gentoo.org/852836 Closes: https://bugs.gentoo.org/892559 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-geosciences/gpsbabel/files')
-rw-r--r--sci-geosciences/gpsbabel/files/gpsbabel-1.8.0-no-automagic-qt5-qt6.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-geosciences/gpsbabel/files/gpsbabel-1.8.0-no-automagic-qt5-qt6.patch b/sci-geosciences/gpsbabel/files/gpsbabel-1.8.0-no-automagic-qt5-qt6.patch
new file mode 100644
index 000000000000..47a1a37e1ba3
--- /dev/null
+++ b/sci-geosciences/gpsbabel/files/gpsbabel-1.8.0-no-automagic-qt5-qt6.patch
@@ -0,0 +1,34 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 2a7d805..65bd4db 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -26,7 +26,11 @@ set(CMAKE_AUTORCC ON)
+ add_executable(gpsbabel)
+
+ # Find the QtCore library
+-find_package(QT NAMES Qt6 Qt5 COMPONENTS Core REQUIRED)
++if(USE_QT6)
++ find_package(QT NAMES Qt6 COMPONENTS Core REQUIRED)
++else()
++ find_package(QT NAMES Qt5 COMPONENTS Core REQUIRED)
++endif()
+ find_package(Qt${QT_VERSION_MAJOR} COMPONENTS Core REQUIRED)
+ list(APPEND QT_LIBRARIES Qt${QT_VERSION_MAJOR}::Core)
+ if(${Qt${QT_VERSION_MAJOR}Core_VERSION} VERSION_LESS 5.12)
+diff --git a/gui/CMakeLists.txt b/gui/CMakeLists.txt
+index 4c839c2..ac329dd 100644
+--- a/gui/CMakeLists.txt
++++ b/gui/CMakeLists.txt
+@@ -23,7 +23,11 @@ endif()
+ add_executable(${TARGET} WIN32 MACOSX_BUNDLE)
+
+ # Find the QtCore library
+-find_package(QT NAMES Qt6 Qt5 COMPONENTS Core REQUIRED)
++if(USE_QT6)
++ find_package(QT NAMES Qt6 COMPONENTS Core REQUIRED)
++else()
++ find_package(QT NAMES Qt5 COMPONENTS Core REQUIRED)
++endif()
+ find_package(Qt${QT_VERSION_MAJOR} COMPONENTS Core Gui Network SerialPort Widgets Xml REQUIRED)
+ list(APPEND QT_LIBRARIES Qt${QT_VERSION_MAJOR}::Core Qt${QT_VERSION_MAJOR}::Gui Qt${QT_VERSION_MAJOR}::Network Qt${QT_VERSION_MAJOR}::SerialPort Qt${QT_VERSION_MAJOR}::Widgets Qt${QT_VERSION_MAJOR}::Xml)
+ if(${Qt${QT_VERSION_MAJOR}Core_VERSION} VERSION_LESS 5.12)