summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Schiffbauer <mschiff@gentoo.org>2020-04-01 13:22:16 -0500
committerMarc Schiffbauer <mschiff@gentoo.org>2020-05-05 01:06:57 -0500
commit3ce758f1233b3f32337f52e282ae435a511aa2a9 (patch)
tree3cd62bb0c747ef9c5973996d49f87befaed367b2 /sci-geosciences/opencpn/opencpn-5.0.0.ebuild
parentdev-tcltk/tclreadline: fix HomepageInSrcUri (diff)
downloadgentoo-3ce758f1233b3f32337f52e282ae435a511aa2a9.tar.gz
gentoo-3ce758f1233b3f32337f52e282ae435a511aa2a9.tar.bz2
gentoo-3ce758f1233b3f32337f52e282ae435a511aa2a9.zip
sci-geosciences/opencpn: add version 5.0.0
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Marc Schiffbauer <mschiff@gentoo.org>
Diffstat (limited to 'sci-geosciences/opencpn/opencpn-5.0.0.ebuild')
-rw-r--r--sci-geosciences/opencpn/opencpn-5.0.0.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/sci-geosciences/opencpn/opencpn-5.0.0.ebuild b/sci-geosciences/opencpn/opencpn-5.0.0.ebuild
new file mode 100644
index 000000000000..4ae2fe2e75a1
--- /dev/null
+++ b/sci-geosciences/opencpn/opencpn-5.0.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WX_GTK_VER="3.0"
+inherit cmake-utils wxwidgets
+
+DOC_VERSION="4.8.2.0"
+
+DESCRIPTION="a free, open source software for marine navigation"
+HOMEPAGE="https://opencpn.org/"
+SRC_URI="https://github.com/OpenCPN/OpenCPN/archive/v${PV}.tar.gz -> ${P}.tar.gz
+doc? ( https://launchpad.net/~opencpn/+archive/ubuntu/${PN}/+files/${PN}-doc_${DOC_VERSION}.orig.tar.xz )
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc lzma opengl"
+
+RDEPEND="
+ app-arch/bzip2
+ lzma? ( app-arch/xz-utils )
+ dev-libs/tinyxml
+ media-libs/freetype:2
+ media-libs/portaudio
+ net-misc/curl
+ sys-libs/zlib
+ opengl? ( virtual/opengl )
+ x11-libs/gtk+:2
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ !sci-geosciences/opencpn-plugin-wmm
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+S="${WORKDIR}/OpenCPN-${PV}"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-CMakeLists.txt.patch"
+)
+
+src_configure() {
+ setup-wxwidgets
+ local mycmakeargs=(
+ -DUSE_S57=ON
+ -DUSE_GARMINHOST=ON
+ -DBUNDLE_GSHHS=CRUDE
+ -DBUNDLE_TCDATA=ON
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ if use doc; then
+ dohtml -r "${S}"/../${PN}/doc/*
+ fi
+ cmake-utils_src_install
+}
+
+pkg_postinst() {
+ if use doc; then
+ einfo "Documentation is available at file:///usr/share/doc/${PF}/html/help_en_US.html"
+ fi
+}