summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2023-09-04 00:02:29 +0300
committerSam James <sam@gentoo.org>2023-10-27 03:30:38 +0100
commitb0e526eb749b52deaf3418e2384548ff294d702c (patch)
tree704398ec078dc8a0ad46365ef21f4069a2f05703 /sci-libs/HighFive
parentsci-libs/cantera: 3.0.0 version bump (diff)
downloadgentoo-b0e526eb749b52deaf3418e2384548ff294d702c.tar.gz
gentoo-b0e526eb749b52deaf3418e2384548ff294d702c.tar.bz2
gentoo-b0e526eb749b52deaf3418e2384548ff294d702c.zip
sci-libs/HighFive: new package v2.7.1 (sci-libs/cantera[hdf5] dep)
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/HighFive')
-rw-r--r--sci-libs/HighFive/HighFive-2.7.1.ebuild69
-rw-r--r--sci-libs/HighFive/Manifest1
-rw-r--r--sci-libs/HighFive/metadata.xml15
3 files changed, 85 insertions, 0 deletions
diff --git a/sci-libs/HighFive/HighFive-2.7.1.ebuild b/sci-libs/HighFive/HighFive-2.7.1.ebuild
new file mode 100644
index 000000000000..a177d45fa8d7
--- /dev/null
+++ b/sci-libs/HighFive/HighFive-2.7.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOCS_BUILDER="doxygen"
+DOCS_DIR="doc"
+
+inherit cmake docs
+
+DESCRIPTION="Header-only C++ interface for libhdf5"
+HOMEPAGE="https://github.com/BlueBrain/HighFive"
+SRC_URI="https://github.com/BlueBrain/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="Boost-1.0"
+SLOT="0"
+IUSE="mpi test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ sci-libs/hdf5[mpi?]
+ doc? ( app-doc/doxygen[dot] )
+
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ >=dev-cpp/catch-3.4.0:0
+ dev-libs/boost
+ dev-cpp/eigen
+ media-libs/opencv
+ )
+"
+
+DOCS=( {README,CHANGELOG}.md )
+
+src_prepare() {
+ default
+ sed -i -e "s/-Werror //" "${S}"/CMake/config/CompilerFlagsHelpers.cmake || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ default
+ local mycmakeargs=(
+ -DHIGHFIVE_PARALLEL_HDF5=$(usex mpi)
+
+ -DHIGHFIVE_USE_BOOST=$(usex test)
+ -DHIGHFIVE_USE_EIGEN=$(usex test)
+ -DHIGHFIVE_USE_OPENCV=$(usex test)
+ -DHIGHFIVE_USE_XTENSOR=OFF
+
+ -DHIGHFIVE_EXAMPLES=$(usex test)
+ -DHIGHFIVE_UNIT_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ default
+ use test && cmake_src_compile
+ use doc && doxygen_compile
+}
+
+src_test() {
+ # Set -j1 to prevent race
+ cmake_src_test -j1
+}
diff --git a/sci-libs/HighFive/Manifest b/sci-libs/HighFive/Manifest
new file mode 100644
index 000000000000..dec4fca0f6cb
--- /dev/null
+++ b/sci-libs/HighFive/Manifest
@@ -0,0 +1 @@
+DIST HighFive-2.7.1.tar.gz 518596 BLAKE2B e2c499ff629bf1ef5ec62baffa71624f90099179a31a085ede4a027c1747ecad7da0f4964c755e77c0825ac3ef4006ead972a3e7b59103ebaa6bd1a552f57f42 SHA512 4fbbd3898791a67e44329a5d0e20e16454b9393510236563b12fe4346cd4f2785d43d915ea05239ac1568d00651e41d85d93590f01454ffc1b82e7bba28e780a
diff --git a/sci-libs/HighFive/metadata.xml b/sci-libs/HighFive/metadata.xml
new file mode 100644
index 000000000000..988d62f71f0e
--- /dev/null
+++ b/sci-libs/HighFive/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>torokhov-s-a@yandex.ru</email>
+ <name>Sergey Torokhov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">BlueBrain/HighFive</remote-id>
+ </upstream>
+</pkgmetadata>