summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-12-15 12:53:31 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-15 12:53:31 +0100
commit36e58bd383f463bc43de82b5c0691adf7454915e (patch)
tree4626322b321f266ea537d94b1f6d0c2bbd878e76 /sci-libs/colpack/colpack-1.0.10.ebuild
parentapp-backup/bareos: bump 19.2 to 19.2.9 (diff)
downloadgentoo-36e58bd383f463bc43de82b5c0691adf7454915e.tar.gz
gentoo-36e58bd383f463bc43de82b5c0691adf7454915e.tar.bz2
gentoo-36e58bd383f463bc43de82b5c0691adf7454915e.zip
sci-libs/colpack: Remove USE="static-libs"
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/colpack/colpack-1.0.10.ebuild')
-rw-r--r--sci-libs/colpack/colpack-1.0.10.ebuild25
1 files changed, 11 insertions, 14 deletions
diff --git a/sci-libs/colpack/colpack-1.0.10.ebuild b/sci-libs/colpack/colpack-1.0.10.ebuild
index 9ba8c09a081b..b432192067c6 100644
--- a/sci-libs/colpack/colpack-1.0.10.ebuild
+++ b/sci-libs/colpack/colpack-1.0.10.ebuild
@@ -1,31 +1,29 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit autotools eutils ltprune toolchain-funcs
+inherit autotools toolchain-funcs
MYPN="ColPack"
DESCRIPTION="C++ algorithms for specialized vertex coloring problems"
-LICENSE="GPL-3 LGPL-3"
HOMEPAGE="http://cscapes.cs.purdue.edu/coloringpage/"
SRC_URI="https://github.com/CSCsw/${MYPN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3 LGPL-3"
SLOT="0"
-IUSE="openmp static-libs"
KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND=""
-DEPEND="${RDEPEND}"
+IUSE="openmp"
S="${WORKDIR}/${MYPN}-${PV}"
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
- if [[ ${MERGE_TYPE} != "binary" ]] && use openmp && [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp; then
- ewarn "You are using gcc without OpenMP"
- die "Need an OpenMP capable compiler"
- fi
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_prepare() {
@@ -36,13 +34,12 @@ src_prepare() {
src_configure() {
econf \
- --enable-shared \
- $(use_enable static-libs static) \
+ --disable-static \
$(use_enable openmp)
}
src_install() {
default
rm -rf "${ED}"/usr/examples
- use static-libs || prune_libtool_files --all
+ find "${ED}" -name '*.la' -delete || die
}