summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/mathgl/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/mathgl/files')
-rw-r--r--sci-libs/mathgl/files/mathgl-2.1.3.1-x11.patch65
1 files changed, 65 insertions, 0 deletions
diff --git a/sci-libs/mathgl/files/mathgl-2.1.3.1-x11.patch b/sci-libs/mathgl/files/mathgl-2.1.3.1-x11.patch
new file mode 100644
index 000000000000..cff27870d365
--- /dev/null
+++ b/sci-libs/mathgl/files/mathgl-2.1.3.1-x11.patch
@@ -0,0 +1,65 @@
+ CMakeLists.txt | 1 +
+ json/CMakeLists.txt | 2 +-
+ udav/CMakeLists.txt | 2 +-
+ widgets/CMakeLists.txt | 4 ++--
+ 4 files changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 3364973..0c3a645 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -316,6 +316,7 @@ endif(enable-wx)
+ if(enable-qt)
+ set(MGL_HAVE_QT 1)
+ FIND_PACKAGE(Qt4 4.8 REQUIRED QtCore QtGui QtNetwork QtWebKit)
++ FIND_PACKAGE(X11)
+ if(NOT QT4_FOUND)
+ message(SEND_ERROR "Couldn't find Qt4 library.")
+ endif(NOT QT4_FOUND)
+diff --git a/json/CMakeLists.txt b/json/CMakeLists.txt
+index 79d4716..0a53874 100644
+--- a/json/CMakeLists.txt
++++ b/json/CMakeLists.txt
+@@ -9,6 +9,6 @@ include_directories(${MathGL_BINARY_DIR}/json)
+ qt4_wrap_ui(json_ui_src MainWindow.ui)
+ qt4_wrap_cpp(json_moc_src ${json_moc_hdr} )
+ add_executable(MglForJsTestBench ${json_src} ${json_moc_src} ${json_ui_src})
+-target_link_libraries(MglForJsTestBench mgl-qt ${QT_LIBRARIES})
++target_link_libraries(MglForJsTestBench mgl-qt ${QT_LIBRARIES} ${X11_LIBRARIES})
+
+ endif(MGL_HAVE_QT)
+diff --git a/udav/CMakeLists.txt b/udav/CMakeLists.txt
+index 9a9c574..a1ff2df 100644
+--- a/udav/CMakeLists.txt
++++ b/udav/CMakeLists.txt
+@@ -27,7 +27,7 @@ qt4_add_resources(udav_rc_src ${udav_rc} )
+ qt4_wrap_cpp(udav_moc_src ${udav_moc_hdr} )
+ add_executable(udav ${udav_src} ${udav_moc_src} ${udav_rc_src})
+ #set_target_properties(udav PROPERTIES COMPILE_FLAGS "${CMAKE_CXX_FLAGS} -pthread")
+-target_link_libraries(udav mgl-qt ${QT_LIBRARIES})
++target_link_libraries(udav mgl-qt ${QT_LIBRARIES} ${X11_LIBRARIES})
+
+ if(MGL_HAVE_PTHREAD)
+ target_link_libraries(udav ${CMAKE_THREAD_LIBS_INIT})
+diff --git a/widgets/CMakeLists.txt b/widgets/CMakeLists.txt
+index 90ea00c..f582003 100644
+--- a/widgets/CMakeLists.txt
++++ b/widgets/CMakeLists.txt
+@@ -93,7 +93,7 @@ if(MGL_HAVE_QT)
+ set_target_properties(mgl-qt-static PROPERTIES CLEAN_DIRECT_OUTPUT 1)
+ set_target_properties(mgl-qt-static PROPERTIES COMPILE_FLAGS -DMGL_STATIC_DEFINE)
+ target_link_libraries(mgl-qt mgl)
+- target_link_libraries(mgl-qt ${QT_LIBRARIES})
++ target_link_libraries(mgl-qt ${QT_LIBRARIES} ${X11_LIBRARIES})
+
+ if(enable-mgl2)
+ set_target_properties(mgl-qt PROPERTIES OUTPUT_NAME "mgl2-qt")
+@@ -137,7 +137,7 @@ if(MGL_HAVE_QT AND MGL_HAVE_FLTK)
+ endif(enable-mgl2)
+
+ target_link_libraries(mgl-wnd mgl)
+- target_link_libraries(mgl-wnd ${QT_LIBRARIES})
++ target_link_libraries(mgl-wnd ${QT_LIBRARIES} ${X11_LIBRARIES})
+ # target_link_libraries(mgl-wnd ${wxWidgets_LIBRARIES})
+ target_link_libraries(mgl-wnd ${FLTK_LIBRARIES})
+