summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-10 10:54:08 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-10 11:32:41 +0200
commitd92790683390daf3d9ccfc8c11aa7b653c89d870 (patch)
tree8a05576219827866f3ef9889d0fe23b67148d21a /sci-libs/rtree
parentdev-python/shapely: Enable py3.13 (diff)
downloadgentoo-d92790683390daf3d9ccfc8c11aa7b653c89d870.tar.gz
gentoo-d92790683390daf3d9ccfc8c11aa7b653c89d870.tar.bz2
gentoo-d92790683390daf3d9ccfc8c11aa7b653c89d870.zip
sci-libs/rtree: Bump to 1.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sci-libs/rtree')
-rw-r--r--sci-libs/rtree/Manifest1
-rw-r--r--sci-libs/rtree/rtree-1.3.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sci-libs/rtree/Manifest b/sci-libs/rtree/Manifest
index 9cc4d0715929..0fac7140604c 100644
--- a/sci-libs/rtree/Manifest
+++ b/sci-libs/rtree/Manifest
@@ -1 +1,2 @@
DIST Rtree-1.0.0.tar.gz 48837 BLAKE2B 60e516155e7e48158494b7ea4720dc71ece2111fb94e320976a6dd691d2458b8586c2bf8109a37d86db211ac342d77877b435bdb54627a94c898642e8520a071 SHA512 9a414cd65b27ba35313dd7185dece83f5d7235867f6f0c72c2902d7ffd72808138dbf30d8fe11c8bbf0ec463072e5f6112d75b5fdd5a1dab7720c56d3632d576
+DIST rtree-1.3.0.tar.gz 48190 BLAKE2B 1a9ed3617ca14e3a88e5800e871e3d3edd58bc31d5dcad3c30a4a3a51b44678beacfddc1c72cbd984139e8e9acfffda45cc478857dacba5b44e7775f29ef890f SHA512 28810b769d90914e5aea9ea0b7f27b946c8d19495965696624d4fdd94c6ad462eb5ce7004d2c41e017d14a69bc913f43fdcef5293abe8504b66d8dcd5f4955a2
diff --git a/sci-libs/rtree/rtree-1.3.0.ebuild b/sci-libs/rtree/rtree-1.3.0.ebuild
new file mode 100644
index 000000000000..ff8999dbd054
--- /dev/null
+++ b/sci-libs/rtree/rtree-1.3.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN=${PN^}
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="R-Tree spatial index for Python GIS"
+HOMEPAGE="
+ https://rtree.readthedocs.io/
+ https://github.com/Toblerity/rtree/
+ https://pypi.org/project/Rtree/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ sci-libs/libspatialindex
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ dev-python/sphinx-issues
+distutils_enable_tests pytest