summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-13 18:40:29 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-13 18:40:29 +0100
commitc7c75f705d7b16117ffa3c716e77c17425225657 (patch)
treeb5e68aad886afd9eb1fb7d87b1e7a86274c7878f /sci-libs/ta-lib
parentsci-libs/gaul-devel: Port to EAPI 7 (diff)
downloadgentoo-c7c75f705d7b16117ffa3c716e77c17425225657.tar.gz
gentoo-c7c75f705d7b16117ffa3c716e77c17425225657.tar.bz2
gentoo-c7c75f705d7b16117ffa3c716e77c17425225657.zip
sci-libs/ta-lib: Port to EAPI 7
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/ta-lib')
-rw-r--r--sci-libs/ta-lib/ta-lib-0.4.0.ebuild31
1 files changed, 21 insertions, 10 deletions
diff --git a/sci-libs/ta-lib/ta-lib-0.4.0.ebuild b/sci-libs/ta-lib/ta-lib-0.4.0.ebuild
index 99cb7258bb33..7a7a581a503c 100644
--- a/sci-libs/ta-lib/ta-lib-0.4.0.ebuild
+++ b/sci-libs/ta-lib/ta-lib-0.4.0.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-AUTOTOOLS_AUTORECONF=yes
-
-inherit autotools-utils
+inherit autotools
DESCRIPTION="Technical Analysis Library for analyzing financial markets trends"
HOMEPAGE="http://www.ta-lib.org/"
@@ -14,15 +12,28 @@ SRC_URI="mirror://sourceforge/ta-lib/${P}-src.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="static-libs"
-S="${WORKDIR}"/${PN}
+S="${WORKDIR}/${PN}"
PATCHES=( "${FILESDIR}"/${P}-asneeded.patch )
-AUTOTOOLS_IN_SOURCE_BUILD=1
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
src_test() {
- ewarn "Note: this testsuite will fail without an active internet connection."
- "${S}"/src/tools/ta_regtest/ta_regtest || die "Failed testsuite."
+ src/tools/ta_regtest/ta_regtest || die
+}
+
+src_install() {
+ default
+
+ # no static archives
+ find "${D}" -name '*.la' -delete || die
}