summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKostadin Shishmanov <kocelfc@tutanota.com>2024-05-04 15:15:53 +0300
committerMichael Orlitzky <mjo@gentoo.org>2024-05-04 09:33:29 -0400
commit0d95e18ec0a35f9a6dfc582adbc8e2288928c16c (patch)
tree003e1a9a08e9da8953fc4e3de435e331b1ffb36e /sci-libs
parentsys-libs/libnvme: fix musl build (diff)
downloadgentoo-0d95e18ec0a35f9a6dfc582adbc8e2288928c16c.tar.gz
gentoo-0d95e18ec0a35f9a6dfc582adbc8e2288928c16c.tar.bz2
gentoo-0d95e18ec0a35f9a6dfc582adbc8e2288928c16c.zip
sci-libs/linbox: backport commit to fix gcc 14 build
Closes: https://bugs.gentoo.org/930923 Signed-off-by: Kostadin Shishmanov <kocelfc@tutanota.com> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/linbox/files/linbox-1.7.0-gcc14.patch433
-rw-r--r--sci-libs/linbox/linbox-1.7.0-r1.ebuild114
2 files changed, 547 insertions, 0 deletions
diff --git a/sci-libs/linbox/files/linbox-1.7.0-gcc14.patch b/sci-libs/linbox/files/linbox-1.7.0-gcc14.patch
new file mode 100644
index 000000000000..f35f1072955d
--- /dev/null
+++ b/sci-libs/linbox/files/linbox-1.7.0-gcc14.patch
@@ -0,0 +1,433 @@
+https://bugs.gentoo.org/930923
+https://github.com/linbox-team/linbox/commit/b8f2d4ccdc0af4418d14f72caf6c4d01969092a3
+https://src.fedoraproject.org/rpms/linbox/c/7389d46e81dc00dcb952b2ccbbbec3fb4fcc6c8b
+
+From c614c401386ee8db014a9be56244888f7b282a18 Mon Sep 17 00:00:00 2001
+From: Jean-Guillaume Dumas <Jean-Guillaume.Dumas@imag.fr>
+Date: Fri, 26 Jan 2024 16:31:56 +0100
+Subject: [PATCH] const_cast missing faster empty init
+
+---
+ linbox/algorithms/gauss/gauss-nullspace.inl | 10 +-
+ .../matrix/sparsematrix/sparse-ell-matrix.h | 8 +-
+ .../matrix/sparsematrix/sparse-ellr-matrix.h | 18 +--
+ linbox/ring/ntl/ntl-lzz_p.h | 11 +-
+ linbox/ring/ntl/ntl-lzz_pe.h | 143 +++++++++---------
+ linbox/ring/ntl/ntl-zz_px.h | 6 +
+ 6 files changed, 104 insertions(+), 92 deletions(-)
+
+diff --git a/linbox/algorithms/gauss/gauss-nullspace.inl b/linbox/algorithms/gauss/gauss-nullspace.inl
+index 0b70e1d7c..2d6032563 100644
+--- a/linbox/algorithms/gauss/gauss-nullspace.inl
++++ b/linbox/algorithms/gauss/gauss-nullspace.inl
+@@ -2,7 +2,7 @@
+ * Copyright (C) LinBox 2008
+ *
+ * Written by Jean-Guillaume Dumas <Jean-Guillaume.Dumas@imag.fr>
+- * Time-stamp: <27 Aug 20 15:17:09 Jean-Guillaume.Dumas@imag.fr>
++ * Time-stamp: <26 Jan 24 16:05:55 Jean-Guillaume.Dumas@imag.fr>
+ *
+ *
+ * ========LICENCE========
+@@ -104,11 +104,11 @@ namespace LinBox
+
+ Permutation<Field> P(field(),(int)Nj);
+
+- // A.write( std::cerr << "A:=", Tag::FileFormat::Maple ) << ';' << std::endl;
++// A.write( std::cerr << "A:=", Tag::FileFormat::Maple ) << ';' << std::endl;
+ this->InPlaceLinearPivoting(Rank, Det, A, P, Ni, Nj );
+
+- // P.write( std::cerr << "P:=", Tag::FileFormat::Maple ) << ';' << std::endl;
+- // A.write( std::cerr << "Ua:=", Tag::FileFormat::Maple ) << ';' << std::endl;
++// P.write( std::cerr << "P:=", Tag::FileFormat::Maple ) << ';' << std::endl;
++// A.write( std::cerr << "Ua:=", Tag::FileFormat::Maple ) << ';' << std::endl;
+
+ for(size_t i=0; i< Ni; ++i) {
+ if (A[i].size() == 0) {
+@@ -123,7 +123,7 @@ namespace LinBox
+ }
+ }
+
+- // A.write( std::cerr << "Ub:=", Tag::FileFormat::Maple ) << ';' << std::endl;
++// A.write( std::cerr << "Ub:=", Tag::FileFormat::Maple ) << ';' << std::endl;
+
+ return this->nullspacebasis(x, Rank, A, P);
+ }
+diff --git a/linbox/matrix/sparsematrix/sparse-ell-matrix.h b/linbox/matrix/sparsematrix/sparse-ell-matrix.h
+index 59006d6c5..2604f47b8 100644
+--- a/linbox/matrix/sparsematrix/sparse-ell-matrix.h
++++ b/linbox/matrix/sparsematrix/sparse-ell-matrix.h
+@@ -1210,10 +1210,10 @@ namespace LinBox
+ _colid_beg = iter._colid_beg ;
+ _colid_it = iter._colid_it ;
+ _data_it = iter._data_it ;
+- _data_beg = iter._data_beg ;
+- _data_end = iter._data_end ;
+- _field = iter._field ;
+- _ld = iter._ld ;
++ const_cast<data_it>(_data_beg) = iter._data_beg ;
++ const_cast<data_it>(_data_end) = iter._data_end ;
++ const_cast<Field &>(_field) = iter._field ;
++ const_cast<size_t&>(ld) = iter._ld ;
+ _row = iter._row ;
+
+ return *this;
+diff --git a/linbox/matrix/sparsematrix/sparse-ellr-matrix.h b/linbox/matrix/sparsematrix/sparse-ellr-matrix.h
+index 498a5525d..a60943868 100644
+--- a/linbox/matrix/sparsematrix/sparse-ellr-matrix.h
++++ b/linbox/matrix/sparsematrix/sparse-ellr-matrix.h
+@@ -1102,11 +1102,11 @@ namespace LinBox
+ _Iterator &operator = (const _Iterator &iter)
+ {
+ _data_it = iter._data_it ;
+- _data_beg = iter._data_beg ;
+- _data_end = iter._data_end ;
+- _field = iter._field ;
+- _rowid = iter._rowid;
+- _ld = iter._ld ;
++ const_cast<element_iterator>(_data_beg) = iter._data_beg ;
++ const_cast<element_iterator>(_data_end)= iter._data_end ;
++ const_cast<Field &>(_field) = iter._field ;
++ const_cast<std::vector<size_t>&>(_rowid) = iter._rowid;
++ const_cast<size_t&>(ld) = iter._ld ;
+ _row = iter._row ;
+
+ return *this;
+@@ -1252,10 +1252,10 @@ namespace LinBox
+ _colid_beg = iter._colid_beg ;
+ _colid_it = iter._colid_it ;
+ _data_it = iter._data_it ;
+- _data_beg = iter._data_beg ;
+- _data_end = iter._data_end ;
+- _field = iter._field ;
+- _ld = iter._ld ;
++ const_cast<data_it>(_data_beg) = iter._data_beg ;
++ const_cast<data_it>(_data_end) = iter._data_end ;
++ const_cast<Field &>(_field) = iter._field ;
++ const_cast<size_t&>(ld)= iter._ld ;
+ _row = iter._row ;
+
+ return *this;
+diff --git a/linbox/ring/ntl/ntl-lzz_p.h b/linbox/ring/ntl/ntl-lzz_p.h
+index 201baaa35..def3a23f7 100644
+--- a/linbox/ring/ntl/ntl-lzz_p.h
++++ b/linbox/ring/ntl/ntl-lzz_p.h
+@@ -85,7 +85,7 @@ namespace Givaro
+ * @param x reference to Integer to contain output (reference returned).
+ * @param y constant reference to field element.
+ */
+- template <>
++ template <>
+ Integer& Caster(Integer& x, const NTL::zz_p& y)
+ {
+ return x = int64_t(rep(y));
+@@ -130,7 +130,7 @@ namespace LinBox
+ typedef NTL::zz_p Element ;
+ typedef Givaro::UnparametricOperations<Element> Father_t ;
+ typedef UnparametricRandIter<NTL::zz_p> RandIter;
+-
++
+ const Element zero,one,mOne ;
+
+
+@@ -145,6 +145,11 @@ namespace LinBox
+ ,zero( NTL::to_zz_p(0)),one( NTL::to_zz_p(1)),mOne(-one)
+ {}
+
++ Element &init (Element &x) const
++ {
++ return x = NTL::to_zz_p(0);
++ }
++
+ Element& init(Element& x, const double& y) const
+ {
+ double z = fmod(y,(double)Element::modulus());
+@@ -153,7 +158,7 @@ namespace LinBox
+ return x = NTL::to_zz_p(static_cast<long>(z)); //rounds towards 0
+ }
+
+- Element &init (Element &x, const integer &y=0) const
++ Element &init (Element &x, const integer &y) const
+ {
+ NTL::ZZ tmp= NTL::to_ZZ(std::string(y).data());
+ return x = NTL::to_zz_p(tmp);
+diff --git a/linbox/ring/ntl/ntl-lzz_pe.h b/linbox/ring/ntl/ntl-lzz_pe.h
+index 60b132a06..d53444b69 100644
+--- a/linbox/ring/ntl/ntl-lzz_pe.h
++++ b/linbox/ring/ntl/ntl-lzz_pe.h
+@@ -96,18 +96,18 @@ namespace LinBox
+ NTL::zz_pE::init(irredPoly);
+ _f = irredPoly;
+ }
+-
++
+ NTL_zz_pE_Initialiser( const Integer & p, const NTL::zz_pX & f) {
+ NTL::zz_p::init((int64_t) p);
+ NTL::zz_pE::init(f);
+ _f = f;
+ }
+-
++
+ NTL_zz_pE_Initialiser(const NTL::zz_pX &f) {
+ NTL::zz_pE::init(f);
+ _f = f;
+ }
+-
++
+ const NTL::zz_pX& modulus() const {
+ return _f;
+ }
+@@ -143,22 +143,22 @@ namespace LinBox
+ NTL_zz_pE (const integer &p, const integer &k) :
+ NTL_zz_pE_Initialiser(p,k),Father_t ()
+ {
+- init(const_cast<Element &>(zero), 0);
+- init(const_cast<Element &>(one), 1);
+- init(const_cast<Element &>(mOne), p-1);
++ init(const_cast<Element &>(zero), 0);
++ init(const_cast<Element &>(one), 1);
++ init(const_cast<Element &>(mOne), p-1);
+ }
+-
++
+ NTL_zz_pE (const integer &p, const NTL::zz_pX &f) :
+ NTL_zz_pE_Initialiser(p,f), Father_t()
+ {
+ init(const_cast<Element &>(zero), 0);
+- init(const_cast<Element &>(one), 1);
+- init(const_cast<Element &>(mOne), p-1);
++ init(const_cast<Element &>(one), 1);
++ init(const_cast<Element &>(mOne), p-1);
+ }
+-
++
+ NTL_zz_pE(const NTL_zz_pE &F) :
+- NTL_zz_pE_Initialiser(F.modulus()), Father_t(),
+- zero(NTL::to_zz_pE(0)), one(NTL::to_zz_pE(1)), mOne(-one)
++ NTL_zz_pE_Initialiser(F.modulus()), Father_t(),
++ zero(NTL::to_zz_pE(0)), one(NTL::to_zz_pE(1)), mOne(-one)
+ {
+ }
+
+@@ -182,15 +182,15 @@ namespace LinBox
+
+ bool isUnit (const Element& x) const
+ {
+- if (isZero(x)) {
+- return false;
+- }
+-
+- NTL::zz_pX g, tmp;
+- tmp = NTL::conv<NTL::zz_pX>(x);
+- NTL::GCD(g, tmp, modulus());
+-
+- return g == 1;
++ if (isZero(x)) {
++ return false;
++ }
++
++ NTL::zz_pX g, tmp;
++ tmp = NTL::conv<NTL::zz_pX>(x);
++ NTL::GCD(g, tmp, modulus());
++
++ return g == 1;
+ }
+
+ bool isMOne (const Element& x) const
+@@ -207,7 +207,9 @@ namespace LinBox
+ return f;
+ }
+
+- Element & init(Element & x, integer n = 0) const
++ Element & init(Element & x) const { return x; }
++
++ Element & init(Element & x, integer n) const
+ { // assumes n >= 0.
+ int e = exponent();
+ n %= cardinality();
+@@ -215,14 +217,14 @@ namespace LinBox
+ //write(std::cout << "init-ed ", x) << std::endl;
+ return x;
+ }
+-
++
+ // documentation of NTL::conv:
+ // http://www.shoup.net/ntl/doc/conversions.txt
+ // XXX = long, ZZ, ZZ_p, ZZ_pE, ZZ_pX
+ template<class XXX>
+ Element &init(Element &x, const XXX &y) const {
+- x = NTL::conv<NTL::zz_pE>(y);
+- return x;
++ x = NTL::conv<NTL::zz_pE>(y);
++ return x;
+ }
+
+ integer & convert(integer & x, const Element & y) const
+@@ -279,81 +281,80 @@ namespace LinBox
+ x=one/x;
+ return x;
+ }
+-
++
+ Element& div(Element &x, const Element &y, const Element &z) const {
+- NTL::zz_pX g, zx;
+- conv(zx, z);
+- NTL::GCD(g, zx, modulus());
+-
+- NTL::zz_pE zg;
+- conv(zg, zx / g);
+- x = NTL::conv<NTL::zz_pE>(NTL::conv<NTL::zz_pX>(y) / g);
+- x /= zg;
+-
+- return x;
++ NTL::zz_pX g, zx;
++ conv(zx, z);
++ NTL::GCD(g, zx, modulus());
++
++ NTL::zz_pE zg;
++ conv(zg, zx / g);
++ x = NTL::conv<NTL::zz_pE>(NTL::conv<NTL::zz_pX>(y) / g);
++ x /= zg;
++
++ return x;
+ }
+-
++
+ Element& divin(Element &x, const Element &y) const {
+- Element r;
+- div(r, x, y);
+- return x = r;
++ Element r;
++ div(r, x, y);
++ return x = r;
+ }
+
+ bool isDivisor(const Element &x, const Element &y) const {
+- if (isZero(y)) {
+- return false;
+- }
+-
+- if (isUnit(y)) {
+- return true;
+- }
+-
+- NTL::zz_pX a, b;
+- conv(a, x);
+- conv(b, y);
+-
+- NTL::zz_pX ga, gb;
+- NTL::GCD(ga, a, modulus());
+- NTL::GCD(gb, b, modulus());
+-
+- NTL::zz_pX r;
+- r = ga % gb;
+- return isZero(NTL::conv<Element>(r));
++ if (isZero(y)) {
++ return false;
++ }
++
++ if (isUnit(y)) {
++ return true;
++ }
++
++ NTL::zz_pX a, b;
++ conv(a, x);
++ conv(b, y);
++
++ NTL::zz_pX ga, gb;
++ NTL::GCD(ga, a, modulus());
++ NTL::GCD(gb, b, modulus());
++ NTL::zz_pX r;
++ r = ga % gb;
++ return isZero(NTL::conv<Element>(r));
+ }
+-
++
+ Element& gcd(Element &g, const Element &a, const Element &b) const {
+ NTL::zz_pX r1, r2, x, y;
+ conv(x, a);
+ conv(y, b);
+-
++
+ NTL::GCD(r1, x, modulus());
+ NTL::GCD(r2, y, r1);
+-
++
+ return g = NTL::conv<Element>(r2);
+ }
+-
++
+ Element& gcdin(Element &a, const Element &b) const {
+ NTL::zz_pE g;
+ gcd(g, a, b);
+ return a = g;
+ }
+-
++
+ Element& dxgcd(Element &g, Element &s, Element &t, Element &u, Element &v, const Element &a, const Element &b) const {
+ NTL::zz_pX gx, sx, tx, ux, vx, ax, bx;
+ conv(ax, a);
+ conv(bx, b);
+-
++
+ NTL::XGCD(gx, sx, tx, ax, bx);
+-
++
+ ux = ax / gx;
+ vx = bx / gx;
+-
++
+ conv(g, gx);
+ conv(s, sx);
+ conv(t, tx);
+ conv(u, ux);
+ conv(v, vx);
+-
++
+ return g;
+ }
+
+@@ -364,12 +365,12 @@ namespace LinBox
+ x=NTL::to_zz_pE(tmp);
+ return is;
+ }
+-
++
+ std::ostream& write( std::ostream& os ) const
+ {
+ return os << "Polynomial quotient ring using NTL::zz_pE";
+ }
+-
++
+ std::ostream& write( std::ostream& os, const Element& x) const {
+ os << x;
+ return os;
+@@ -429,7 +430,7 @@ namespace LinBox
+ uint64_t _seed;
+ const NTL_zz_pE& _ring;
+ }; // class UnparametricRandIters
+-
++
+ } // LinBox
+
+ #endif //__LINBOX_ntl_lzz_pe_H
+diff --git a/linbox/ring/ntl/ntl-zz_px.h b/linbox/ring/ntl/ntl-zz_px.h
+index 6e7d5b2fd..340df9f95 100644
+--- a/linbox/ring/ntl/ntl-zz_px.h
++++ b/linbox/ring/ntl/ntl-zz_px.h
+@@ -104,6 +104,12 @@ namespace LinBox
+ ,_CField(cf)
+ {}
+
++ /** Initialize p to 0 */
++ Element& init( Element& p ) const
++ {
++ return p = 0;
++ }
++
+ /** Initialize p to the constant y (p = y*x^0) */
+ template <class ANY>
+ Element& init( Element& p, const ANY& y ) const
+--
+2.43.0
+
diff --git a/sci-libs/linbox/linbox-1.7.0-r1.ebuild b/sci-libs/linbox/linbox-1.7.0-r1.ebuild
new file mode 100644
index 000000000000..6f5e7d7b2b55
--- /dev/null
+++ b/sci-libs/linbox/linbox-1.7.0-r1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="C++ template library for integer and finite-field linear algebra"
+HOMEPAGE="https://linalg.org/"
+SRC_URI="https://github.com/linbox-team/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+# I think only macros/libtool.m4 (and COPYING) is GPL-2+; the source
+# headers all say LGPL-2.1
+LICENSE="GPL-2+ LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="doc opencl openmp"
+
+BDEPEND="doc? ( app-text/doxygen )"
+
+# The project README says that gmp, givaro, and blas/lapack are required
+# transitively via fflas-ffpack, but that's not true. The build system
+# checks for them, and `git grep` shows that they're used directly.
+DEPEND="dev-libs/gmp[cxx(+)]
+ =sci-libs/givaro-4.2*
+ =sci-libs/fflas-ffpack-2.5*
+ virtual/cblas
+ virtual/lapack
+ opencl? ( virtual/opencl )
+ dev-libs/ntl:=
+ sci-libs/iml
+ dev-libs/mpfr:=
+ sci-mathematics/flint"
+
+# Use mathjax to render inline latex rather than requiring a working latex
+# installation to generate bitmaps.
+RDEPEND="${DEPEND}
+ doc? ( >=dev-libs/mathjax-3 )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.0-hardened-testfails.patch
+ "${FILESDIR}"/${PN}-1.7.0-gcc14.patch
+)
+
+# The --enable-openmp flag has been removed upstream, but we don't want
+# openmp support to disappear after the package has been compiled with
+# it, so we retain the USE flag and the toolchain check.
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+
+ if use doc; then
+ # Avoid the need for a working LaTeX installation. MathJax does
+ # slow down the browser a bit but it also renders much more
+ # nicely than the latex-generated bitmaps would.
+ echo "
+ USE_MATHJAX = YES
+ MATHJAX_VERSION = MathJax_3
+ MATHJAX_RELPATH = \"${EPREFIX}/usr/share/mathjax\"
+ MATHJAX_EXTENSIONS = ams
+ " >> doc/Doxyfile.mod || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ #
+ # The --with-all flag includes,
+ #
+ # --with-givaro: used for finite fields, integer, etc. (required)
+ # --with-fflas-ffpack: small field dense linear algebra (required)
+ # --with-ntl: used for finite field, polynomial arithmetic (optional)
+ # --with-iml: used for fast integer/rational linear algebra (optional)
+ # --with-mpfr: not sure, doesn't seem to be used? (optional)
+ # --with-flint: used in algorithms/matrix-blas3 once (optional)
+ # --with-fplll: an fplll interface not directly used (optional)
+ # --with-doxygen: needed with --enable-doc to build them (optional)
+ #
+ # Some of these could be behind USE flags, but the ./configure output
+ # says that they're "not yet mandatory," which makes me think we might
+ # be overcomplicating things to make them optional right now.
+ #
+ econf \
+ --with-docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --with-all="${EPREFIX}"/usr \
+ --without-fplll \
+ --without-archnative \
+ $(use_enable doc) \
+ $(use_with opencl ocl)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+ if use doc; then
+ # These files are used for incremental doxygen builds but aren't
+ # part of the final output. Check on
+ #
+ # https://github.com/linbox-team/linbox/issues/252
+ #
+ # periodically to see if this is pointless.
+ find "${ED}/usr/share/doc/${PF}" -type f -name '*.md5' -delete || die
+ find "${ED}/usr/share/doc/${PF}" -type f -name '*.map' -delete || die
+ fi
+}