summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-08-01 09:26:16 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-08-01 09:30:08 +0200
commit1155091de323b8ccb618a774460e529688b7f748 (patch)
tree916fc873b3cadad2a4b220565dcbc980f53dbc25 /sci-libs
parentapp-emulation/qemu-guest-agent: version bump to 8.0.3 (diff)
downloadgentoo-1155091de323b8ccb618a774460e529688b7f748.tar.gz
gentoo-1155091de323b8ccb618a774460e529688b7f748.tar.bz2
gentoo-1155091de323b8ccb618a774460e529688b7f748.zip
sci-libs/caffe2: prefixify (by ZongyuZ)
Bug: https://bugs.gentoo.org/911421 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/caffe2/caffe2-2.0.1-r3.ebuild (renamed from sci-libs/caffe2/caffe2-2.0.1-r2.ebuild)16
1 files changed, 15 insertions, 1 deletions
diff --git a/sci-libs/caffe2/caffe2-2.0.1-r2.ebuild b/sci-libs/caffe2/caffe2-2.0.1-r3.ebuild
index b8f88ae63e41..29087a44643f 100644
--- a/sci-libs/caffe2/caffe2-2.0.1-r2.ebuild
+++ b/sci-libs/caffe2/caffe2-2.0.1-r3.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
-inherit python-single-r1 cmake cuda flag-o-matic
+inherit python-single-r1 cmake cuda flag-o-matic prefix
MYPN=pytorch
MYP=${MYPN}-${PV}
@@ -97,6 +97,20 @@ src_prepare() {
pushd torch/csrc/jit/serialization || die
flatc --cpp --gen-mutable --scoped-enums mobile_bytecode.fbs || die
popd
+ # prefixify the hardcoded paths, after all patches are applied
+ hprefixify \
+ aten/CMakeLists.txt \
+ caffe2/CMakeLists.txt \
+ cmake/Metal.cmake \
+ cmake/Modules/*.cmake \
+ cmake/Modules_CUDA_fix/FindCUDNN.cmake \
+ cmake/Modules_CUDA_fix/upstream/FindCUDA/make2cmake.cmake \
+ cmake/Modules_CUDA_fix/upstream/FindPackageHandleStandardArgs.cmake \
+ cmake/public/LoadHIP.cmake \
+ cmake/public/cuda.cmake \
+ cmake/Dependencies.cmake \
+ torch/CMakeLists.txt \
+ CMakeLists.txt
}
src_configure() {