summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-07 07:55:40 +0100
committerSam James <sam@gentoo.org>2022-05-15 01:00:18 +0000
commit15543328d83583166e912e58036079ba7e0431db (patch)
tree3d09ca03d393ea77989aa5a09b03726eebd219aa /sci-libs
parentsci-libs/rocSPARSE: egrep -> grep -E (diff)
downloadgentoo-15543328d83583166e912e58036079ba7e0431db.tar.gz
gentoo-15543328d83583166e912e58036079ba7e0431db.tar.bz2
gentoo-15543328d83583166e912e58036079ba7e0431db.zip
sci-libs/hipSPARSE: egrep -> grep -E
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/hipSPARSE/hipSPARSE-4.3.0-r2.ebuild2
-rw-r--r--sci-libs/hipSPARSE/hipSPARSE-5.0.2.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/sci-libs/hipSPARSE/hipSPARSE-4.3.0-r2.ebuild b/sci-libs/hipSPARSE/hipSPARSE-4.3.0-r2.ebuild
index 9498143b5003..1a75d379785e 100644
--- a/sci-libs/hipSPARSE/hipSPARSE-4.3.0-r2.ebuild
+++ b/sci-libs/hipSPARSE/hipSPARSE-4.3.0-r2.ebuild
@@ -65,7 +65,7 @@ src_prepare() {
ebegin "$(tc-getCXX) deps/convert.cpp -o deps/convert"
$(tc-getCXX) deps/convert.cpp -o deps/convert
eend $?
- find "${WORKDIR}" -maxdepth 2 -regextype egrep -regex ".*/(.*)/\1\.mtx" -print0 |
+ find "${WORKDIR}" -maxdepth 2 -regextype grep -E -regex ".*/(.*)/\1\.mtx" -print0 |
while IFS= read -r -d '' mtxfile; do
destination=${BUILD_DIR}/clients/matrices/$(basename -s '.mtx' ${mtxfile}).bin
ebegin "Converting ${mtxfile} to ${destination}"
diff --git a/sci-libs/hipSPARSE/hipSPARSE-5.0.2.ebuild b/sci-libs/hipSPARSE/hipSPARSE-5.0.2.ebuild
index 7ce5fdc224c8..3b9e1f762bd7 100644
--- a/sci-libs/hipSPARSE/hipSPARSE-5.0.2.ebuild
+++ b/sci-libs/hipSPARSE/hipSPARSE-5.0.2.ebuild
@@ -65,7 +65,7 @@ src_prepare() {
ebegin "$(tc-getCXX) deps/convert.cpp -o deps/convert"
$(tc-getCXX) deps/convert.cpp -o deps/convert
eend $?
- find "${WORKDIR}" -maxdepth 2 -regextype egrep -regex ".*/(.*)/\1\.mtx" -print0 |
+ find "${WORKDIR}" -maxdepth 2 -regextype grep -E -regex ".*/(.*)/\1\.mtx" -print0 |
while IFS= read -r -d '' mtxfile; do
destination=${BUILD_DIR}/clients/matrices/$(basename -s '.mtx' ${mtxfile}).bin
ebegin "Converting ${mtxfile} to ${destination}"