summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSv. Lockal <lockalsash@gmail.com>2024-07-20 17:26:46 +0000
committerSam James <sam@gentoo.org>2024-09-09 19:15:15 +0100
commit5eef57ad9c2ee2dce41ebccc5e8a4f95731e26d6 (patch)
treeeee4dc9870d0ea102771666980a863acc5b7fb5f /sci-libs
parentsci-libs/hipRAND: strip unsupported flags for potentially switched compiler (diff)
downloadgentoo-5eef57ad9c2ee2dce41ebccc5e8a4f95731e26d6.tar.gz
gentoo-5eef57ad9c2ee2dce41ebccc5e8a4f95731e26d6.tar.bz2
gentoo-5eef57ad9c2ee2dce41ebccc5e8a4f95731e26d6.zip
sci-libs/hipSOLVER: strip unsupported flags for potentially switched compiler
Bug: https://bugs.gentoo.org/936099 Signed-off-by: Sv. Lockal <lockalsash@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/hipSOLVER/hipSOLVER-6.1.1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sci-libs/hipSOLVER/hipSOLVER-6.1.1.ebuild b/sci-libs/hipSOLVER/hipSOLVER-6.1.1.ebuild
index be450babaed3..99c4a9c0ca41 100644
--- a/sci-libs/hipSOLVER/hipSOLVER-6.1.1.ebuild
+++ b/sci-libs/hipSOLVER/hipSOLVER-6.1.1.ebuild
@@ -36,6 +36,8 @@ PATCHES=(
)
src_configure() {
+ rocm_use_hipcc
+
local mycmakeargs=(
-DAMDGPU_TARGETS="$(get_amdgpu_flags)"
-DBUILD_FILE_REORG_BACKWARD_COMPATIBILITY=OFF
@@ -43,5 +45,5 @@ src_configure() {
-DBUILD_WITH_SPARSE=$(usex sparse ON OFF)
)
- CXX=hipcc cmake_src_configure
+ cmake_src_configure
}