summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-10-02 14:32:46 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-10-02 14:58:37 +0200
commit916960e6b70b9d89d19cd9602a4b610d8597c3a5 (patch)
tree613b965f717662d6f242b2753a459f7e3289228d /sci-libs
parentapp-text/poppler: 21.10.0 version bump (diff)
downloadgentoo-916960e6b70b9d89d19cd9602a4b610d8597c3a5.tar.gz
gentoo-916960e6b70b9d89d19cd9602a4b610d8597c3a5.tar.bz2
gentoo-916960e6b70b9d89d19cd9602a4b610d8597c3a5.zip
sci-libs/gdal: Fix build with app-text/poppler-21.10.0
Package-Manager: Portage-3.0.26, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/gdal/files/gdal-3.3.2-poppler-21.10.0.patch32
-rw-r--r--sci-libs/gdal/gdal-3.3.2.ebuild1
2 files changed, 33 insertions, 0 deletions
diff --git a/sci-libs/gdal/files/gdal-3.3.2-poppler-21.10.0.patch b/sci-libs/gdal/files/gdal-3.3.2-poppler-21.10.0.patch
new file mode 100644
index 000000000000..a727d21dab64
--- /dev/null
+++ b/sci-libs/gdal/files/gdal-3.3.2-poppler-21.10.0.patch
@@ -0,0 +1,32 @@
+From 9c09870e374ca21d558101af3f4c09a6164fdfc3 Mon Sep 17 00:00:00 2001
+From: Even Rouault <even.rouault@spatialys.com>
+Date: Sun, 26 Sep 2021 22:49:52 +0200
+Subject: [PATCH] Fix build against Poppler master
+
+---
+ frmts/pdf/pdfdataset.cpp | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/frmts/pdf/pdfdataset.cpp b/frmts/pdf/pdfdataset.cpp
+index 9c4c28a6572..50a8154c756 100644
+--- a/frmts/pdf/pdfdataset.cpp
++++ b/frmts/pdf/pdfdataset.cpp
+@@ -5012,7 +5012,7 @@ PDFDataset *PDFDataset::Open( GDALOpenInfo * poOpenInfo )
+ #ifdef HAVE_POPPLER
+ if (bUseLib.test(PDFLIB_POPPLER))
+ {
+- GooString* poMetadata = poCatalogPoppler->readMetadata();
++ auto poMetadata = poCatalogPoppler->readMetadata();
+ if (poMetadata)
+ {
+ #if (POPPLER_MAJOR_VERSION >= 1 || POPPLER_MINOR_VERSION >= 72)
+@@ -5026,7 +5026,9 @@ PDFDataset *PDFDataset::Open( GDALOpenInfo * poOpenInfo )
+ const char * const apszMDList[2] = { pszContent, nullptr };
+ poDS->SetMetadata(const_cast<char**>(apszMDList), "xml:XMP");
+ }
++#if (POPPLER_MAJOR_VERSION < 21 || (POPPLER_MAJOR_VERSION == 21 && POPPLER_MINOR_VERSION <= 9))
+ delete poMetadata;
++#endif
+ }
+
+ /* Read Info object */
diff --git a/sci-libs/gdal/gdal-3.3.2.ebuild b/sci-libs/gdal/gdal-3.3.2.ebuild
index 5a7c010cdbfd..216917c266d1 100644
--- a/sci-libs/gdal/gdal-3.3.2.ebuild
+++ b/sci-libs/gdal/gdal-3.3.2.ebuild
@@ -89,6 +89,7 @@ PATCHES=(
"${FILESDIR}/${PN}-2.2.3-soname.patch"
"${FILESDIR}/${PN}-2.3.0-curl.patch" # bug 659840
"${FILESDIR}/${PN}-3.3.0-libdir.patch"
+ "${FILESDIR}/${P}-poppler-21.10.0.patch"
)
src_prepare() {