summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-05-19 14:21:37 +0200
committerAlfredo Tupone <tupone@gentoo.org>2022-05-19 14:21:37 +0200
commit9a42cd8464b298ba349f0f3a4f49d965412df85c (patch)
treeb42ed884f942b31d17d778d0baa6ceef309f16aa /sci-libs
parentapp-emulation/qemu: forward ~loong (diff)
downloadgentoo-9a42cd8464b298ba349f0f3a4f49d965412df85c.tar.gz
gentoo-9a42cd8464b298ba349f0f3a4f49d965412df85c.tar.bz2
gentoo-9a42cd8464b298ba349f0f3a4f49d965412df85c.zip
sci-libs/onnx: add to tree
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/onnx/Manifest1
-rw-r--r--sci-libs/onnx/metadata.xml11
-rw-r--r--sci-libs/onnx/onnx-1.11.0.ebuild29
3 files changed, 41 insertions, 0 deletions
diff --git a/sci-libs/onnx/Manifest b/sci-libs/onnx/Manifest
new file mode 100644
index 000000000000..7ff467655359
--- /dev/null
+++ b/sci-libs/onnx/Manifest
@@ -0,0 +1 @@
+DIST onnx-1.11.0.tar.gz 9464979 BLAKE2B dfc8ab81d4776f806fa26c751c1eb1e19ea4cf9f0aa498880dc18eca160fdd9c43eda0077124ea7a674082e5ed93de7497411c48c3f9a12146905072e6477af6 SHA512 dc7045702188d7f40fead3ab6eccd8ff63357824c36873b415ad989d19aa952ff2c3758120de9050d84d92a35993198971be54ffa8e8d99fc70aa1b14b2ff73e
diff --git a/sci-libs/onnx/metadata.xml b/sci-libs/onnx/metadata.xml
new file mode 100644
index 000000000000..2a58de7a87a9
--- /dev/null
+++ b/sci-libs/onnx/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">onnx/onnx</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/onnx/onnx-1.11.0.ebuild b/sci-libs/onnx/onnx-1.11.0.ebuild
new file mode 100644
index 000000000000..8a650bee773f
--- /dev/null
+++ b/sci-libs/onnx/onnx-1.11.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit cmake
+
+DESCRIPTION="Open Neural Network Exchange (ONNX)"
+HOMEPAGE="https://github.com/onnx/onnx"
+SRC_URI="https://github.com/onnx/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ dev-libs/protobuf"
+BDEPEND="dev-util/patchelf"
+
+src_install() {
+ cmake_src_install
+
+ patchelf --set-soname libonnxifi.so "${D}"/usr/lib/libonnxifi.so \
+ || die
+ mv "${D}"/usr/lib/libonnxifi.so "${D}"/usr/$(get_libdir)/libonnxifi.so \
+ || die
+}