summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-11-14 10:55:52 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-11-14 10:56:17 +0100
commite56830faba292decabfbe0f1df56967eb840d21c (patch)
treefdab748222332c7e68a07cacdb52680293c99e4d /sci-libs
parentsci-libs/caffe2: add 2.5.1 (diff)
downloadgentoo-e56830faba292decabfbe0f1df56967eb840d21c.tar.gz
gentoo-e56830faba292decabfbe0f1df56967eb840d21c.tar.bz2
gentoo-e56830faba292decabfbe0f1df56967eb840d21c.zip
sci-libs/pytorch: add 2.5.1
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/pytorch/Manifest1
-rw-r--r--sci-libs/pytorch/files/pytorch-2.5.1-dontbuildagain.patch17
-rw-r--r--sci-libs/pytorch/files/pytorch-2.5.1-setup.patch10
-rw-r--r--sci-libs/pytorch/files/pytorch-2.5.1-torch_shm_manager.patch11
-rw-r--r--sci-libs/pytorch/pytorch-2.5.1.ebuild62
5 files changed, 101 insertions, 0 deletions
diff --git a/sci-libs/pytorch/Manifest b/sci-libs/pytorch/Manifest
index df910a695333..4564491a43b5 100644
--- a/sci-libs/pytorch/Manifest
+++ b/sci-libs/pytorch/Manifest
@@ -1,2 +1,3 @@
DIST pytorch-2.4.0.tar.gz 115031093 BLAKE2B d206477963977011627df284efa01482fbf57e9fcb5f58f51d679c742b8e5dde6aa6affd8745ab817fcd09477d129a81e74e07be576b5d3585eaca1c735b8e01 SHA512 804d25944035f33de6591fd942fbda44d3de037717a4397d38a97474b01775d30eaf93d16dd708a832c0119050d24d73b90990fd3e3773be79d26ada25244d22
DIST pytorch-2.4.1.tar.gz 115029469 BLAKE2B c2909ff27d527bc57cba56b780d3b8cd07a043ab045caa6c6b27857a16f9ad10aaab2116b26226b1e46ee08ffb44007965d914464418e4ae14ca48c3f3f383bb SHA512 7e9b4485e242eaf0d648765c6621d73d95e7107b766646a098175436d1ab2e2b864badd0757a3bab6b7c318233f2120bad9ac07b39bb9e357897919580c87631
+DIST pytorch-2.5.1.tar.gz 116091366 BLAKE2B 7838b17562b94ffc7d798031348689db607dd5eae2a3c35be365972e2b52a2c1b12067068d5aca5ab00cf0977d9c2c3c9ae5337d69534c864c732e6256cbeef6 SHA512 a913a466324a65fa3d79c5e9ad4d605fc7976f0134fda2f81aaa3cea29d56926604999b8a238759646d211e63b47bbb446cdffa86ca8defd8159f11e30301289
diff --git a/sci-libs/pytorch/files/pytorch-2.5.1-dontbuildagain.patch b/sci-libs/pytorch/files/pytorch-2.5.1-dontbuildagain.patch
new file mode 100644
index 000000000000..3a3d24e155d9
--- /dev/null
+++ b/sci-libs/pytorch/files/pytorch-2.5.1-dontbuildagain.patch
@@ -0,0 +1,17 @@
+--- a/setup.py
++++ b/setup.py
+@@ -470,14 +470,6 @@
+ check_submodules()
+ check_pydep("yaml", "pyyaml")
+ build_python = not BUILD_LIBTORCH_WHL
+- build_caffe2(
+- version=version,
+- cmake_python_library=cmake_python_library,
+- build_python=build_python,
+- rerun_cmake=RERUN_CMAKE,
+- cmake_only=CMAKE_ONLY,
+- cmake=cmake,
+- )
+
+ if CMAKE_ONLY:
+ report(
diff --git a/sci-libs/pytorch/files/pytorch-2.5.1-setup.patch b/sci-libs/pytorch/files/pytorch-2.5.1-setup.patch
new file mode 100644
index 000000000000..10052a65c939
--- /dev/null
+++ b/sci-libs/pytorch/files/pytorch-2.5.1-setup.patch
@@ -0,0 +1,10 @@
+--- a/setup.py 2023-02-14 19:34:56.327571750 +0100
++++ b/setup.py 2023-02-14 19:35:31.073020464 +0100
+@@ -238,6 +238,7 @@
+ import setuptools.command.sdist
+ from setuptools import Extension, find_packages, setup
+ from setuptools.dist import Distribution
++sys.path[:0] = os.getcwd()
+ from tools.build_pytorch_libs import build_caffe2
+ from tools.generate_torch_version import get_torch_version
+ from tools.setup_helpers.cmake import CMake
diff --git a/sci-libs/pytorch/files/pytorch-2.5.1-torch_shm_manager.patch b/sci-libs/pytorch/files/pytorch-2.5.1-torch_shm_manager.patch
new file mode 100644
index 000000000000..5d7902b9bef7
--- /dev/null
+++ b/sci-libs/pytorch/files/pytorch-2.5.1-torch_shm_manager.patch
@@ -0,0 +1,11 @@
+--- a/torch/__init__.py
++++ b/torch/__init__.py
+@@ -1951,7 +1951,7 @@
+ return path.encode("utf-8")
+
+
+-_C._initExtension(_manager_path())
++_C._initExtension(b"/usr/bin/torch_shm_manager")
+
+ del _manager_path
+
diff --git a/sci-libs/pytorch/pytorch-2.5.1.ebuild b/sci-libs/pytorch/pytorch-2.5.1.ebuild
new file mode 100644
index 000000000000..1a5e4c9a039f
--- /dev/null
+++ b/sci-libs/pytorch/pytorch-2.5.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_EXT=1
+inherit distutils-r1 prefix
+
+DESCRIPTION="Tensors and Dynamic neural networks in Python"
+HOMEPAGE="https://pytorch.org/"
+SRC_URI="https://github.com/pytorch/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+RDEPEND="
+ ${PYTHON_DEPS}
+ ~sci-libs/caffe2-${PV}[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ ')
+"
+DEPEND="${RDEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ ')
+"
+
+src_prepare() {
+ eapply \
+ "${FILESDIR}"/${P}-dontbuildagain.patch \
+ "${FILESDIR}"/${P}-setup.patch
+
+ # Set build dir for pytorch's setup
+ sed -i \
+ -e "/BUILD_DIR/s|build|/var/lib/caffe2/|" \
+ tools/setup_helpers/env.py \
+ || die
+ distutils-r1_src_prepare
+
+ hprefixify tools/setup_helpers/env.py
+}
+
+python_compile() {
+ PYTORCH_BUILD_VERSION=${PV} \
+ PYTORCH_BUILD_NUMBER=0 \
+ USE_SYSTEM_LIBS=ON \
+ CMAKE_BUILD_DIR="${BUILD_DIR}" \
+ distutils-r1_python_compile develop sdist
+}
+
+python_install() {
+ USE_SYSTEM_LIBS=ON distutils-r1_python_install
+}